Archer C7 Auto-negotiation port speed failure

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C7 Auto-negotiation port speed failure

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C7 Auto-negotiation port speed failure
Archer C7 Auto-negotiation port speed failure
2018-08-12 03:24:02
Model :

Hardware Version :

Firmware Version :

ISP :

I'm running a TP-Link Archer C7 router, w/ the firmware 3.15.3 Build 180114 Release 39265n. My ISP is cable, I have their Technicolor TC4310 cable modem connected to the Internet port on the C7. Both the Modem and the C7 doc claim to have 10/100/1000M Auto-negotiation ports. My ISP provides 200Mbps and I've confirmed this with one of my laptops (only) connected directly to the cable modem output port. When I connect the cable modem to the Internet input port on the C7 (and reboot everything) the highest speed I can get at any output port of the C7 is 100Mbps. It would seem that the Auto-negotiation of port speed on the C7 is stuck at no higher than 100Mbps. Logged into the C7 I can find nowhere to manually configure the port speeds.
Has anyone else experienced this issue? Any ideas?
  0      
  0      
#1
Options
1 Reply
Re:Archer C7 Auto-negotiation port speed failure
2018-08-16 04:40:06
Have not experienced this.

Try a different cable between router and modem.
Is IPv6 support turned on and working (check with something like https://test-ipv6.com/)
Is NAT Boost enabled?

Short of that I would recommend contacting TP-Link support and open a ticket.

Good luck.
  0  
  0  
#2
Options

Information

Helpful: 0

Views: 2268

Replies: 1