HS200 plugs keep disconnecting every day or 2

HS200 plugs keep disconnecting every day or 2
HS200 plugs keep disconnecting every day or 2
2019-03-07 02:24:17
Model: HS200
Hardware Version: V1
Firmware Version: 1.2.5

I've been having problems with my switches for the past month where they keep disconnecting.  Actually, not disconnecting but refusing connections.  I know they arent disconnected since I can still ping them and see them on the netwokr but trying to control them via the kasa app shows they are offline.

 

If I try and control them directly I get 

 

"Error: read ECONNRESET"

 

I was also getting "Error: connect ECONNREFUSED" the other day.

 

The only way to bring them back is to physically press the reboot button.

 

This is happening to 3 devices at the right now.

0
0
#1
Options
6 Replies
Re:HS200 plugs keep disconnecting every day or 2
2019-03-07 17:50:08

@Scott.St 

 

 

Scott, 

 

I'm not sure about that error,  Can you provide a screenshot so we can see how its displayed and provide it to our software team for investigation?

 

 

thank you 

0
0
#2
Options
Re:Re:HS200 plugs keep disconnecting every day or 2
2019-06-11 05:54:45 - last edited 2019-06-11 06:06:27

I just saw this post and I've been having the same problems too.  My KP200 dual wifi outlet keeps disconnecting every couple of days.  I thought it was my wifi router.  So I ended up buying a synology MR2200.  I have had no issues with any other device in the house including the TPlink HS103P2 mini plugs.

 

My setup:

Synology MR2200 - never had to reboot unit (router is sitting 2 feet away from the KP200 outlet)

KP200 (1 unit)

HS103P2 (2 units)

No outages/brownouts (I have solar panels + 2 lithium battery packs)

 

The ONLY way I can get the KP200 working again is by doing a complete reset.  Is there a resolution?

 

Please advise

0
0
#3
Options
Re:Re:HS200 plugs keep disconnecting every day or 2
2019-08-16 00:01:14

I am having the exact same issue.    It seems to be common issue.   Can we get some fix / solution posted?

0
0
#4
Options
Re:HS200 plugs keep disconnecting every day or 2
2020-01-02 17:10:02

I'm having the same issue as well.  Tried changing my WiFi channel, but it didn't help.

0
0
#5
Options
Re:HS200 plugs keep disconnecting every day or 2
2020-01-19 06:28:52

@Carl I’m having the same issue (as many others apparently). Can TP-Link come up with a solution to fix this so I don’t have to return my switches?

0
0
#6
Options
Re:HS200 plugs keep disconnecting every day or 2
3 weeks ago

@MikeD20855 

 

And anyone else having this issue.  Please send us screenshots of any error codes you seem to be having.  We would need this to avoid legnthy back and fourths with our dev team. 

0
0
#7
Options