Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)

Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-11 21:57:17
Model: Archer C9
Hardware Version: V1
Firmware Version: 20180125-rel56387

Hi all,

Any suggestions here?  I have an Archer C9 (v1) AC1900 running the latest (2018) firmware from this page: https://www.tp-link.com/us/support/download/archer-c9/v1/#Firmware

 

I just signed up/set up Centurylink's Gigabit Fiber.

 

I can't get my router to connect over PPPoE.  It works fine if I use the router CenturyLink gave me, a Zyxel C3000Z.  But with my Archer C9, it just infinitely tries to connect. 

I have my PPPoE username/password (lastnamefirstname###@centurylink.net).  I got it from calling CenturyLink.


Some googling says perhaps I need to set VLAN ID to 201, but that setting doesn't exist on my router.  I followed this guide: https://www.tp-link.com/us/support/faq/1584/ , but there is no "IPTV" setting on the left hand side.


Any ideas?

0
0
#1
Options
10 Replies
Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-12 19:39:45

@Praxis 

 

It looks like your DSL modem is also a router. You will still need the Zyxel as it pulls the internet from the DSL line, you would then connect your TP-Link router to the Zyxel. 

 

Customers would typically set their modem to bridge mode so it just passes the internet connection through it, and then set up the PPPoE login info on the router which it will then receive internet.

 

Here is a FAQ that shows a setup with a DSL modem: https://www.tp-link.com/us/support/faq/713/

0
0
#2
Options
Re:Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-12 19:45:27

Tony wrote

@Praxis 

 

It looks like your DSL modem is also a router. You will still need the Zyxel as it pulls the internet from the DSL line, you would then connect your TP-Link router to the Zyxel. 

 

Customers would typically set their modem to bridge mode so it just passes the internet connection through it, and then set up the PPPoE login info on the router which it will then receive internet.

 

Here is a FAQ that shows a setup with a DSL modem: https://www.tp-link.com/us/support/faq/713/

 

Hi Tony,

 

I appreciate the reply, but this is not correct.  There is no DSL modem involved.  As I said, I am using fiber.  No DSL modem involved.  

 

The Zyxel is just connecting via PPPoE.  I should be able to replicate this on my Archer C9.  I think the issue is that I need to also set VLAN tagging, but I can't find that option on my Archer C9 v1.

0
0
#3
Options
Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-13 22:06:34 - last edited 2019-10-14 15:41:01

@Praxis 

 

Going back really quick to the IPTV. You should find that by logging into the TP-Link router and going to Advanced > Network > IPTV. You can set the following VLAN numbers, make sure to check 802.1Q Tag to the right.

 

 

If that does not work, you can try changing the configuration of the Zyxel to be a bridging device. Here is a link to the process it shows how, under transparent bridging. This involves modifying your ISP device so it would be best to contact them to see if it is possible to do that to avoid any issues:

 

https://www.centurylink.com/home/help/internet/modems-and-routers/zyxel-c3000z/access-advanced-setup/wan-settings.html

0
0
#4
Options
Re:Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-13 22:43:58
Hi Tony, This is the same screenshot from the article I linked to in my original post. This is my whole problem- there is no IPTV setting. I see Internet and LAN. But there is no IPTV option under Advanced > Network. This is the entire problem I mentioned in my original post. How do I get that option to show up?
0
0
#5
Options
Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-13 23:02:27

@Praxis 

 

Please provide a screenshot of what you are seeing.

0
0
#6
Options
Re:Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-06-13 23:22:18
I'll have to do so after I get home, but it's pretty much the exact same screen, there's just no IPTV option on the left hand side under LAN.
0
0
#7
Options
Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-07-03 17:26:57

Any ideas?

0
0
#8
Options
Re:Re:Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-07-03 17:40:34

@Praxis 

 

Please provide the screenshots of what you are seeing.

0
0
#9
Options
Re:Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-07-19 17:48:38

I was able to change mine to IPTV

File:
Screenshot_20190719-134632_Samsung Internet.jpgDownload
0
0
#10
Options
Re:Re:Archer C9 can't connect over PPPoE to Centurylink (Gigabit Fiber)
2019-10-12 00:06:35 - last edited 2019-10-12 00:08:35

@Praxis  I had same problem with TP-Link Archer A7:  the PPPoE auth to CenturyLink would not work. Solution was indeed to enter the VLAN settings that are found in the picture in this thread.

I found the settings here in the admin console:

- Advanced (top tab)

- Network (left nav)

- IPTV/VLAN (sub left nav)

Then, following the picture found in this thread, I changed these settings:

- checked Enable IPTV/VLAN

- Mode = Custom
- Internet VLAN ID = 201
- IP-Phone VLAN ID = 202
- IPTV VLAN ID = 203

- Also checked "802.1Q Tag"
 

Then it worked! Glad I found this thread.

 

0
0
#11
Options