Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band

Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2019-07-20 03:44:01

My PC which uses a TP Link Archer T8E PCI wifi card only connects to my deco M9 mesh network via the 2.4 GHz on wireless-N. How can I force it to the 5 GHz band?

 

I cannot turn the 2.4GHz band off because things like security cameras and other smart home accessories only operate on that band. I am only getting ~150 mbps down when I should be getting 500+ on 5GHz.

 

What can I do?

0
0
#1
Options
7 Reply
Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2019-07-22 16:41:06

@ag11600 

 

If you go to your adapter connection status what is the link speed you are getting?

 

You can try to set a preference to 5GHz networks in the properties of your adapter

 

As far as the Deco unit you can set the connected computer as a high priority device by going into your devices list.

 

The Deco will place the unit on a wireless band depending on how much demand is needed, should the computer need additional speed it will be moved to hte 5GHz so you will not stay on the 2.4GHz as more speed is needed.

0
0
#2
Options
Re:Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2019-07-22 17:45:40 - last edited 2019-07-22 17:46:30

Hi Tony,

 

It doesn't seem I have the same set of options. I have the latest driver version for the T8E 6.30.223.228. I'm also getting 400mbps (wireless N) speeds. 

 

0
0
#3
Options
Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2019-07-23 15:41:29

@ag11600 

 

Go into your router settings in your Deco app and enable the guest network, with the guest network enabled you can disable the 2.4Ghz so only 5GHz is active. You wont be able to communicate with other devices on the Deco network with it being a guest network, but you should get the 5GHz you want to be connected to.

0
0
#4
Options
Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2020-10-07 21:53:14 - last edited 2020-10-07 21:55:45

@Tony Do you know how to set a preferred band, similar to the screenshots above, on Mac OS? Also, is there a way to upvote the feature request to add to M9 the ability to force a specific band per device? That would solve this problem for everyone.

 

(The guest network workaround is a last resort for me because I really need access to my network assets from the computer that keeps switching over to 2.4ghz.)

 

Thanks for your help!

0
0
#5
Options
Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2020-10-08 20:42:39

@rhs 

 

From what I have found the general consensus is to separate the wireless networks. Since you are not able to on a Deco you may need to utilize the guest network in have the guest network host the 2.4G or 5G.

0
0
#6
Options
Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2020-10-08 21:49:45

@Tony But is there a way to 1) submit a feature request, and 2) vote for feature requests posted by others?

0
0
#7
Options
Re:Computer (TP Link Archer T8E) only connecting to Deco M9 Plus via 2.4 GHz band
2020-10-09 17:39:57

@rhs 

 

Anytime a user posts a feature request we forward that. Please note that does not mean it is guaranteed to be implemented as they are all submitted for consideration.

0
0
#8
Options