AC4000/Archer A20: Slow Ethernet Speeds

AC4000/Archer A20: Slow Ethernet Speeds
AC4000/Archer A20: Slow Ethernet Speeds
2020-01-02 01:32:50
Model: Archer A20
Hardware Version: V1
Firmware Version: 1.1.1 Build 20191026 rel.10453(5553)

Hi,

 

I've been trying to understand why I'm not seeing full  upload and download speeds since upgrading from an Airport Extreme base station/router, to the TP-Link Archer A20. We have 1Gb fiber to our house. Typically, I'd see download speeds from 700mbps down to 350-400mbps depending on network conditions. We usually see upload of 900mbps+. These are speedtest.net readings.

 

Since the A20 came into the picture, we're seeing ~200mbps down, and abou 100mbps up. When I plug directly into the fiber modem (Zyxel C1100Z) from my desktop computer, I see the speed I expect. When I hardwire or go over 5Ghz wifi, we see the reduced speed. I've checked FW upgrade, I've restarted/rebooted the router. Nothing seems to work. 

 

I've also swapped out cables. I have one cable I used to directly hardwire my desktop to the fiber modem. Used this same cable to plug the Archer A20 into the fiber modem. No improvement. I used the same cable to plug my desktop into the A20. No improvement. Only configuration that gets me to "full speed" is to bypass the A20 completely and go into the fiber modem. This wasnt the case previously with my Airport Extreme router in the same configuration with same cabling...

 

Any ideas?

0
0
#1
Options
9 Replies
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-01-02 01:41:47
I should add that the speedtest embedded in the A20's http-based setup and management interface reports roughly the same speed Im getting via speedtest on my desktop.
1
1
#2
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-01-05 18:03:10

Looks like this is QoS-related. I can find no ability to globally turn off QoS. I had to manually set the QoS bandwidth for up and down to very high numbers, and my speed tests now look appropriate. Can the next firmware version for the A20 include an Off option for QoS?

2
2
#3
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-01-07 00:09:19

@JRice 

 

Thank you for pointing that out.

 

I have seen that related to the Deco as far as needing to update the QoS speeds.

 

There aren't any plans to have an option to disable QoS, but I can pass that as a feature request.

1
1
#4
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-04-30 06:07:40

@Tony Is there a reason to not have the ability to disable QoS on A20? We won't have NAT boost if it's on, right?

1
1
#5
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-04-30 21:59:45

@ReddJim 

 

Correct, you can only have one or the other.

0
0
#6
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-06-27 22:56:15

I'm having a very similar issue. When I connect my modem to my A20, any client connected to the router (wired or wireless) reports speeds in the 70-90Mbps range. And I get the same speed when running a speedtest in the router software itself. 

 

When I connect my modem directly to my PC and run a speedtest, I get speeds in the 215-250Mbps range. What gives? I've heard that turning QoS off could fix issues like this, but apparently there's no way to turn it off in this router? @JRice what settings in the router software did you change to fix your issue?

0
0
#7
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
2020-07-13 02:11:56

@OldSenileGuy I have this exact same problem. Did you ever get it resolved?

0
0
#8
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
a week ago

same problem here with no solution by support so far. 

0
0
#9
Options
Re:AC4000/Archer A20: Slow Ethernet Speeds
a week ago
Have you run the SPEED TEST on the on the A20? What speed should you be getting? What did you get before? If this wired or wireless, or both, that is the problem? What DEBUG have you done?
0
0
#10
Options