Deco M9 plus giving extremely slow internet speeds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco M9 plus giving extremely slow internet speeds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M9 plus giving extremely slow internet speeds
Deco M9 plus giving extremely slow internet speeds
2020-01-07 04:04:51
Model: Deco M9 Plus  
Hardware Version: V1
Firmware Version: 1.3.0build 20190821 rel. 54023

Spectrum tech just spent 3 hours in my house. After solving some cable TV issues with coaxial, he tried to fix our extremely slow internet speed issue.  He measured 115 MPS coming into house and also coming out of my Netgear cable modem. He found an issue with my long ethernet cable that runs from cable modem to router, and suggests replacing the plugs on the cable which had been sloppily applied. He leaves. I go to get everything back up and running. First the Deco didn't want to boot back up, but two reboots and both units are online. But speed is still only about 9.8 mps.   So I Plug the Deco M9 plus main unit directly into my cable modem with ethernet cable, plug my laptop into Deco with ethernet cable, get about 10 mps. Try wireless from Deco to laptop with laptop about 1 foot away from Deco, get same figure. Out of desperation I get my old router, an Apple Airport Extreme which I had just replaced with the Deco. Try same thing, with ethernet connection I get 115 mps, with wireless and laptop about 1 foot away from Apple router I get 100.

 

   Are there any known issues with Netgear cable modems and Deco M9+ ? Any settings I should check on Deco? I did standard setup,didnt change any settings except for network name and password, and turning on guest network.

 

  Really desperate here. So desperate I'm about to call Geek Squad!!!!

 

JBNHNY

  0      
  0      
#1
Options
5 Reply
Re:Deco M9 plus giving extremely slow internet speeds
2020-01-07 04:10:39

@JBNHNY 

 

Additional info:  I went back and connected the Apple Airport to the Deco router via ethernet and set the Airport to Bridge Mode. The speed test while logged onto the Airport's wifi network now went down to 10 mps. It's definitely something happening with the Deco M9+.  

  0  
  0  
#2
Options
Re:Deco M9 plus giving extremely slow internet speeds
2020-01-07 04:53:31

@JBNHNY 

 

I used the Deco app on my iPhone to do a speed test, and it says 115 mps while simultaneously my lap top using wirelss access is getting 10 mps. This leads me to think that the Deco is slowing things down consistently to 10 mps, whether device accesses Deco unit wirelessly or via ethernet cable.

  1  
  1  
#3
Options
Re:Deco M9 plus giving extremely slow internet speeds
2020-01-08 17:23:59

@JBNHNY 

 

Open the Deco app, go to "More" (bottom right), go to QoS, scroll down, select Edit to the right. Try the option to get via internet speed test, save it, and test. If you still have the slow speeds, go back and set the speed manually to something like 10000 mbps for both, and save.

  0  
  0  
#4
Options
Re:Deco M9 plus giving extremely slow internet speeds
2020-01-08 18:46:55

@Tony spent 2 hours with support yesterday. Finally took factory reset of both decos to solve issue. Speed had been hitting 125 mps for 12 hours now so hopefully it was a one tome glitch. Thanks for the info. 

  0  
  0  
#5
Options
Re:Deco M9 plus giving extremely slow internet speeds
2020-01-15 20:45:27

@JBNHNY 

 

Thanks for the update, I wonder what the factor was that reset resolved.

  0  
  0  
#6
Options

Information

Helpful: 0

Views: 613

Replies: 5

Related Articles