Archer X50 slow speed on all lan ports, wifi is ok...

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer X50 slow speed on all lan ports, wifi is ok...

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer X50 slow speed on all lan ports, wifi is ok...
Archer X50 slow speed on all lan ports, wifi is ok...
2020-03-07 19:12:34
Model: Archer AX50  
Hardware Version: V1
Firmware Version: 1.0.5

i found out if u remove terher app, and do a factory reset u get full speed again....
went u add the app again , booommm again u lose 50% off your ISP speed i have 1Gb/s internet line ,
with the terhet.app ive got now only 350mb/s on all LAN ports.. your software is the problem,
so i don't use it any to get my isp full speed back ....... or do i need to buy x6000 ?
Thanks for crap tehter.app software !!!
David

  0      
  0      
#1
Options
3 Reply
Re:Archer X50 slow speed on all lan ports, wifi is ok...
2020-03-09 20:37:37 - last edited 2020-03-09 20:56:14

@David_vt 

 

Thank you for your feedback.

 

Please visit our official website to get a hold of your local TP-Link Support team to deteremine the issue and next steps to take: www.tp-link.com

  0  
  0  
#2
Options
Re:Archer X50 slow speed on all lan ports, wifi is ok...
2020-03-10 07:27:56

@David_vt 

 

There is a bug with the software app that enables something in the router to make it slow down. The router needs to be factory reset to get the speed back. Its an option that we cant tweak in the current firmware so im not sure what the software is actually achieving by doing this.

 

My random guess would be the qos. Tplink needs to make an option to fully disable it.

  1  
  1  
#3
Options
Re:Archer X50 slow speed on all lan ports, wifi is ok...
2020-11-07 20:09:46

@Shaun_L 

 

I did experience this same issue and it was enabling and the disabling the QOS feature in the software. Reseting the router to factory defaults and going through the setup and leaving QOS disabled seem to do the trick so my hardwire speeds were no longer reduced.

  0  
  0  
#4
Options