Deco M5 WiFi slow after recent firmware update

Deco M5 WiFi slow after recent firmware update
Deco M5 WiFi slow after recent firmware update
2020-04-08 04:51:51
Model: Deco M5
Hardware Version: V1
Firmware Version: 1.4.4 Build 20200221 Rel 65392

I noticed a significant drop in download speed on my Decos after recent firmware update to 1.4.4. Both 2.4 GHz and 5 GHz bands are affected.

 

Normally wifi on my modem/router is turned off, Decos are in AP mode.

 

Topography is modem/router->Main Deco via ethernet cable->Slave Decos via wifi

 

If I switch off Decos and connect directly to wifi on my modem/router, I get around 86-94 Mbps down and 35-38Mbps up. Before the upgrade, I was getting these speeds with Decos as well. The link is 100/40 Mbps.

 

After firmware upgrade to 1.4.4, I am getting 48-55 Mbps downloads on Decos. I get these from speed tests on Ookla, choosing the nearest server. When I use the Deco app speedtest, it gets better results, but I don't think they are relevant.

 

I tried downgrading via the web interface to the older firmware, but the downgrade wan't allowed.

 

Please helpt to downgrade or fix the slow speeds. 

2
2
#1
Options
22 Reply
Re:Deco M5 WiFi slow after recent firmware update
2020-04-08 16:35:04

I am seeing the same thing in my house as well.  Significant drop off in WiFi signal after the last update.

0
0
#2
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-08 20:00:13

@Calli 

 

Set the main Deco to router mode, leave the second one off. Connect, and in the Deco app go to the QoS settings, and set the upload and download speed to something like 100 / 100. If you do speed tests what do you get? Then switch the Deco to AP mode, and do the tests again, what speeds are you getitng now?

0
0
#3
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-08 22:54:37

@Tony 

 

Hi Tony,

 

Thanks for your message.

 

I already tried that  - set the Deco in Router mode, in the QoS edited the download speeds to 100, tested, then tried 1000, tested. Unfortunately, it had no effect on speeds - I am getting the same low speeds, both in Router mode and in AP mode.

 

I just saw someone else reporting the same issues on the TP English forum: https://community.tp-link.com/en/home/forum/topic/202624

 

I will try a factory reset on the units and see if this helps.

 

If it doesn't, what are our options? The Decos worked well before the firmware upgrade.

0
0
#4
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-09 15:05:02 - last edited 2020-04-09 15:30:55

For anyone experiencing a slowdown after upgrading please try this:

 

Go to our official website at: www.tp-link.com, then navigate to the Deco M5 support page (search for Deco m5, and select support when getting the result), go to the firmware section.

 

First select your hardware version, using the wrong hardware version may brick your Deco.

 

Download the firmware before the April released one. Extract the downloaded file and you will be left with a folder containing a .bin file. Now log into the Deco using a computer web browser. Here is how you would do that: https://www.tp-link.com/us/support/faq/2641/

 

Go to Advanced > System > Firmware Upgrade, and upload the .bin file. 

 

 

This should downgrade the mesh network back to previous firmware. Test the speed to verify if they have returned, if so, please go back to our website, and now download the latest firmware there. Make sure you download the firmware for your hardware version.

1
1
#5
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-10 02:21:37

 @Calli 

 

Factory reset helped. Speeds are back to normal. I had to rebuild the network from scratch after factory reset, but that wasn't a big deal.

 

Thanks @Tony 

2
2
#6
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-10 17:14:39

@Calli 

 

Thank you for the update on the solution, I'll make note of that.

0
0
#7
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-22 16:57:04
Having the same problem, but with the instructions above you indicate it is important to use correct firmware for version. I have 6 Decos in my house 3 are version 1, 3 are version 2. What do I do in that case? Will there be another firmware update to correct this issue soon? 219MB coming in, down to 24. Please help.
0
0
#8
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-22 20:36:36

@Bradduh 

 

Go into your QoS menu and look at the upload/download, make sure those are not set lower than your download/upload speed. If they are manually set them to what they should be. 

 

Messing with the firmware may involve deleting the Deco network, setting up only version 1s then downgrading/upgrading. Then setting up only the v2 by themselves and doing the same.

 

You could also look and factory defaulting the Deco units and setting them up to see if the speed returns.

0
0
#9
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-26 02:22:09

I have a Deco M5 V1 (three units). All are connected via cat-5 wiring. Internet comes from the cable modem to the primary M5, then out from the primary M5 to a network switch where it gets sent to two different wired locations, which are coonnected to the other two M5s.

 

In the Deco app, when I test the internet connection, the incoming speed reported by the app is about 350Mbps. I have a computer connectred to the switch, and it gets download speeds of about 125-150 Mbps. However, all devices connected via Wi-Fi are getting 1Mbps or slower download speed.

 

This started after I upgraded all three routers to the 1.4.4 (2020) firmware.

 

Following directions in this thread, I attempted to revert to the 1.3.7 version (Sept 2019 firmware). When I attempted to upload via the web interface, the process took about 10 minutes, but when it reloaded, the 1.4.4 firmware was still listed for all three M5 devices. So I tried to upload 1.3.7 back to the M5 devices, but now the web interface tells me I can't becuase it isn't the latest firmware (well, duh!).

 

Speeds on my iPad (5Ghz network) are now .56 Mbps down. My iPhone, on the first try, woudln't even connect to the speedtest.net server. The second time, it got 1.2 Mbps down.

 

I am incredibly frustrated. This was a ***TERRIBLE*** time to do a firmware upgrade. We've got  two adults and five kids all working from home, via video conference, and now we have essentially no internet on any of our devices. (Only my computer is wired in to the network.) It's a shame, because I told people at work about how much I loved my M5, and I know at least two co-workers bought M5s based on that recommendation. So did my brother, now that I think about it. After this disaster, I won't be able to give such a strong recommendation,.

 

Any advice? QoS is set to Standard. Total bandwidth is set to 350/10, which is what my stated speed is from the ISP (and is pretty close to what the Deco app reports as the incoming pipe from the cable modem. Other misc info, in case it helps: Operating mode is router. Beamforming is enabled. Fast Roaming is disabled. UPNP is enabled SIIP ALG is enabled. I have no port forwarding or address reservation. MAC clone is disabled. IPTV/LAN is disabled. I haven't modified the DHCP server settings (no custom DNS). I haven't modified the LAN IP. IPv6 is disabled.

 

I'd *really* appreciate any help you can offer.

1
1
#10
Options
Re:Deco M5 WiFi slow after recent firmware update
2020-04-27 17:49:28

@SethL 

 

Aside from the firmware, you can also delete your Deco network from the app, then reset every single Deco node. Configure the Deco network back with the same wireless name and password to see if the speed restores. Once everything is set back up, power down all the satellite units, and start just with the main unit to make sure that performs well, then add one other, and test, and so on.

 

Another area to check is the QoS menu, in that the speeds that is set for that reflect your internet speed so that is not throttling you by having speeds set lower then what your internet speed is.

0
0
#11
Options