Deco app not showing connected devices to linked deco M9 unit

Deco app not showing connected devices to linked deco M9 unit
Deco app not showing connected devices to linked deco M9 unit
2020-05-06 21:06:19
Hardware Version: V2
Firmware Version: 1.2.12 Build 20191014 Rel. 42025

Hey All,

 

Been comparing the M9 Plus with the X60 to decide which one to keep. Currently you cannot see the connected clients when you click on a deco M9 plus unit. When you click on the settings for a particular connected device, under "Linked Deco", it says "Unavailable for current firmware". I find it very insightful to know which devices are connected to which units like you can with the X60 units, see screenshot. Will a future update occur such that this information will be available for the M9 plus units?

 

0
0
#1
Options
14 Replies
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-07 17:33:58

@MaxSwole 

 

Yes, the new update for the M9 will have the UI, how the Decos are connected to each other, and what devices are connected to what node.

 

Now in your case if you are holding both units and deciding which to return, then time is the next thing. We do not have a solid release date for the M9 so by the time it is released you may not be able to return whichever unit by then. 

0
0
#2
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-09 21:04:54

@Tony having same issue on new set of m9 plus with inability to see connected device information. rebooted + reinstalled app and still no change

 

 

 

0
0
#3
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-11 18:15:14

@rsn 

 

That firmware version is the initial release so you do not have it. Check to see if there is a newer version, but if the Deco says it is up to date you will need to wait until another version is released.

0
0
#4
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-11 18:53:10 - last edited 2020-05-11 19:29:28

@Tony Not sure what you mean by "do not have it"; I am on the same firmware as what was mentioned in the OP for my M9s. Deco is showing as currently up-to-date, have you gotten any more insight as to ETA on next release?

0
0
#5
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-13 18:03:25

@rsn 

 

The screenshots of OP references the X60 not the M9. That is what I mean by the M9 not having it, and no there is no date set.

0
0
#6
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-13 22:29:31 - last edited 2020-05-13 22:30:45

@Tony 

 

what's interesting is that the M9s were actually showing connected clients and related up/down stats at one point prior to that firmware update

 

I even had a refurbed set i purchased for my parents home, and it was able to show the same details wonder what changed?

0
0
#7
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-05-13 22:45:38

@MaxSwole 

I am having the same issue, but with a P9 Home network.  My network and wifi seems to be functioning but my Deco app does not show any devices connected.  I have tried rebooting, removing, reinstalling, deleting/reinstalling iphone app.  I even deleted and recreated my network.  I am thinking this is a firmware issue or an Deco app version issue.  Tech support (in broken written English) only suggested to 'live with it' or repeat my above already attempted steps.  Keep me updated. 

0
0
#8
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-07-02 21:33:43 - last edited 2020-07-02 21:36:55

@Tony 

 

Any news on when we can expect an update? I am thinking of using the M9 in a public business setting so it would be largely helpful to be able to see connected clients per node.

 

Thanks

0
0
#9
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-07-06 17:08:04

@MaxSwole 

 

No, so far the M9 v1 got the update, but not yet for the v2.

0
0
#10
Options
Re:Deco app not showing connected devices to linked deco M9 unit
2020-07-06 17:50:06 - last edited 2020-07-06 17:55:35

@Tony 

 

Your response led me to check for firmware updates, and I found the below for v2. This update never showed up on the Deco App, but I will follow the instructions to update through the utility. How come the app does not notify you for a new update?

 

https://www.tp-link.com/us/support/download/deco-m9-plus/v2/#Firmware

 

Deco M9 Plus(US) _V2_200324
Published Date: 2020-06-23 Language: Multi-language File Size: 21.02 MB

Modifications and Bug Fixes:
1. Added switch for the UPnP function.
2. Added isolation switch for the main network and guest network in Access Point mode.
3. Displayed which client is connected to which deco and which Wi-Fi band.
4. Displayed how Decos are connected to each other, using Wi-Fi or Ethernet backhaul.
5. Disabled ping on WAN port to get rid of security risks.
6. TP-Link smart devices can be automatically added as smart devices after being connected to the Deco network now.
7. Improved system security and reliability.
8. Supported the Zigbee device called Muller light.

Notes:
1. Please update your Deco App to the latest version in order to use new features.
2. If there are other Deco models in your Deco network, you may miss some new features till other models release updates in the near future.

 

https://www.tp-link.com/us/support/download/deco-m9-plus/v2/#Utility

 

M9Plus_2.0_upgrade_tool(Win32)

Published Date: 2020-06-08 Language: English File Size: 29.86 MB

Operating System: WindowsXP/7/8/10

Firmware upgrade utility for Deco M9 Plus V2.0

0
0
#11
Options