Archer A7 - Phone getting two IP addresses

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer A7 - Phone getting two IP addresses
Archer A7 - Phone getting two IP addresses
2020-05-13 19:38:35 - last edited 2020-06-09 21:45:39
Model: Archer A7
Hardware Version: V5
Firmware Version: 1.0.14

I set up a DHCP reservation 192.168.1.116 for my Pixel 3 (need static IP for an app). When I look at the DHCP client list, I see that as an active lease, and all is well, as long as I connect the phone to the 2.4 GHz band.

 

If I connect it to the 5 GHz network, however, that lease still shows up, but the phone connects with an IP address of 192.168.1.134.  That lease shows up in the client list as well as the 192.168.1.116 lease. Even more confusing, the .134 lease shows on the list with a MAC address that does not match the MAC of the phone.

 

In both cases, the phone connects with the network just fine, but I want the phoen to connect to the router with the same IP address regardless of which band I am using. Is that possible?

0
0
#1
Options
1 Accepted Solution
Re:Archer A7 - Phone getting two IP addresses-Solution
2020-06-08 22:57:58 - last edited 2020-06-09 21:45:39

@Tony  I found the reason for the problem, and a solution.

 

When connecting to a new WiFi network, the Pixel 3 by default uses a "randomized MAC address". That's why the DHCP server was not assigning the IP address I wanted to the phone.  When setting up a new WiFi network on the phone you can set it to use the device's MAC address rather than a random address. Now the DHCP server on the router sees the address I specified in the reservation and correctly assigns the IP address I need.

 

This is a little better than assigning a static IP address for that network on the phone itself only because I can change that IP address if necessary from the router. To set a static IP address on the phone itself you need to shut down the WiFi network on the router, "forget" that network on the phone, manually set up a new network with the correct SSID on the phone, and manually enter the IP address in the Advanced Options for the network. You have to go through the same steps to force it to use the device's MAC address rather than a randomized address, but at least I will know a year from now how to change the phone's IP address on my home network!

Recommended Solution
2
2
#7
Options
6 Reply
Re:Archer A7 - Phone getting two IP addresses
2020-05-14 17:59:34

@Denali 

 

Are you using range extenders? That can modify the MAC address of the connected client device.

0
0
#2
Options
Re:Archer A7 - Phone getting two IP addresses
2020-05-14 18:41:01
No, I am not using a range extender.
0
0
#3
Options
Re:Archer A7 - Phone getting two IP addresses
2020-05-15 22:26:14

@Denali 

 

Delete the reservation within the A7, assign a static IP address on the phone itself.

 

Were you also using ARP binding?

0
0
#4
Options
Re:Archer A7 - Phone getting two IP addresses
2020-05-19 23:59:20

@Tony 

Tony wrote

@Denali 

 

Delete the reservation within the A7, assign a static IP address on the phone itself.

 

Were you also using ARP binding?

Thanks for the suggestion. If Tech Support can't resolve the problem, I will resort to that.  I am still exchanging emails with them.

0
0
#5
Options
Re:Archer A7 - Phone getting two IP addresses
2020-05-20 20:06:14

 

Tony wrote

@Denali 

 

Delete the reservation within the A7, assign a static IP address on the phone itself.

 

Were you also using ARP binding?

@Tony 

Well, today TP-Link Tech Support gave up. They said, "As per consulting here, since we already did all the troubleshooting the issue could be on your phone's setup since the other laptop that we tested works fine except for your phone. "

 

So I took your suggestion and set the phone up with a static IP address for the 5 GHz band on our home network. Unfortunately, that setting, buried in the bowels of network settings and available only when manually adding a new network, is probably one I'll forget a year from now. But it works.

 

Thanks.

0
0
#6
Options
Re:Archer A7 - Phone getting two IP addresses-Solution
2020-06-08 22:57:58 - last edited 2020-06-09 21:45:39

@Tony  I found the reason for the problem, and a solution.

 

When connecting to a new WiFi network, the Pixel 3 by default uses a "randomized MAC address". That's why the DHCP server was not assigning the IP address I wanted to the phone.  When setting up a new WiFi network on the phone you can set it to use the device's MAC address rather than a random address. Now the DHCP server on the router sees the address I specified in the reservation and correctly assigns the IP address I need.

 

This is a little better than assigning a static IP address for that network on the phone itself only because I can change that IP address if necessary from the router. To set a static IP address on the phone itself you need to shut down the WiFi network on the router, "forget" that network on the phone, manually set up a new network with the correct SSID on the phone, and manually enter the IP address in the Advanced Options for the network. You have to go through the same steps to force it to use the device's MAC address rather than a randomized address, but at least I will know a year from now how to change the phone's IP address on my home network!

Recommended Solution
2
2
#7
Options