Deco M9 Plus internet speed slower in AP mode.

Deco M9 Plus internet speed slower in AP mode.
Deco M9 Plus internet speed slower in AP mode.
2020-05-18 18:39:29
Hardware Version: V2
Firmware Version:

Curious if anyone else is seeing this behavior.

 

I have a Deco M9 Plus as the title says.  If I connect the M9 directly to my cable modem and run an internet speed test I get ~940Mbs pretty consistently. However, the M9 does support some of the features I use on my network, so I put it in AP mode and connected it to my router (Nighthawk R7000).  As soon as I did this I saw the internet speed test drop to ~540Mbs.  Thinking that was strange I plugged in my laptop with a cable to the router and tested. I got ~900+ Mbs from the laptop.  I switched the cables on the M9 with the one on the laptop.  Still ~540Mbs.  I plugged the M9 back into the cable modem in router mode.  Once again ~900+ Mbs on the M9 internet speed test.

 

Is there something I'm missing that would cause the M9 to run at a lower speed in AP mode?

 

 

1
1
#1
Options
7 Replies
Re:Deco M9 Plus internet speed slower in AP mode.
2020-05-19 20:43:02

@david_lu 

 

It seems very odd as I would expect the other way around to be happening as far as the speed.

 

Are speed tests done while wired to the main Deco and other satellite units powered down?

0
0
#2
Options
Re:Deco M9 Plus internet speed slower in AP mode.
2020-05-19 20:50:21 - last edited 2020-05-19 20:59:34

@david_lu No speed tests are done while all units are powered up and healthy according to the Deco App.

 

I don't know that I'm explaining this correctly.

 

SETUP1 ~940Mbs:

CABLE MODEM <<<-eth-->>> DECO M9 (Router Mode)

(Deco is connected to the CABLE MODEM with a cat 5e cable)

Speed test is run from the Deco App. 

 

 

SETUP 2: ~540Mbs:

CABLE MODEM <<<---eth--->>> Nighthawk R700 <<<---eth--->>> DECO M9 (AP Mode)

(DECO is connected to the R7000 via cat5e.  R7000 is connected to the cable modem via cat 5e.)

Speed test is run from the Deco App.

 

I assume the speed test is being run from the M9 itself to the test end point and not from my device over wifi to the Deco.  Is this correct?

 

 

0
0
#3
Options
Re:Deco M9 Plus internet speed slower in AP mode.
2020-05-20 20:52:47

@david_lu 

 

Correct, the in-app test is from the Deco point of view, but I would recommend doing the actual speed test from the device itself. Given the Deco is capable of giving 900+ Mbps, then it could be something with the Ethernet cable being used.

 

If the Ethernet cable from the modem to the nighthawk is the same when the Deco is connected to the modem, then swap out the Ethernet cable that is from the Deco to the night hawk or change the port it is on. 

0
0
#4
Options
Re:Deco M9 Plus internet speed slower in AP mode.
2020-12-26 15:53:04

@david_lu I'm experiencing the exact same problem.  Was there ever a resolution to your problem?

0
0
#5
Options
Re:Deco M9 Plus internet speed slower in AP mode.
2021-04-09 15:23:01

@collabguy Same problem here as well.   Seems like there is no solution and this is just a bad product.  

0
0
#6
Options
Re:Deco M9 Plus internet speed slower in AP mode.
2021-04-10 14:23:26

@Brychance I worked with their developer from China on this, which started at 10pm EST for me.  We spent a couple of hours on it.  We never did resolve the problem.  I don't think they will fix this issue until more people complain about it.  For TP-Link it's probably a low priority right now since there are probably not a lot of people buying 1Gbps internet speed.  It would be so easy for them to duplicate this issue in their lab.  But they have to care enough to want to help their customers.

0
0
#7
Options
Re:Deco M9 Plus internet speed slower in AP mode.
2021-04-11 15:59:40

@collabguy Thanks so much for the info and I assumed it was something like that.  It pretty much reinforces my effort to not buy anything whatsoever that is made in China.  I know, pretty tough now a days, but at least I'm going to make an effort to aviod their 'products' at all costs.  

0
0
#8
Options