WDS lets me reach root router but not internet access

WDS lets me reach root router but not internet access
WDS lets me reach root router but not internet access
2020-05-28 20:14:36 - last edited 2020-06-03 14:59:11
Model: Archer C8
Hardware Version: V1
Firmware Version: 4.0.0 Build 20160517 Rel. 44603

Hi TP-Link community,

 

I've followed the instructions listed here to try and extend my wireless range downstairs: https://www.tp-link.com/us/support/faq/1083/


But even though WDS is enabled (shows "WDS Status: Run" on the Advanced -> Status page), and DHCP on the bridging router is disabled, I can only ping the root router and bridging router; I don't have internet access.

 

Any ideas? Root router is a Netgear R7000, and the bridging router is this TP-Link Archer C8.

 

Here is the result of pinging the bridging router (192.168.1.2), and the root router (192.168.1.1):

 

moi@moi-surface:~$ ping -c 4 192.168.1.2

PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.

64 bytes from 192.168.1.2: icmp_seq=1 ttl=64 time=2.19 ms

64 bytes from 192.168.1.2: icmp_seq=2 ttl=64 time=2.25 ms

64 bytes from 192.168.1.2: icmp_seq=3 ttl=64 time=2.18 ms

64 bytes from 192.168.1.2: icmp_seq=4 ttl=64 time=4.45 ms

--- 192.168.1.2 ping statistics ---

4 packets transmitted, 4 received, 0% packet loss, time 3003ms

rtt min/avg/max/mdev = 2.179/2.765/4.446/0.970 ms

moi@moi-surface:~$ ping -c 4 192.168.1.1

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=4.37 ms

64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=2.45 ms

64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=3.77 ms

64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=3.67 ms

--- 192.168.1.1 ping statistics ---

4 packets transmitted, 4 received, 0% packet loss, time 3005ms

rtt min/avg/max/mdev = 2.451/3.563/4.365/0.695 ms

moi@moi-surface:~$

 

Update: If within Windows' network settings I manually specify the IP address (I set it to the same as the automatically-assigned one), subnet mask (255.255.255.0), and default gateway (this one I changed from the automatically assigned 192.168.1.2 to the root router's 192.168.1.1), I have internet access!

 

But how do I make this process automatic? I don't want to configure the default gateway for every device that tries to connect to the extended network.

0
0
#1
Options
1 Accepted Solution
Re:WDS lets me reach root router but not internet access-Solution
2020-06-01 15:16:14 - last edited 2020-06-03 14:59:11

@jenesuispasbava 

 

If a connected device is getting the gateway of 192.168.1.2, check the C8 to make sure the DHCP server is no longer running. If the server is off, look at the DHCP setting of the root router. Connect other devices to see if it was just an issue with that one device.

Recommended Solution
0
0
#2
Options
2 Replies
Re:WDS lets me reach root router but not internet access-Solution
2020-06-01 15:16:14 - last edited 2020-06-03 14:59:11

@jenesuispasbava 

 

If a connected device is getting the gateway of 192.168.1.2, check the C8 to make sure the DHCP server is no longer running. If the server is off, look at the DHCP setting of the root router. Connect other devices to see if it was just an issue with that one device.

Recommended Solution
0
0
#2
Options
Re:WDS lets me reach root router but not internet access
2020-06-03 14:59:08

@Tony 

 

I double-checked the C8 (bridging router) to make sure the DHCP server wasn't running - it was off - but re-enabled it and re-disabled it and it seems to have solved the problem. Looks like both routers were trying to assign IP addresses, and now only the root router is.

0
0
#3
Options