Invalid RSA Public Key

Invalid RSA Public Key
Invalid RSA Public Key
2020-06-09 22:41:33
Model: Archer A9
Hardware Version: V6
Firmware Version: 1.1.0 Build 20200416 rel.72485

I've seen this issue elsewhere on this forum with no workable solution even from TP-Link support.

 

When I connect to my router (https://tplinkwifi.net or tplinkwifi.net) I get a request to create a password.  When I do that, I get an error "Invalid RSA Public Key".  I can't continue from there.

 

Per all the other forum entry "solutions"  I've tried the following:

I've used Chrome and Chrome incognito, Brave, Firefox, IE, Safari (on my cell phone) with the exact same issue.  I've re-tried after clearing browser history/caches for the browsers with the same issue.  I've rebooted my router and pulled power for 1-minute+ with same issue.

Is there some superuser or TP-Link support specialist that can give a definitive/validated solution to this?

0
0
#1
Options
2 Reply
Re:Invalid RSA Public Key
2020-06-09 23:15:32

@Steelart99

 

I've been having other issues with my router Wi-Fi not working consistently.  As a result, I had logged into my Guest Wi-Fi. 

 

When I installed Tether on my cell phone (another connection option), it told me that I could not connect to the router when on a Guest network.  So, I was finally able to get the main Wi-Fi network working long enough and then all the "Invalid RSA Public Key" issues went away.

0
0
#2
Options
Re:Invalid RSA Public Key
2021-10-08 00:11:55

@Steelart99 

I have this issue too. It only happens on one computer and it doesn't matter what browser I use. If I cold boot the router (C7) then I can login as normal just using my existing password. After sometime (I haven't determined how long) it reverts to the prompt that I have to create an administrator password and even if I try any word I get the invalid RSA public key error. If I try from another computer at anytime I can log in without issue. I can also login using the Tether app at anytime also. So, it seems to be PC (or probably MAC address) related. It would be good if there was response from TPLink support about how to resolve this issue.

0
0
#3
Options