Ubuntu on Lenovo Z500 cannot access wifi of Deco M9 Plus WiFi System

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Ubuntu on Lenovo Z500 cannot access wifi of Deco M9 Plus WiFi System
Ubuntu on Lenovo Z500 cannot access wifi of Deco M9 Plus WiFi System
2020-06-17 14:00:37 - last edited 2020-06-17 14:02:49
Hardware Version: V1
Firmware Version: 1.2.12

Hello all,

 

I just bought my Deco M9 Plus and old Router is netgear RTN66W Double Band.

 

When I ran Ubuntu 20.04 with RTN66W, it can access the 2.4GHz band and Lenovo Z500 only supports 2.4GHz.

After I switch to M9, the Ubuntu no longer can access the wifi network.

 

Here is my setup:

 

Main network: 2.4 GHz + 5 GHz

Guess network: 2.4 GHz

 

The ubuntu cannot access both Main and Guess network. If I remove the wifi access password, then the Ubuntu can access the wifi without problems.

Also, my phones and other computers have no issues to access the wifi network and the system always prompts that the password is not correct.

If I run window 8 64 bit on this Z500 machine, it also has no issues to access the Main network.

 

Question> what might be the culprit that causes the issues specific for Ubuntu?

 

Thank you

0
0
#1
Options
3 Reply
Re:Ubuntu on Lenovo Z500 cannot access wifi of Deco M9 Plus WiFi System
2020-06-18 20:37:47

@q0987 

 

Try setting up the wireless connection as WPA.

0
0
#2
Options
Re:Ubuntu on Lenovo Z500 cannot access wifi of Deco M9 Plus WiFi System
2020-06-19 00:24:31

@Tony 

 

where should i set wpa?

 

router or ubuntu?

 

thx

0
0
#3
Options
Re:Ubuntu on Lenovo Z500 cannot access wifi of Deco M9 Plus WiFi System
2020-06-19 21:03:52

@q0987 

 

My apologies, setting up the wireless connection for WPA in Linux. Unfortunately, Deco does not let you control that aspect.

0
0
#4
Options