Port forwarding to Deco from ISP modem/router

 
Port forwarding to Deco from ISP modem/router
Port forwarding to Deco from ISP modem/router
2020-06-18 08:45:11 - last edited 2020-11-12 23:18:20
Model: Deco P9
Hardware Version:
Firmware Version: 1.1.0 Build 20200513 Rel 52023

My deco system is working in router mode and the main deco is connected to ISP modem/router via ethernet.

 

I need to open a port for a service to run on my computer. If I'm understanding this right, I'll need to setup port forwarding on both ISP modem/router and Deco system, that is to forward the port communication from ISP modem/router to deco and then from deco to my computer.

 

To setup port forwarding on my ISP modem/router, I must choose the device to forward to from a list of connected devices. ( my ISP modem/router doesn't allow manually specifying IP address to forward to.) The issue is, although I can see from Deco app the IP address it gets assigned from ISP modem/router, it is not listed in the connected service from ISP modem/router. Thus, I can not setup port forwarding to deco from ISP modem/router.

 

What is it that hides Deco from the connected devices list on ISP modem/router? How can I set it up so I can see deco as a normal connected device on ISP modem/router, as this is the only way I can set port forwarding to deco from ISP router/modem.

 

I've tried disable all firewall related settings on my ISP modem/router, the port is still closed.( port forwarding on deco is setup correctly and tested to confirm working.)

2
2
#1
Options
1 Accepted Solution
Re:Port forwarding to Deco from ISP modem/router-Solution
2020-06-19 21:49:26 - last edited 2020-06-19 21:49:35

@Tony 

Thanks for the hint, it was the MAC for main deco I input in ATT box setting. 

 

I finally managed it to work. It turns out that I was right to suspect it should be some other MAC of the same main deco to be provided to ATT box for reference.


Each deco has several MAC addresses for different usage, but somehow only one of them is printed at the device bottom. All MAC should be printed and labeled clearly, either on the device or in Deco app. This is actually one thing I'd like to suggest TP-LINK to consider with.

 

Lucky me knowing each deco has several MAC. All I did is just to find those "hidden" ones and to try one by one. In my case the one printed ends with "78", the one actually worked ends with "79".

 

Cheers!

Recommended Solution
1
1
#7
Options
6 Reply
Re:Port forwarding to Deco from ISP modem/router
2020-06-18 13:45:04
Sounds like your ISP modem is also a router. So you need to either have that placed into bridge mode, or you only use the Deco as a mesh AP. Just guessing maybe someone here can help, but it sounds like you need to talk to your ISP.
0
0
#2
Options
Re:Port forwarding to Deco from ISP modem/router
2020-06-18 18:47:22

@Jets Thanks for the hint!

 

Although I don't perfectly understand what this is all about, but a quick google regarding bridge mode makes all senses to me now.

 

Unfortunately, my ISP modem/router (an ARRIS BWG210-700) doesn't offer option for bridge mode, instead, it offers an "IP Passthrough" option, which according to google results should do exactly the same thing here. Besides, there are quite a few users shared there sucessful experience regarding howto set this up and working, well, with other routers instead of deco system though.

 

While setting this "IP Passthrough" option, one of the key steps is to pick which lan device to pass to, which should be the main deco in my case. However, deco doesn't show up in the connected lan devices as I mentioned in previous post, so I can't pick it as the lan device to pass to. Fortunately, the option settings allows me to manually input the mac address for the lan device to pass to, so I just input the mac address printed on the bottom of the main deco. I thought this should work.

 

Then, as adviced, I rebooted the ISP modem/router (the ARRIS BWG210-700) first, then rebooted the main deco after. ( Port forwarding has been setup in Deco app for port 30000 to my computer (192.168.68.105), the main deco is getting an internal IP address of 192.168.1.171 from my ISP modem/router)

 

Now, I start the service on my computer to listen at port 30000, from another computer in the same lan, I run "nc -zv 192.168.68.105 30000" which gives a connection succeed feedback, so I'm sure the port on my computer is open. From the same "another computer", I run "nc -zv 192.168.1.171 30000" also gives a connection succeed feedback, so I think the deco port forwarding is also working fine.

 

If I check the port from internet (using online checking tools, e.g. https://www.yougetsignal.com/tools/open-ports/), the port is closed. I've tried several other checking tools, all report port closed.

 

I'm stucked now:

1. Where did  I do wrong in the setup?

2. How do I check if my ISP modem/router IP Passthrough is working as expected?

3. What should I do next to have this to work?

 

 

 

 

0
0
#3
Options
Re:Port forwarding to Deco from ISP modem/router
2020-06-18 23:06:01

@mark-night 

 

If you connected to the AT&T network and tested the WAN IP address and the port then the Deco is working as it should.

 

There seems to be various setup guides on the IP passthrough so if that is not working I would try a different port. Modify the port the service uses, reflect that in the Deco, test again while on the AT&T network, and then configure the modem/router.

 

Last resort would be to contact the ISP to see what may be wrong.

0
0
#4
Options
Re:Port forwarding to Deco from ISP modem/router
2020-06-18 23:42:12

@Tony 

Thanks for the response.

 

After a few hours of digging, I believe the issue has something to do with the weird fact that main deco is not showing up in the devices list of BGW210. The main deco is the only device that is connected to BGW210, but the devices list of BGW210 is empty. When I try to setup IP Passrough or Port Forwarding on BGW210, an existing connected device must be picked from the list, as the list is empty, there is no way to proceed. The only exception though, when setting IP Passthrough, there is a field where  I can manually input the destination MAC address, and that is where I copied in the MAC address that was printed on the bottom of my main deco. I thought this should work but it doesn't.

 

In the Deco app, More->Advanced->IPv4, I can see the IP address is a private address (192.168.1.171) get from BGW210, instead of a public address I'm expecting. (It should be a public IP if passthrough worked, right?) This clearly means the IP Passthrough on BGW210 is not working, which I suspect is because BGW210 can not see main deco at all (the devices list is empty) although I manually input MAC address. 

 

Now, it might be a good time to contact AT&T, but before that, I still want to make clear one thing:

As each deco node has multiple MAC addresses, is the one printed on the device bottom be the one needed to be provided to preceding router for passing address? In other words, is the one printed on bottom the so called "WAN port MAC address"?

 

Thanks.

0
0
#5
Options
Re:Port forwarding to Deco from ISP modem/router
2020-06-19 21:00:52

@mark-night 

 

From what I was able to gather the Deco should be getting a WAN IP, now it could be different in the AT&T box and the Deco will still get the LAN IP. 

 

Each unit does have it's MAC address but the one MAC to reference would be the main Deco if a MAC needs to be referenced.

0
0
#6
Options
Re:Port forwarding to Deco from ISP modem/router-Solution
2020-06-19 21:49:26 - last edited 2020-06-19 21:49:35

@Tony 

Thanks for the hint, it was the MAC for main deco I input in ATT box setting. 

 

I finally managed it to work. It turns out that I was right to suspect it should be some other MAC of the same main deco to be provided to ATT box for reference.


Each deco has several MAC addresses for different usage, but somehow only one of them is printed at the device bottom. All MAC should be printed and labeled clearly, either on the device or in Deco app. This is actually one thing I'd like to suggest TP-LINK to consider with.

 

Lucky me knowing each deco has several MAC. All I did is just to find those "hidden" ones and to try one by one. In my case the one printed ends with "78", the one actually worked ends with "79".

 

Cheers!

Recommended Solution
1
1
#7
Options