AX6000 2.4GHz, 5GHz, Smart Connect issue

AX6000 2.4GHz, 5GHz, Smart Connect issue
AX6000 2.4GHz, 5GHz, Smart Connect issue
a week ago - last edited a week ago
Hardware Version: V1
Firmware Version: 1.1.0 Build 20200427 rel.80857(5553)

Scenario

 

I have enabled Smart Connect under wifi options in my AX6000. This merges 2.4GHz and 5GHz wifi frequencies. That was alright until I got the Brother MFC printer that works only on 2.4GHz. Now, printer still detects the network and connects to it but randomly my devices (phones, iPad and Macbook) loose printer connection and will not print. The printer still shows connected to Network but sitting dead.

 

So, I started 2.4GHz Guest WiFi on which just the printer can connect. I allowed Guest wifi to access internal network - assuming devices can now connect and take print but that didn't work. Mind that 2.4 GHz AP isolation is not enabled. 

 

Even if I manually change the devices' wifi to connect to 2.4GHz guest network it still can't print. As you can see the Firmware is the latest one. I am certain that all such 2.4GHz 'only' supported devices will not be able to work/connect properly under "Smart Connect" mode. I don't intend to disable the functionality and create two SSIDs one for 2.4 and one for 5 - but I don't want manual separation of devices to connect to those frequencies.  

 

Now, I can either return the printer or disable the Smart Connect (& let go my badwidth/speed benefits - the reason why we buy expensive routers) or do the wired connection with the router for which I have to do plenty of prep work.

 

Any suggestion/help?

 

** Printer has no network related issues. I have reset its network config. It connects successfuly to router. I can see DHCP giving IP address to printer as well. If I attach the cable - it works fine. 

0
0
#1
Options
6 Replies
Re:AX6000 2.4GHz, 5GHz, Smart Connect issue
a week ago

 

Amit2777 wrote

Now, I can either return the printer or disable the Smart Connect (& let go my badwidth/speed benefits - the reason why we buy expensive routers)

@Amit2777 

 

Not sure what you meant here?

 

Smart Connect and 'my badwidth/speed benefits' actually are not related? If anything, with Smart Connect you CAN lose 'speed'!

 

Smart Connect concept is pretty simple. The router 'figures out' what band (2.4 or 5Ghz) the device can work on and connects it to one it WILL work on. However, Smart Connect will not aways connect your device to the one that it is best suited for. From what I've read, TP-Link Smart Connect will take into account the number of devices on the bands. It will not overload one band vs. the other(s). That means one could find an N device on the same band as an AC device which can degrade the performance of the AC device. Also mix G devices (if anyone still uses these) with N speed devices.

 

Always best to MANUALLY configure the router and device to isolate individual speed devices to the proper bands.

 

Most if not all printers will need the 2.4Ghz band. I've had Smart Connect enabled on a few different routers and my printers (all HP) have never had a problem being 'found' by my wired and wireless devices of all speeds. At one time though I did have problems with ONE specific HP 310A printer. It needed one of 2 RESERVED IP Addresses to work correctly via wireless. Later printer PC s/w did fix that problem though.

 

Wondering if you assigned on the ROUTER the Printer MAC address to a specific IP address and then reinstalled the device s/w so it used that same IP Address (or changed the printer fixed IP Address on the s/w) if that would solve the problem?

0
0
#2
Options
Re:AX6000 2.4GHz, 5GHz, Smart Connect issue
a week ago

@Amit2777 Having a similar issue w/ Smart Connect (for me, it's Sonos speakers that only work on 2.4ghz). Hope TP-Link can issue a firmware update addressing this. TLDR, my speakers drop off of the network periodically with Smart Connect enabled, but work fine when it's turned off.

0
0
#3
Options
Re:AX6000 2.4GHz, 5GHz, Smart Connect issue
Thursday

@Amit2777 Same issue here. Smart connect needs fixed ASAP.

0
0
#4
Options
Re:AX6000 2.4GHz, 5GHz, Smart Connect issue
Thursday

@IrvSp : I thought about the address reservation and had removed that binding. The issue is almost 2 months old now. Meanwhile in last 5 days twice my router went down and had to reconfigure/restore from previous config (anyway that is a separate issue :)

 

I expect Smart Connect would "load balance" the bandwidth and connection. Evenif I forgo "Speed" benefit, a simple network communication between devices should work when connected to the router. Additionally, majority of the smart home devices are on 2.4GHz so I kind of dislike the idea of multiple SSIDs or switch the network when you want to print...or turn off the LED

 

 

 

0
0
#5
Options
Re:AX6000 2.4GHz, 5GHz, Smart Connect issue
Thursday

@Amit2777 They could probably fix Smart Connect by allowing you to force specific devices to use 2.4GHz or 5GHz in the settings. I like having one SSID but don't like all the problems that come with.

0
0
#6
Options
Re:AX6000 2.4GHz, 5GHz, Smart Connect issue
Thursday

@Amit2777 

 

I don't know how Smart Connect actually works or even if it is the problem?

 

Load leveling I think is done only at connect time, if it were to do it leveling the devices to keep the bands even in the number of devices per band, that is known usually as Dynamic leveling. I think this is an option on implementation from the chipset maker, but not many use this function, and I don't think TP-Link does.

 

The root problem could be the router for some reason thinks the device can be capable of using 5Ghz even?

 

It might be nothing more than the IP Address change each time you boot?

 

For my HP printer, the printer control on my Windows PC thinks it is here, http://192.168.0.182:3911/ (printer is NOT on now). When it was last on, that is the IP Address it had:

http://192.168.0.182:3911/. I am not using Smart Connect and the Printer is NOT set to an IP Address either in the printer or router. Quite possible it would be given the same IP Address when it comes on IF it were available. All my devices connet every day but the Smart TV and the Printer. Those 2 were on today though (TV not named), On my A20, this is the DHCP list:

 

The circled one it the TV. NO device has a reserved or fixed IP Address. I am NOT using Smart Connect, and I manage who connects to what BAND. Note that the IP Addresses are NOT sequential. I would have expected them to be though.

 

I don't know what Brother Printer you have, but the problem could be with the s/w for it? Have you checked to see if you have the lastest s/w? At one time with a much older HP and had problems like you have. Assigning an IP Address to the printer solved that.

 

If you want to do that, you need to carve out some IP Addresses outside of the DHCP range. Rather than start the IP Address Pool at the default (192.168.0.2), start it at say at 192.168.0.100. Then you can adding the printer any IP Address between 192.168.0.2 and 192.168.0.99 and it will aways get that IP address. You can do it one of two ways, by the router under IP Address Reservation or on the Printer.

 

Since those addresses not in the pool will NOT be given out to any device, you have to make sure you don't assign two devices the same IP Address though.

 

Of course, without Smart Connect, you also must manage the device and have it connect to the SSID you wish.

0
0
#7
Options