Deco M5 DHCP not assigning IP addresses

Deco M5 DHCP not assigning IP addresses
Deco M5 DHCP not assigning IP addresses
2020-07-21 03:38:38 - last edited 2020-07-21 03:42:09
Model: Deco M5
Hardware Version: V3
Firmware Version: 1.3.4 Build 20191012 Rel. 52072

I recently purchased a 3 Deco M5 kit and I'm quite happy with it in terms of range and speed. However, it is VERY common that it will not pick up an IP address when a device (new or existing) tries to connect to it.

 

This issue happened with one kit I purchased and upgraded immediately upon installation to firmware version 1.4.4. Because it was happening so much, I exchanged it for another of the same kit. Now, I did not upgrade the firmware, as I thought that could be the issue. Evidently, it wasn't. I keep getting devices (iMac, MacBook, Windows laptop, iPad, Apple Watch, iPhone, smart tv, etc...) to get 169.254.x.x self assigned ips for a while (sometimes seconds, sometimes many minutes or until I give up) instead of an assigned 192.168.68.x IP address.

 

Looking at the logs, there are several entries of this kind:

 

"Mon Jul 20 23:20:53 2020 daemon.err udhcpd[18648]: no free IP addresses. OFFER abandoned"

 

Which is very odd, as I have about 25 connected devices, and the DHCP pool is set at 192.168.68.100-192.168.68.250 (in the device that I returned I had changed it to .2-.250, but to no avail).

 

I thought it could be some issue with the DHCP server, either in the firmware or hardware. But the problem persists with a new device (kit) and older FW.

 

If I set the IP address as manual, rather than automatic, the device connects with no problem, but really it's a pain to do that, and DHCP should work.

 

I have not seen this issue in other posts, so I hope someone can shed some light. Otherwise, I will return and look for an alternative whole home system.

 

Thank you

3
3
#1
Options
16 Reply
Re:Deco M5 DHCP not assigning IP addresses
2020-07-21 19:14:50

@regisk Lenovo Ideapad 3 14ARE05

Deco M5 not giving out DHCP address to this laptop.

 

Manual assigning and network is ok.

No other devicea hasthis issue.

Typical that there is something wrong with a Lenovo, there is always something no matter a phone, a laptop, clock, always something.

0
0
#2
Options
Re:Deco M5 DHCP not assigning IP addresses
2020-12-14 22:45:48

@regisk I have the exact same problem. Any sollution?

0
0
#3
Options
Re:Deco M5 DHCP not assigning IP addresses
2020-12-25 17:20:08

@regisk same here.  Started on this last update to firmware 1.5.1 and prior to that I was impressed with how stable the system was.  Now my dhcp range is 200 addresses, 27 ip addresses assigned and I am still seeing the no free ip error in the system log and failing connections.

0
0
#4
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-01-21 15:47:26

@VWhy I have a deco m9 and having the same issue. I'm on 1.4.3 for the m9. 
 

Today, when this happened again, I tweaked the dhcp range and it picked up a client or two but still spotty until I reset the main deco. Happened again after a few hours. 
 

I was wondering if this had to do with address reservation; also think this got worse with apples private address feature which created multiple mac for the same device. That said I removed a lot of devices from address reservation and turned off private address and still have this issue, though seemingly less (but still persists) 

0
0
#5
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-01-30 15:57:12

@Al852 

I also have the same problem with M9 plus with last firmware. 

I can't connect my 3 ipcams to my LAN. The ipcams can't get ip. 

 

Guy

0
0
#6
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-02-03 01:40:46

I'm having the same exact issue as well.

2 - M5s: static IP works fine, DHCP is a dumpster fire.

What makes it frustrating is that it's random, one device that's working fine today might not work at all tomorrow. 

0
0
#7
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-02-06 18:54:32

@regisk 

 

I've had the same issue. 

When I fire my infrequently used printer up, it doesn't pickup an IP same again for my Xbox.

 

Ive now just switched the Deco's over to AP Mode instead of router and it seems to be working fine.

 

Not a Fix, but a possible workaround, depending on whether you need to use the rest of the functionality of the Deco's in Router mode.

0
0
#8
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-02-06 21:14:39

@Hedgehog 

 

I've swapped a couple of emails w/TP-Link support and I'm still waiting for a solution but in the meantime, I'm just assigning static IPs whenever a device is unable to connect.

 

Frustrating to say the least.

0
0
#9
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-02-07 15:05:28

@Hedgehog 

 

Support suggested changing the DNS servers to: 8.8.8.8 & 8.8.4.4

 

Maybe that will help?

 

 

0
0
#10
Options
Re:Deco M5 DHCP not assigning IP addresses
2021-02-08 11:23:47

@Hedgehog 

 

So far the change tho DNS seems to be doing the trick.

0
0
#11
Options