Slow Internet on deco M9 plus, Main Network ONLY

Slow Internet on deco M9 plus, Main Network ONLY
Slow Internet on deco M9 plus, Main Network ONLY
2020-08-11 11:43:56 - last edited 2020-08-11 13:49:09
Hardware Version:
Firmware Version: 1.2.12 build 2019014 Rel. 42025

On my new M9 plus, I get really great speeds uploading and downloading on the GUEST network. But on the MAIN version of the network, I get almost no internet. In fact sometimes I can't get any internet at all.

 

GUEST network: 50mbps down, 6mbps upload

MAIN network: 10mbps down, 0.06 Mbps upload

 

It was working fine until just today and nothing changed in my settings.

 

Rebooting didn't change anything, modifying the qos didn't change anything. I also tried disabling and re-enabling the main network.

 

How do I fix this?

 

Edit: to clarify, the speed test on the router app is fast, but when using a client and a web browser the Google speed test is only slow when connected to the main Network.

0
0
#1
Options
4 Reply
Re:Slow Internet on deco M9 plus, Main Network ONLY
2020-08-12 17:27:39

@NeilKY 

 

Delete the Deco network, and factory default every Deco unit. Once the network comes back up, connect only one device. If that is slow, power it down or disconnect and connect with your phone. 

 

Slowdown could be on the device being used or the Deco so use different devices to narrow it down.

0
0
#2
Options
Re:Slow Internet on deco M9 plus, Main Network ONLY
2020-08-12 18:09:26

@Tony 

 

  • Copying files between computers is fast.
  • Internet on each device is slow on both networks now, from the router to the clients but not from the router to the internet

 

If I factory reset as recommended, can I restore my previous settings using my login info, or will all those settings be lost? Renaming the devices on the network based on MAC address was a long, tedious process.

 

Tony wrote

@NeilKY 

 

Delete the Deco network, and factory default every Deco unit. Once the network comes back up, connect only one device. If that is slow, power it down or disconnect and connect with your phone. 

 

Slowdown could be on the device being used or the Deco so use different devices to narrow it down.

 

0
0
#3
Options
Re:Slow Internet on deco M9 plus, Main Network ONLY
2020-08-13 20:35:36

@NeilKY 

 

There is not a way to back up the configurations. You could look to do that as a last resort if you would like.

 

In the meantime, try swapping the main Deco unit with one of the satellite units.

 

Check the QoS speed setting, that may be set low so it would slow down everything connected. Manually set it higher.

0
0
#4
Options
Re:Slow Internet on deco M9 plus, Main Network ONLY
2020-08-17 12:16:09
I solved my problem. I couldn't afford the time wasted by resetting like you suggested. hopefully tp-link will come out with a backup settings feature which is a standard feature on almost all other routers on the market. What I did was I rename my SSID for the main Network. It ended in "-5g". I replaced this with another word and it works fine! So odd! It even works with a capital g "-5G". I went back to the lowercase and it broke again. So if anybody has an SSID that ends in -5g, and your internet is not working, give this a try
0
0
#5
Options