Archer A6 Parental Controls are ignoring Daylight Savings config settings

Archer A6 Parental Controls are ignoring Daylight Savings config settings
Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-06 21:10:57
Model: Archer A6
Hardware Version: V2
Firmware Version: 1.1.5 Build 20191112 rel.36515(5553)

I did a Factory Reset on my Archer A6, then performed the following "quick config":

  • Set Password
  • Set TimeZone to GMT -0800 (Pacific Time)
  • Static IP configuration
  • Smart Connect (no changes)
  • [Save]
  • TP-Link Cloud Service log in
  • [Save]

 

Then I performed the following additional configuration:

  • Advanced -> System Tools
    • Enable 24 Hour Time [Save]
    • Enable Daylight Savings Time [Save]
  • Parental Controls
    • Add
      • Name: TEST
      • Devices: test01 (wired), test02 (wifi)
      • Blocked Content: no change
      • Bed Time:
        • Enabled School Nights, 8PM - 7AM
        • Enabled Weekend 10PM - 7AM
      • [Save]

 

My test01/test02 device is a Raspberry PI running Ubuntu connecting eth0 with a direct ethernet connection and wlan0 connected to the Archer A6 wifi.  Test device timezone is set to Pacific TIme with daylight savings.

 

Once per minute, a simple shell script will attempt to ICMP ping "google.com" over each network connection (eth0 and wlan0), and log the results to a text file.

 

I've run this test for a couple nights, repeating the factory reset and rebuilding the configuration each time.  Both nights, the internet access would shut off exactly one hour later than expected.  Both nights, the internet would turn on one hour later than expected.

 

It appears that Parental Controls are not respecting the Daylight Savings settings.

0
0
#1
Options
8 Reply
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-08 18:03:32

@Seganku 

 

If you were to leave the time settings so the router automatically gets the time, do you see the same thing?

 

When manually selecting the time, what was your start date and end date, and what was the status of the daylight savings?

0
0
#2
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-11 00:31:29

@Tony 

 

I am not "manually selecting the time".  The only changes made here were to enable 24-hour time and enable daylight savings time.

0
0
#3
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-11 22:47:30

@Seganku 

 

I would recommend reaching out to our support team to see what the issue may be.

0
0
#4
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-12 16:11:01

@Tony Yes, I got an email asking for proof of purchase, and replied to that, but haven't seen a response from TP-Link for 6 days now :(

0
0
#5
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-14 17:21:14 - last edited 2020-09-14 17:43:26

@Tony 8 days now.

0
0
#6
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-16 16:11:44

@Seganku 

 

You have been communicating with email support since Sept 7th, and have been exchanging emails on the 8th, 11th, 12th, and the 15th. regarding daylight savings.

 

I am not sure what you are counting.

0
0
#7
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2020-09-17 03:10:55

@Tony Yes, I did finally get a response on Tuesday.  Thanks!

0
0
#8
Options
Re:Archer A6 Parental Controls are ignoring Daylight Savings config settings
2021-07-10 14:39:58

@Seganku Sorry, I'm late to the party, but I had this issue too. Support was no help (ticket #263820). After all, how do you show someone that the a device that should have been able to connect at a particular time - after 'Bed Time' setting expired, for instance - was not in fact able to connect? My solution was to turn off DST and set the time zone one hour forward: Eastern time instead of Central time, for example. This somehow resulted in my Archer A9's "Current Time" matching the correct time for my location. Disappointing that TP-Link is unable to even acknowledge that this is an issue. 

0
0
#9
Options