TP-LINK DECO P7 blinks red when in AP mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TP-LINK DECO P7 blinks red when in AP mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TP-LINK DECO P7 blinks red when in AP mode
TP-LINK DECO P7 blinks red when in AP mode
2020-09-14 13:38:32 - last edited 2020-09-23 14:14:49
Model: Deco P7  
Hardware Version:
Firmware Version:

Hello,

 

My setup is like that:

 

Fritzbox 7590 (only for DSL and wlan) -----------> EdgeRouter X (no wifi, controls the complete lan in the house and the decos are connected with this one) ---> DECO P7 main connected via ethernet, DECO P7 slave 1 connected via nothing, so basically wifi. this one doesnt work. AP mode. In router mode, main is ethernet and the slaves are wifi but then i have triple NAT i think BUT it works perfectly, even tho i have 3 NATS then. 

Any way to fix this? do i need to connect the switch for all LANS in the house to the fritbox 7590 because it has wifi, so the decos can expand the wifi?? 

  0      
  0      
#1
Options
1 Accepted Solution
Re:TP-LINK DECO P7 blinks red when in AP mode-Solution
2020-09-22 20:54:41 - last edited 2020-09-23 14:14:49

@kostaK 

 

Please check your firmware in that you are running 1.4.7, if not update the firmware through the Deco app.

 

If you are running 1.4.7, please follow the procedure below:

 

1.      Switch back to Router Mode.

2.      Wait for all Decos to be online.

3.      Download the firmware from here and extract it: 

         https://static.tp-link.com/2020/202009/20200918/Deco_P7_1.4.8.zip

4.      Access http://tplinkdeco.net and perform a firmware upgrade.

5.      After the upgrade, the new version should be 1.4.8 200916, please make sure all Decos are successfully upgraded.

Recommended Solution
  1  
  1  
#7
Options
10 Reply
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-15 15:34:55

@kostaK 

 

In router mode the main needs to be wired, in AP mode all could be wired, but if only the main then the slave should work off of Wi-Fi.

 

Have you tried swapping the nodes so the other is now the main Deco?

 

You can wire both nodes into your LAN while in AP mode.

  0  
  0  
#2
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-15 15:47:05

@Tony i didnt try that but my router doesnt have wifi, could this be the reason? its green for a short time and then instantly gets red blinking, i resetted it already etc

  0  
  0  
#3
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-16 20:12:42

@kostaK 

 

If your main router doesn't have Wi-Fi that is fine. Its the cable going from the router to the main Deco that matters. Going back to the node, I would look to swap it to see if the blinking follows the node.

  0  
  0  
#4
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-18 22:16:15
AP Mode, deco1 is connected via ethernet plug to the switch/router. it lights green. Deco 2 and 3 (slaves) wirh wifi, even if i place them near the deco1, they are green after the reset and adding to the setup for 1min and get red blinking instantly.
  0  
  0  
#5
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-18 22:19:38
btw does powerline etc srill works if in Ap mode?
  0  
  0  
#6
Options
Re:TP-LINK DECO P7 blinks red when in AP mode-Solution
2020-09-22 20:54:41 - last edited 2020-09-23 14:14:49

@kostaK 

 

Please check your firmware in that you are running 1.4.7, if not update the firmware through the Deco app.

 

If you are running 1.4.7, please follow the procedure below:

 

1.      Switch back to Router Mode.

2.      Wait for all Decos to be online.

3.      Download the firmware from here and extract it: 

         https://static.tp-link.com/2020/202009/20200918/Deco_P7_1.4.8.zip

4.      Access http://tplinkdeco.net and perform a firmware upgrade.

5.      After the upgrade, the new version should be 1.4.8 200916, please make sure all Decos are successfully upgraded.

Recommended Solution
  1  
  1  
#7
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-23 13:49:45

@Tony okay, did it what now

 

  0  
  0  
#8
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-23 14:03:41

@Tony it actually fixed it, so a firmware issue!

 

ty for your help :)

  0  
  0  
#9
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-23 14:10:56

@Tony last question, from where are the speed tests? if im at the deco 3, does it takes the speedest from the main deco? or how? with my pc and speedtest i get way lower via lan connection

  0  
  0  
#10
Options
Re:TP-LINK DECO P7 blinks red when in AP mode
2020-09-23 22:00:31

@kostaK 

 

The speed test in the app is done from the main Deco. When on Deco 3 you traverse through the other Decos so it will not be as fast.

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 1009

Replies: 10

Related Articles