Deco M9 plus not connecting to websites (wired)

Deco M9 plus not connecting to websites (wired)
Deco M9 plus not connecting to websites (wired)
2020-10-08 07:58:35 - last edited 2020-10-09 23:49:11
Hardware Version: V2
Firmware Version: 1.4.2

I set up the M9 plus today and have no issues accessing internet etc through the wireless network. The issue is the wired connection to my pc. It shows that I have an active internet connection (I can ping IP and Domains successfully), however cannot load web pages. Only google based pages seem to work (youtube, maps etc) but they take forever to load (if at all). Have tried too many fixes to mention here and am at a loss as to the root problem. Any help would be appreciated.

0
0
#1
Options
1 Accepted Solution
Re:Deco M9 plus not connecting to websites (wired)-Solution
2020-10-09 23:48:56 - last edited 2020-10-09 23:49:11

@Tony 

 

Mate it ended up being the network adapter. I tried a different Ethernet adapter and it works now. Not sure what was wrong with that Aquantia adapter but it was the issue. 

Recommended Solution
2
2
#7
Options
6 Reply
Re:Deco M9 plus not connecting to websites (wired)
2020-10-08 17:00:17

@Shane54 

 

Manually configure your network adapter settings in trying different DNS servers. Something may be up with the IPV4 settings in your network card since the Wi-Fi works. Also, if you haven't done so update the drivers to the latest as something to check off.

0
0
#2
Options
Re:Deco M9 plus not connecting to websites (wired)
2020-10-08 19:44:48

@Tony 

 

Thank you for your reply. All my network adapters are up to date. I tried five different DNS servers and the issue was not resolved. 

 

I should clarify that the PC is wired only and my mobo does not have wifi. All other devices on the wireless network - phones, laptop and TV work fine. 

 

Basically web pages cannot resolve and forever try to load. I have also tried a range of different browsers, flushed DNS, reset winsock etc. 

0
0
#3
Options
Re:Deco M9 plus not connecting to websites (wired)
2020-10-08 22:07:18

@Shane54 

 

Go into the Deco app, and look in the parental controls, mainly to see if the computer might have been accidentally added to a child profile or teen.

 

Others things I would try is to connect to a different Deco node.

 

To see if it may be something related software wise on the computer, boot the computer in safe mode with networking to see how that works. Probably have done it, but swap the cable too at this point.

0
0
#4
Options
Re:Deco M9 plus not connecting to websites (wired)
2020-10-09 00:44:13

@Tony 

 

Tried everything you suggested but the problem still exists. I don't think it is the ISP as my previous setup was working fine. Unfortunately that modem/router died so I can't test this with my old setup. 

 

Seems like something is throttling the wired connection but I can't pinpoint what. 

0
0
#5
Options
Re:Deco M9 plus not connecting to websites (wired)
2020-10-09 21:00:47

@Shane54 

 

Please reach out to your local support team here: https://www.tp-link.com/support/

0
0
#6
Options
Re:Deco M9 plus not connecting to websites (wired)-Solution
2020-10-09 23:48:56 - last edited 2020-10-09 23:49:11

@Tony 

 

Mate it ended up being the network adapter. I tried a different Ethernet adapter and it works now. Not sure what was wrong with that Aquantia adapter but it was the issue. 

Recommended Solution
2
2
#7
Options