Deco S4 Slow wifi

Deco S4 Slow wifi
Deco S4 Slow wifi
2020-10-10 03:19:56
Model: Deco S4
Hardware Version:
Firmware Version: 1.4.3 20200918 Rel 77820

I have just installed the Deco S4 with 3 units. I have Verizon FIOS service with an Ethernet connection from the FIOS ONT to the base S4 unit on first floor. Second unit is in second floor hallway and third unit is in the third floor hallway. I have 300 Mbps service. By way of an Ethernet connection to the base unit, I get speeds around 280 Mbps on a MacBook Pro.. However, wifi speed 3 feet from base is only around 50 Mbps. Same on my iPhone 11, 50 Mbps. Second and third units get wifi speeds around 40. I know I'm not going to get 280 via wifi, but I thought I would get at least 100. I'm a novice and don't really know what to check or change to improve wifi speeds. Suggestions welcome. Thanks. 

0
0
#1
Options
2 Reply
Re:Deco S4 Slow wifi
2020-10-12 16:14:39

@ScottDR6 

 

Sounds like you may be on the 2.4G. If you look at the wireless setting through the app are you able to switch off the 2.4G? If so, if you test the speeds again what do you get?

0
0
#2
Options
Re:Deco S4 Slow wifi
2020-10-17 23:48:37

@ScottDR6 I have the Deco M5 and more-or-less the same thing happened to me.  I have FIOS which I changed plans from 50 Mps to 200 Mps.  The Deco Internet Speed Test was getting close to 300 Mps up and down, but my phone and computers were only getting 60-80 Mps.  As it turns out the QOS setting had the max speed set to the older 50 Mps plan.  I am not sure if I had set this or not.  Going to the QOS setting atomatically sets this to the max speed of the Deco Internet Test Speed.  I saved the setting and now my devices get the 300 Mps.

0
0
#3
Options
Related Articles