Problems connecting the slave deco behind the switch

Problems connecting the slave deco behind the switch
Problems connecting the slave deco behind the switch
2020-10-13 12:58:14 - last edited 2021-08-19 10:28:45
Model: Deco M4
Hardware Version: V2
Firmware Version: 1.4.2 Build 20200727 Rel.37987

Hi community

I have this schema in my home.. but i have a problem in the basement.

When i connect slave deco through ethernet cable into the switch... response times with LAN & WAN are very bad

If I disconnect the cable, slave deco works well trougth WIFI connection... but slower than ethernet

if I connect the slave between the router and the switch works well... but I prefer connect switch to the router directly (layer 2) because the cable goes through the wall and it is a cat6. In the basement I have the office and other components such as a 4k multimedia server etc. and I think it is not necessary pass all that traffic through the slave Deco.

 

Deco are configured as access-point not router.

Any idea why the deco connected behind the switch breaks all my basement connectivity?

 

Thanks in advance.

 

 

0
0
#1
Options
1 Accepted Solution
Re:Problems connecting the slave deco behind the switch-Solution
2021-08-19 07:30:21 - last edited 2021-08-19 10:28:45

@jgcortizo I had a similar set-up, didn't work either. Eventually I found this post that sorted all my problems... https://community.tp-link.com/en/home/forum/topic/98898

 

 

Apparently, you need to put the main Deco between the modem and switch.  

Recommended Solution
1
1
#6
Options
6 Reply
Re:Problems connecting the slave deco behind the switch
2020-10-13 17:58:56

@jgcortizo 

 

If you get better performance having the slave in front of the switch then that would be a better option. Given the TP-Link switch is an unmanaged switch I am not sure what else you can do?

 

It could possibly be the cable from the Deco to the switch? Or the port?

 

You could also swap the first floor Deco with the basement Deco to see if the issue follows the Deco or stays at the location. if it stays at the location, then have the router go to the basement slave, then the switch after.

0
0
#2
Options
Re:Problems connecting the slave deco behind the switch
2020-10-15 11:56:16

@Tony 

 

Thanks Tony for your response,

 

but... I think the best option is the one I have drawn, not to put the slave in the middle ...No error in the connectivity design... except doesn't work.

that's why my question was...Why slave doesn't work behind the switch? they are from the same brand also..

 

I would like have all deco nodes connected trouhtg ethernet to get maximun speed... but now, basement node is connected to main node via WIFI.

Doesn't make sense to me.

 

Regards

 

 

 

0
0
#3
Options
Re:Problems connecting the slave deco behind the switch
2020-10-15 20:18:27

@jgcortizo 

 

My suggestions from post #2 were mainly to see if you see anything different as far as speeds. I understand you would like the topology a certain way, but it was suggested to see if there is an issue or it will run the same speeds either way it is set up. 

0
0
#4
Options
Re:Problems connecting the slave deco behind the switch
2020-10-16 12:41:11

@jgcortizo I think it's because you are creating a loopback. The slave is connecting to the network via Ethernet and WIFI, so it's connecting to itself and sending network traffic around and around creating a loopback effect. 

1
1
#5
Options
Re:Problems connecting the slave deco behind the switch-Solution
2021-08-19 07:30:21 - last edited 2021-08-19 10:28:45

@jgcortizo I had a similar set-up, didn't work either. Eventually I found this post that sorted all my problems... https://community.tp-link.com/en/home/forum/topic/98898

 

 

Apparently, you need to put the main Deco between the modem and switch.  

Recommended Solution
1
1
#6
Options
Re:Problems connecting the slave deco behind the switch
2021-08-22 05:48:20

I read this thread several times since the 'solution' was posted and didn't understand it (mostly because the diagram in the solution post was not clear which form was to be used). Then I followed the link to the other thread where the diagram came from and now it is clear. However, the original poster has not responded and I wonder whether he has solved his problem yet.

 

@jgcortizo  says his Decos are in AP mode, and the solution post in the other thread says either topology works for AP mode. "You can connect all the Deco units directly to your home modem/router/switch as you want. The system will work as expected."

 

But that other thread also says "If you have switches on the network and find Ethernet Backhaul not working, please check the management IP address of your switches. It's possible that some switches adopt 192.168.0.1 (which is the same as the LAN IP address of the main Deco) as the management IP, which may cause some conflicts on the network. In this case, it's recommended to change the management IP address of switches to another subnet." I suspect this might be the root problem for jgcortizo and would explain the bad ping times and lost pings.

 

0
0
#7
Options