All devices except randomly only one can't connect to the Internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

All devices except randomly only one can't connect to the Internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
All devices except randomly only one can't connect to the Internet
All devices except randomly only one can't connect to the Internet
2020-10-18 14:52:16 - last edited 2020-10-18 15:42:18
Model: TL-WR845N  
Hardware Version: V4
Firmware Version: Latest

My new setup for the past month is very simple. 


My TL-WR845N router is connected to ONU via its WAN port. ONU connected to the OLT over Fiber. The WAN connection is over PPPoE. In the TL-WR845N, the username and password for the PPPoE connection is saved and it connects instantly when switching on the TL-WR845N Router or going through the disconnect/connect sequence in the web utility. 


This particular router only supports 2.4Mghz mode. The ISP only supports IPv4. I have configured the LAN side DNS to and while the WAN side DNS is left default to whatever is assigned by the ISP. There is NO cloning of the MAC address enabled on TL-WR845N (which is default setting). All the LAN side addresses are assigned via DHCP in the default x.x x.100 to x.x x 199 range. TL-WR845N has the latest firmware updated. All other settings are not changed and left to their default. There is no MAC address filtering or another security setup which is changed.  


There are usually 5 or 6 devices connected to the TP-WR845N router. They all get full speed internet. I also have a 4G mobile hotspot wifi router and mobile hotspots on my phones as a backup, each with with a separate SSIDs. Therefore I have always 3 back ups to access internet in addition to FTTH connection through TL-WR845N. None of the devices are connected to TL-WR845N over ethernet cable. All connect via its wifi interface.


Below problems occur when the internet connectivity is definitely NOT down. 


Problem 1: 


Occasionally any one device randomly (let's call this device as X) will be able to connect to the wifi of TL-WR845N but NOT be able to access internet, while reset of devices connected to TL-WR845N can access the internet. If I switch X to connect to any of the  mobile hotspots wifi,  X connects to the internet in a heartbeat. I change X to connect back to TL-WR845N, it immediately connects to WiFi but no internet.


I have tried all of below to troubleshoot: (note that all other devices can connect to internet when troubleshooting, except X):


Forget or delete WiFi SSID from X and retry. The problem off not and to access internet doesn't get solved. 


Delete the ARP table entry of X from the TL-WR845N. Then connect X to TL-WR845N. Again no internet on reconnection to TL-WR845N. 


Reset X by power off and power on sequence, connect to TL-WR845N. No internet access.


Change the SSID name for the TL-WR845N's WiFi interface. Connect X to the new SSID. No internet connection. 


Reboot TL-WR845N, either through the web utility or by unplugging there power cable and putting it back in after ten seconds. This may or may not work. It is random. 


Reboot the ONU while doing any of  the above steps. 


Note that the X here can be an Android phone, iPad or windows 10 PC. All have latest OS and software updates. Therefore this is not a device specific issue. I don't believe it is an ISP issue either since all other devices can access the internet just fine. 


I witness this behavior occuring randomly three times in a month. 



Problem 2:


This is same as Problem 1, but occurs on one specific device a lot more consistently. It is a Lenovo phone running Android 6.0. It is used by my grandparents for whatsapp and youtube. Let's call this device as P.


Every couple of days P suffers from Problem 1. All devices can connect to internet but not P. Switch P to connect to any of the mobile hotspots, it connects to the internet without a problem. Switch it back to connect to the TL-WR845N wifi interface and no internet access. 


I have tried to get P to be signed the same IPv4 address outside of x.x.x.100-199 range by going into the TL-WR845N web utility and reserving a IP addresses for its MAC. This shouldn't make a difference but as network protocol development engineer, wanted to eliminate possibility of any DHCP bug causing the issue. That didn't help either. DHCP implementation in TL-WR845N is unlikely to because this problem. 


I have personally spent an hour or so, twice, to try to get P to be able to access the  internet following the steps I described in Problem 1, including resetting P and resetting its network settings from Android menu. Nothing works. 


One thing I have observed that works is the following sequence: 


1. In P's wifi settings - Forget the SSID belonging to TL-WR845N. 

2. Switch off WiFi on P.

3. Switch off TL-WR845N for ten seconds. 

4. Power on TL-WR845N after ten seconds. 

5. Connect a device other than P to the TL-WR845N first (optional step at times). 

6. Switch on WiFi on P.

7. Reconnect to SSID of TL-WR845N and re-enter the password. 


The above has worked three times so far. But it is frustrating to go through this. It is hard for grandparents to be able to do it on their own when I am remote. 


I am a network protocol development engineer with 15+ years experience. Therefore I know more about possible protocol related problems than average ISP engineers or the support staff of wifi router manufacturers. I have been using WiFi and DSL, Cable Modem, FTTH for 20+ years. I have done plenty of troubleshooting for connectivity problems with WiFi, internet 2G, 3G and 4G in my life. I have used DD-WRT and other open source implementations to modify stock wifi routers operating systems. But this particular problem has me puzzled. I don't have a network sniffer to understand what is exactly going on. The systems log of TL-WR845N is of no help in this particular situation. 


I have narrowed down the problem to three possible issues:


1. For some reason the P's MAC address is getting exposed somewhere in the ISP network and gets blocked. However this should not happen since TL-WR845N is in NAT mode. Indeed if this is happening TL-WR845N has a bug in its NAT implementation. 


2. There is a bug in the TL-WR845N's MAC clone function. It is randomly leaks the MAC address of a device that connects to it randomly. That is the only reason I can think of P (a specific device) and X (any random device) facing the problem of NOT being able to access internet when all other devices can access internet. At the same time P or X,  if switched to a different wifi of a mobile hotspot have no issues connecting to the internet. It still doesn't explain why this issue is more persistent with P (Lenovo Android 6.0 phone). 


3. The problem is at the device end and there is incompatibility between some protocol the way it is implemented in the P and on the TP-WR845N side. But then on lesser occasions, I seen it happen with windows 10, ipad, and Android 9.0 and 10.0 phones. 


I am fairly certain there isn't any limit set on the number of devices that can connect to TL-WR845N as LAN clients, that is causing the problems. There have never been more than six LAN clients connected. Usually the problem happens when only two devices are active or only P is the active device connected to TL-WR845N.


It is very hard to explain all this to the ISP guy in first place. And then ask them to troubleshoot what is happening at their end. I can't tell if the TL-WR845N router is forwarding packets received from P on to its WAN interface.  My internet FTTJ provider is a very small ISP, not a big one like Jiofiber or Airtel fiber or Youbroadband fiber (Indian ISPs). They are hardly ever reachable or responsive most of the time. Even if I am were to be able to explain them, they do not have skills to investigate the equipment on their side of the network. (when I was getting 1/10th of my download speed but full upload speed, the ISP guy told me that the 100Mbps FE WAN port of my router needs to be a gigabit ethernet and I needed a GE router for 50Mbps symmetrical internet speed. I had to question his logic, telling him that if the upload is full speed (i.e 50Mbps), then there is no physical ethernet port issue for the download at 50Mbps. I told him there is a provisioning issue at their end. I asked him if he can test the speed from their side coming into to OLT and then ONU. Since there are only 4 or 5 subscribers connected to the OLT, there can't be congestion on the download. And they he needs to make sure my PPPoE account is provisioned properly. After a few days magically started getting consistent  upload and download speed I am subscribed to). 


This particular issue would be beyond most average users as well as support personnel of large ISPs. 


Has anyone faced a similar issue with TP link routers? Is there any TP support engineers who participated or monitor this thread? Have I missed anything?





3 Reply
Re:All devices except randomly only one can't connect to the Internet
2020-10-20 18:10:39 - last edited 2020-10-23 22:42:40



Thank you for the information given.


Are the X and P devices able to ping other devices on the network and the gateway or another device to that affected device?


As I was reading all the troubleshooting which looks like all you are able to do I thought of what you mentioned. The fact of the router possibly being hampered. For six devices I would not expect that, but the symptoms give the same random pattern. 


In one case it was a user that had smart plugs, more than ten, but had the same random pattern.


The router could be malfunctioned? I would expect the router to handle at least about ten.


Do you happen to have an extra router or access point to connect to the TL-WR845N, disable the Wi-Fi on the 845, and let the new connected device handle the wireless devices?

Re:All devices except randomly only one can't connect to the Internet
2020-10-23 12:07:59



Thanks for your reply. 


The devices connected to the WiFi, i.e is the LAN side can ping each other. There is no problem for either X or P duce's to reach other devices on the WiFi subnet or the gatewaty up address (which is the LAN IP address of TL-WR845N set to x.x.x.1). TL-WR845N can ping the IP address assigned to P or X as well as and 8.8.8 8 or another public DNS server on the WAN side  It is only getting to the WAN that is the issue. 


I do have a DD-WRT wifi router connected via Ethernet cable to the TL-WR485N. That is to extend the network to other part of the house across two walls. The DD-WRT has the DHCP set to forward to the TL-WR485N. It is on the same subnet as the TL-WR485N. DD-WRT has everything turned off - NAT, DHCP, WAN forwarding. Therefore it acts like a WiFi access point on the same sub-net with same SSID. The devices have no problem connecting to either wifi router and connecting to the internet. For troubleshooting I disconnected the DD-WRT's LAN connection to the TL-WR485N. That would isolate TP-WR485N completely. 


One thing I have observed is that this happens when perhaps when only X or P are the devices directly connected to TL-WR485N's wifi interface and no other devices are showing up in the client table. Connecting subsequent devices to the TL-SR485N's wifi interface works just fine and those devices can access internet. It is like once all devices go into sleep mode and are not active on the network, and then the first device that wakes up and connects back becomes X or P. And the router's NAT probably for reason malfunctions with the first device that reconnects. The second and rest of the devices don't face the same problem. 


I don't know how to consistently reproduce the problem. 


I could do what you suggested with letting DD-WRT's wifi interface be on and switch off TL-WR485N's wifi interface. I am now remote and no longer where the set up is. I don't remember if there is a way to shut off TL-WR485N's wifi radio or wifi interface? Do you suggest to shut it off when X or P are unable to connect or to run this set up permanently to see if problem occurs?


I don't see wifi radio or interface driver to be an issue. That is because I can ping to the P or X from the devices that are attached to the DD-WRT's wifi interface. So those ping packets are going from the DD-WRT wifi side to its LAN ethernet interface to TL-WR485N's LAN ethernet interface to its wifi interface and then to X or P. The ping response packets are traveling in the opposite direction. 


It is still something about NAT or MA'C address of P or X getting blocked as if MAC based filtering is on 

Re:All devices except randomly only one can't connect to the Internet
2020-11-05 18:07:50



I was able to get a beta firmware that you can potentially try. Please note this is for UN versions of the hardware. If you look below the router label rather than it being a country code like (US) or (UK) see if it says (UN). If so, use the link below and update the router with that.


The build is 190627 (date = June 27th 2019), if your build is newer then don't upload it.



Helpful: 0

Views: 721

Replies: 3