Deco M9 Plus keeps blocking important websites / ip's / mail

Deco M9 Plus keeps blocking important websites / ip's / mail
Deco M9 Plus keeps blocking important websites / ip's / mail
2020-12-30 12:59:42 - last edited 2020-12-30 13:04:10
Hardware Version: V2
Firmware Version: 1.4.3 Build 20200921 Rel. 42500

Some websites (ie. my vps that is running my webapp, hosted by knownhost.com) just won't connect at all. Also the emails from this server can't be retrieved resulting in an error message. Once I switch to mobile connection all issues are gone and everything works perfectly. I faced these issues the moment I replaced my old powerline adapters with this new Deco M9 Plus set.

 

I tried the following but I am lost now:

- I updated the firmware of all 3 M9 router devices

- No parental controls installed

- I turned off all 3 'Antivirus' options.

- I changed the DNS servers to 8.8.8.8 and 8.8.4.4 but this couldn't solve the issue. 

- I set the Deco in both router / access point mode, but the issue remains.

- I used different devices as my macbook / iphone / ipad and i can access this website when i switch to mobile connection instead of the M9 wifi. So it's not device related.

 

Any suggestions would be highly appreciated!

 

Best,

Steve

1
1
#1
Options
3 Reply
Re:Deco M9 Plus keeps blocking important websites / ip's / mail
2020-12-31 19:49:34

Found a solution, i needed to turn my modem in bridge mode and set the M9's in router mode. This fixed all the issues for me.

0
0
#2
Options
Re:Deco M9 Plus keeps blocking important websites / ip's / mail
2020-12-31 20:09:54

@SVDNL with modem in bridge & M9 in router modes, do you need to set M9 manually or just automatically as usual.

Do you have problem with isp modem in router & M9 in router too?

0
0
#3
Options
Re:Deco M9 Plus keeps blocking important websites / ip's / mail
2020-12-31 20:17:25 - last edited 2020-12-31 20:17:52

@47Cosmos 

First make sure after you turn your modem in bridge mode, you turn it off for a few minutes. Set your deco m9's in router mode (without the cables connected) to the modem. Turn the modem on and wait until it's fully rebooted. Then connect the cable between both devices. Set the deco m9's to automatically. I had issues with the modem in router mode and the deco in router Or AP mode. The settings above fixed all issues for me. Also all 3 antivirus options are all checked now and I can access any website without issues.

0
0
#4
Options