TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
2021-01-07 20:12:24
Model: TL-WA801ND
Hardware Version: V6
Firmware Version: 0.9.1 3.16 v0001.0 Build 200116 Rel.61815n(5553)

I have been trying to figure out why some of my smart home devices refuse to work with this particular access point when they work on every other one I own. I have some Yeelight smart lights that use modified SSDP (Simple Service Discovery Protocol) which is part of UPnP to my understanding. I use Homebridge (a docker container that communicates with non-homekit certified devices and allows you to control them via Apple homekit). It works perfectly on any other device but in both AP and mutli-SSID modes this device seems to outright block this traffic. I have recorded both the packets sent by homebridge (the "hello out there" packets) in Wireshark as well as the same packets from the smart lights. Homebridge is on the wired connection and the lights are connected to the wifi. I can see both devices' packets on the wired/wifi connections respectively using Wireshark and tcpdump but they do not pass from wifi to wired and vice versa. There is no option to enable UPnP in the device and I have been told it is on the latest firmware. I have also reset to factory and the issue persists. Homebridge immediately finds the lights and communicates with them when I use another acess point but this one does not work in any scenario. As this is functioning as an AP, it should not be blocking multicast or any other packets. The packets in question are basically an announcement to the UDP multicast address 239.255.255.250 on port 1982. This page outlines how this process works and on what protocols, ports, etc: https://www.yeelight.com/download/Yeelight_Inter-Operation_Spec.pdf

 

Has anyone else had this issue? Thanks in advance!

0
0
#1
Options
5 Reply
Re:TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
2021-01-07 21:34:09

@Bn624 

 

In range extender mode it will copy the wireless security settings of your original router. If that seemed to work, have you tried changing the settings or looking at your router, and have the TL-WA801N reflect that. For example, copying the channel, width, and version/encryption (wireless security). In the wireless advanced menu of the 801N, make sure the client isolation is also not enabled.

0
0
#2
Options
Re:TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
2021-01-07 21:45:58

 

Tony wrote

@Bn624 

 

In range extender mode it will copy the wireless security settings of your original router. If that seemed to work, have you tried changing the settings or looking at your router, and have the TL-WA801N reflect that. For example, copying the channel, width, and version/encryption (wireless security). In the wireless advanced menu of the 801N, make sure the client isolation is also not enabled.

@Tony 

 

Wireless isolation is not enabled. As far as the repeater/bridge mode, I guess I should have provided a bit more context to my setup. I have a Dell Server running ESXI with a PFSense 2.4 box running on it. The access point plugs into the back of the server using the VLANS set in PFSsense to create the different SSID's. There is no existing wireless network, the access point serves to extend the existing wired network from PFSense to wireless clients. I have tried both AP and multi-SSID mode because I can move the homebridge virtual machine into the trunk network so the access point can work in AP mode without using the VLANS.

0
0
#3
Options
Re:TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
2021-08-13 23:32:51

@Bn624 I think I am having the exact same issue as you. Multicast is set up perfectly on my cisco switch (which acts as my gw) but this access point is blocking all multicast traffic in multi-SSID mode. Same exact AP, same exact issue with Home Assistant and trying to connect to it with my iDevice. Home Assistant can communicate with all my stuff and is wired, none of my wireless devices can. Soon I will have to buy a better AP as I've had nothing but issues with this one.

0
0
#4
Options
Re:TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
2021-08-14 21:34:32

@lunanet_ 

lunanet_ wrote

@Bn624 I think I am having the exact same issue as you. Multicast is set up perfectly on my cisco switch (which acts as my gw) but this access point is blocking all multicast traffic in multi-SSID mode. Same exact AP, same exact issue with Home Assistant and trying to connect to it with my iDevice. Home Assistant can communicate with all my stuff and is wired, none of my wireless devices can. Soon I will have to buy a better AP as I've had nothing but issues with this one.

They basically stopped responding. I did eventually find a workaround however. Use Wireshark or TCPdump to capture the multicast traffic or "hello's" from your smart devices on the wireless network and use tcpreplay to replay that capture on the wired network. Can't tell you why but once you do that multicast passes normally. 

0
0
#5
Options
Re:TL-WA801N V6.8 Blocking Multicast Traffic in AP/Multi-SSID Modes
2021-08-15 09:00:01

@Bn624 cheers I'll try that in a bit. Once I get the money I'll have to get a new AP

0
0
#6
Options