AX11000 changes the IP when setting my Pi-hole as the DNS server

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

AX11000 changes the IP when setting my Pi-hole as the DNS server

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
AX11000 changes the IP when setting my Pi-hole as the DNS server
AX11000 changes the IP when setting my Pi-hole as the DNS server
2021-09-16 02:27:39 - last edited 2021-11-17 05:39:19
Model: Archer AX11000  
Hardware Version:
Firmware Version:

Just bought this tonight - replacing my eero 5 base + 2 beacon setup.

My Pi-hole server is set to 192.168.1.100.  Set my DCHP server from 192.168.1.1 through 192.168.1.100.  Set my Raspberry Pi running the Pi-Hole to a static 192.168.1.100. As soon as I change my DNS server to 192.168.1.100, the router seems to almost lock up.  When I log back into it, I get the following message:

 

"To avoid IP conflict with the front-end device, your router's IP address has been changed to 192.168.0.1"

 

I also tried the whole thing under the 192.168.0.1 scheme - that just results in the same message but putting the router back to 192.168.1.1.  This was never an issue with the eero nor the Asus AC3200 I had before that.  

 

No Pi-hole = this thing is going back to Costco unless it can be fixed.  Firmware is up to date.  I saw a couple of Reddit threads with the same problem from 1-2 years ago on different TP-Link routers but no resolution was ever posted.  

  2      
  2      
#1
Options
1 Accepted Solution
Re:AX11000 changes the IP when setting my Pi-hole as the DNS server-Solution
2021-09-16 12:01:44 - last edited 2021-11-17 05:39:19

Resolved the issue myself.  

Do NOT set the DNS to anything on the LAN under the Internet tab.  Instead, go to the DHCP tab and enter it there (where it says optional).  Very confusing and I'm not sure the purpose in having it for both.  Regardless, I see DNS traffic going across my Pi-hole, so it is working.

Recommended Solution
  10  
  10  
#2
Options
1 Reply
Re:AX11000 changes the IP when setting my Pi-hole as the DNS server-Solution
2021-09-16 12:01:44 - last edited 2021-11-17 05:39:19

Resolved the issue myself.  

Do NOT set the DNS to anything on the LAN under the Internet tab.  Instead, go to the DHCP tab and enter it there (where it says optional).  Very confusing and I'm not sure the purpose in having it for both.  Regardless, I see DNS traffic going across my Pi-hole, so it is working.

Recommended Solution
  10  
  10  
#2
Options

Information

Helpful: 2

Views: 2082

Replies: 1

Related Articles