DEFAULT GATEWAY LOG IN page not SECURE

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

DEFAULT GATEWAY LOG IN page not SECURE

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
DEFAULT GATEWAY LOG IN page not SECURE
DEFAULT GATEWAY LOG IN page not SECURE
2022-02-15 22:06:44 - last edited 2022-02-16 02:09:12
Model: Archer AX50  
Hardware Version:
Firmware Version:

OK ... I am certain that others have had this experience, but I have not seen it mentioned in these forums so far.

 

I have changed my Default Gateway IP address to a 172.28.?.? network setting, which is the same for all practical purposes as using the default 192.?.?.? network. I just prefer the 172.

 

So ... when I log in to the router management page to do any settings adjustments ... in the address bar at the top of the browser page (see attached image) ... it registers as a "NOT SECURE" page. I am on a VPN and the router is set up - to the best of my knowledge - as secure as I know how to make it.

 

So I guess that I ought to make this VERY clear ... I most certainly am able to LOG IN to the router management page and configure all settings to my hearts content, and have them all register correctly as I have desired.

 

I am ONLY concerned with the log-in page of the router being NOT SECURE, and how I might secure it.

 

I live in a very "crowded" wi-fi neighbourhood, and I, as I am certain everyone here is as well, concerned for the security of my online activity.

 

Again, how may I "MAKE" my default gateway address log-in page register as secure, or, HTTPS://?

 

I am using an ARCHER AX50 - latest firmware update. I am on a KINETIC fiber ISP, and everyting is working as it should from that end. The VPN functions perfectly. This behaviour is the same on BOTH WIN 10 & WIN 11 (both with ALL latest updates). Browser, is irrelevant as they all behave the same way.

 

I would love to hear from anyone that has faced this issue, and can explain how to achieve the result that I am after.

 

My concern is this: If I can log in to my router, because it is an un-secure, or HTTP:// page, perhaps anyone in the neighbourhood may be able to as well.

 

Thanks for your assistance.
 

Sincerely, MGBJAY

 

 

f96320f834d2403e9d8e483683a85ac3

  0      
  0      
#1
Options
2 Accepted Solutions
Re:DEFAULT GATEWAY LOG IN page not SECURE-Solution
2022-02-16 00:07:48 - last edited 2022-02-16 02:09:21

  @MGBJAY 

 

There is no issue with the security on your router login page and this warning is unrelated to your IP configuration change.  The more likely explanation is that you also recently enabled secure connections for local management in your router settings.  Enabling this setting will force your browser to encrypt all communications when accessing your router web configuration interface. 

 

By default, this setting is disabled and all communications are unencrypted at the http level.  (Note, wireless communications will still be encrypted at the wifi level if the wifi network in use has some type of security in effect, but anyone already with access to your network may be able to monitor all unencrypted data transmitted on the network.)  When http encryption is disabled, your browser address bar will show the router url address as an unsecure "http://... " connection (no trailing s).

 

The reason you are seeing a warning in your browser now is because you've enabled encryption, which changes the url address to a secure "https://..." connection.  However, as you have no certificate signed by a third party authority, your browser flags the uncertifiied https url as "unsecure".  This only means that the browser has no way of verifying that the page being displayed is from the server it claims to be from.  This issue is important for public servers (such as your email, financial accounts, etc) as it's important to ensure that you are actually connected to the authentic, remote server before you submit any confidential or sensitive information (such as login credentials).

 

However, for local devices such as your own router, there is no need to have a certificate authority verify the connection as the internal IP address you use to connect to your router is private and will only be accessible within your network.  You are connecting to your router internal LAN interface, so you are responsible for confirming you are connected to the correct server.  Basically, you can safely ignore the browser warnings displayed for your router web interface (i.e. follow the browser prompts to proceed with the connection).

 

However, if you absolutely want to remove the browser warnings, then you can disable the secure connection option.  It's usually found under System > Administration > Local Management.  But it's actually recommended that you keep this setting enabled as doing so keeps your connection encrypted, which actually helps keep your connection "secure" from eavesdropping.  In other words, disabling the setting will remove the warnings but also remove the encryption.

 

4c601dfd73024a49ae3ad19d069741bb

Recommended Solution
  6  
  6  
#2
Options
Re:DEFAULT GATEWAY LOG IN page not SECURE-Solution
2022-02-16 01:38:44 - last edited 2022-02-16 02:09:12

  @MikeS21

 

@MikeS21, Excellent. 

 

Thank you for your precise and helpful answer. This has had me puzzled for some time, and I am satisfied now that I have had the settings correct al along.

 

I DID NOT know about the details you covered and after reading that through a few times, it makes sense. I can leave it as it is and find something else to fret over now.

 

Not!

 

I appreciate your thoughtful and complete response without giving me a bunch of information that had nothing to do with the issue at hand. Direct and to the point.

 

Sincerely,

 

MGBJAY

 

Recommended Solution
  3  
  3  
#3
Options
2 Reply
Re:DEFAULT GATEWAY LOG IN page not SECURE-Solution
2022-02-16 00:07:48 - last edited 2022-02-16 02:09:21

  @MGBJAY 

 

There is no issue with the security on your router login page and this warning is unrelated to your IP configuration change.  The more likely explanation is that you also recently enabled secure connections for local management in your router settings.  Enabling this setting will force your browser to encrypt all communications when accessing your router web configuration interface. 

 

By default, this setting is disabled and all communications are unencrypted at the http level.  (Note, wireless communications will still be encrypted at the wifi level if the wifi network in use has some type of security in effect, but anyone already with access to your network may be able to monitor all unencrypted data transmitted on the network.)  When http encryption is disabled, your browser address bar will show the router url address as an unsecure "http://... " connection (no trailing s).

 

The reason you are seeing a warning in your browser now is because you've enabled encryption, which changes the url address to a secure "https://..." connection.  However, as you have no certificate signed by a third party authority, your browser flags the uncertifiied https url as "unsecure".  This only means that the browser has no way of verifying that the page being displayed is from the server it claims to be from.  This issue is important for public servers (such as your email, financial accounts, etc) as it's important to ensure that you are actually connected to the authentic, remote server before you submit any confidential or sensitive information (such as login credentials).

 

However, for local devices such as your own router, there is no need to have a certificate authority verify the connection as the internal IP address you use to connect to your router is private and will only be accessible within your network.  You are connecting to your router internal LAN interface, so you are responsible for confirming you are connected to the correct server.  Basically, you can safely ignore the browser warnings displayed for your router web interface (i.e. follow the browser prompts to proceed with the connection).

 

However, if you absolutely want to remove the browser warnings, then you can disable the secure connection option.  It's usually found under System > Administration > Local Management.  But it's actually recommended that you keep this setting enabled as doing so keeps your connection encrypted, which actually helps keep your connection "secure" from eavesdropping.  In other words, disabling the setting will remove the warnings but also remove the encryption.

 

4c601dfd73024a49ae3ad19d069741bb

Recommended Solution
  6  
  6  
#2
Options
Re:DEFAULT GATEWAY LOG IN page not SECURE-Solution
2022-02-16 01:38:44 - last edited 2022-02-16 02:09:12

  @MikeS21

 

@MikeS21, Excellent. 

 

Thank you for your precise and helpful answer. This has had me puzzled for some time, and I am satisfied now that I have had the settings correct al along.

 

I DID NOT know about the details you covered and after reading that through a few times, it makes sense. I can leave it as it is and find something else to fret over now.

 

Not!

 

I appreciate your thoughtful and complete response without giving me a bunch of information that had nothing to do with the issue at hand. Direct and to the point.

 

Sincerely,

 

MGBJAY

 

Recommended Solution
  3  
  3  
#3
Options