Deco P9 sped dropped drastically and keeps fluxuatiing

Deco P9 sped dropped drastically and keeps fluxuatiing

Deco P9 sped dropped drastically and keeps fluxuatiing
Deco P9 sped dropped drastically and keeps fluxuatiing
2022-09-14 07:41:50
Tags: #speed
Model: Deco P9  
Hardware Version:
Firmware Version: 1.1.3 Build 20201228 Rel.55057

also a DECO M4R Firmware 1.5.4 Build 20220113 Rel. 38349 in my set up

 

For the last week or so my Deco P9 keeps dropping connection and when connected the download speed varies greatly from 2mbps to my normal speed of 200mbps+. I have hardwired to my ISP router and the speeds are constant and have no issues 500mbs, which implies the issues are with the Deco units. 

 

I have SIP ALG, IPv6 and QoS turned off as this seems to be the answer to most queries. I had no issues up till last week and everything was working great for the last month or more.

 

I paid a lot for my Deco's and this is just desperate and would make me stay clear of TP-link if this cannot be rectified   

 

Many thanks

  0      
  0      
#1
Options
5 Reply
Re:Deco P9 sped dropped drastically and keeps fluxuatiing
2022-09-14 16:46:59

  @tonymcgra,

Something I have started to see a few users do, is to set the QoS settings above what is expected from your ISP by increasing the bandwidth gradually, some people were able to see increases in their overall speed; although I expect this to be an unintended behavior.

 

Some things to check:

 

Is your modem in Bridge Mode? Or Providing a Wireless Network?

 

Disable UPnP on Deco.

 

What type of Internet did you select during setup? Dynamic IP, PPoE, etc 

 

What does your network setup look like? Is there a switch between the modem and router?

  0  
  0  
#2
Options
Re:Deco P9 sped dropped drastically and keeps fluxuatiing
2022-09-15 11:36:50

  @Riley_S set up in wifi router mode. All was working great for the last few months no changes. 

I have fiber to the house at 500mbps and 50mbps upload. And I get exactly that from the isp provided Fritzbox modem. And if I connect direyto the deco p9 via eithernet cable to my laptop. It's the wifi that has just bombed out completely in the last week, it's dropping to 1mbps today. I have rebooted everything and it seems to gradually rise to about 40mbps but then drops again.

 

I don't see any UPnP options in my app, so how can I disable this? Deco P9v1.

  0  
  0  
#3
Options
Re:Deco P9 sped dropped drastically and keeps fluxuatiing
2022-09-15 16:37:55

  @tonymcgra,

 

Are the speeds similar when you are connecting your laptop to the router via an Ethernet Connection;

 

The first step that is recommended for troubleshooting this case, is to replace the Ethernet cable between the router and modem. (You would be surprised at how often this is the case).

 

Otherwise, I am finding that this is the setting that you should adjust. The QoS Feature may be limited your bandwidth severely for some reason. There is also a "get internet speed" test available in this menu. Also, make sure that there are no devices with high priority to see if this is causing the issue.

 

 

Using QoS feature of Deco

  0  
  0  
#4
Options
Re:Deco P9 sped dropped drastically and keeps fluxuatiing
2022-09-16 09:58:25

  @Riley_S have checked QoS set to 1000 down and 500 up. Have no priority devices. Have be working with to support and done all checks direct cable to isp modem get 500 down 50up, cable to deco get same. On WiFi get at best today 2down 20-30up???

 

 

We have downgrade firmware last night and problem seem to be solved, but 30- 60 mins later back to 1mbps download.

 

I upgraded firmware again no change. I have now limited the devices on my network wi-fi to 1 or 2 devices blocked everything else and still desperate speeds.

 

I am at a loss, and so frustrated, if I can't fix soon these decos will get the hammer 

  0  
  0  
#5
Options
Re:Deco P9 sped dropped drastically and keeps fluxuatiing
2022-09-20 17:06:31

  @tonymcgra,

If you remove the satellite Deco node from the configuration, does the speed stay the same? I am wondering if the signal has started to degrade to such an extent that the wifi given by your powerline satellite deco, may be affecting the overall quality of the mesh network, you could try to move the satellite deco into the same room, to ensure that it is on the same circuit. 

In the deco app, you can also manually configure what backhauls are used by the individual decos, I would maybe recommend messing around with changing the decos to use a wireless backhaul, to see if the wiring in your walls is a potential cause of the slowed speeds.

 

 

I am racking my brain trying to come up with a reason why a network would have great performance and then degrade over an hour period into almost nothing, maybe the wifi settings on your Decos need to be changed to better allow devices to reconnect to the network, perhaps by changing the encryption settings for your mesh network.

  0  
  0  
#6
Options

Information

Helpful: 0

Views: 90

Replies: 5

Tags

speed
Related Articles