Archer C7 V2 Hardware NAT issues

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C7 V2 Hardware NAT issues
Archer C7 V2 Hardware NAT issues
2017-01-28 11:22:06
Model :

Hardware Version :

Firmware Version :

ISP :

My current router was getting long in the tooth and I was getting very slow wifi speeds as the walls of my house are plaster and the router is several rooms away.
Using Steam to download games (files that are 2-20GB in nature), I would get 2MB/s using wifi and around 18MB/s using a wired connection. I have a 150MB cable internet plan and I am on the Sam Knows program that tests my cable line every hour and it confirms that my download speeds are always 150MB or higher for download speeds.

So I decided to upgrade to the Archer C7 v2 after reading some great hardware reviews. After setup I tried connecting to wifi and downloading a game off of Steam. Speed quickly got up to 10MB/s and then crashed down to zero. Then it would bounce between 300KB/s and zero.

Thinking to test the wired connection I connected an ethernet cable to my laptop and had the same issue. Speed would start fast, but then quickly bounce between 300KB/s and zero.

After trying a few things I disabled the Hardware NAT. Once I did that my 5GHz wireless connection starting downloading around 19MB/s and my wired connection was around 21MB/s.

Everything is now working fine, but why did I have to disable Hardware NAT? I have several roommates who could be using the internet at the same to watch netflix or play video games. Will turning the Hardware NAT off have a negative effect during peak load times in my household?
0
0
#1
Options