TL-WN821N V3 firmware panic in Linux
TL-WN821N V3 firmware panic in Linux
TL-WN821N V3 firmware panic in Linux
2017-03-26 10:27:34
Model :

Hardware Version :

Firmware Version :

ISP :


I have a TL-WN821N V3 adaptor, it works most on first boot up, but, after pinging continuously for anywhere between 30 minutes to a few hours.

dmesg has shows firmware panic error:
usb 1-1.3.4 ath: firmware panic! execause: 0x0000000d: pc: 0x0090e11c: badvaddr: 0x10ff4038

I have tried the adaptor on several different linux mchines (rapberry pi Jessie, Linux mint, centos), it all has the similar firmware panic message after pinging for several hours.
Anyone has any idea how to fix this issue?
0
0
#1
Options
4 Replies
Re:TL-WN821N V3 firmware panic in Linux
2017-03-28 09:03:22
TP-Link has limited support for linux
1
1
#2
Options
Re:TL-WN821N V3 firmware panic in Linux
2017-04-29 20:56:09
Hi tp-link..i have a probelm in my card tl-wn821n in my kali linux 2017.1 can u help me ??????????
0
0
#3
Options
Re:Re:TL-WN821N V3 firmware panic in Linux
2019-04-25 20:24:32

Yes, it is a very well known fact TP-link is very anti-linux and even goes to such extents as to hinder linux users and purposely provide slower speeds for the linux community. 

0
0
#4
Options
Re:Re:Re:TL-WN821N V3 firmware panic in Linux
2019-04-30 18:38:01

Actually TP-Link is not anti-Linux nor do we purposefully slow down access to users using Linux.  OS compatiblity is specifically linked to the Chipset that the adapter uses.  If the Chipset is not compatible with a particualr OS or even a specific version of that OS then we would not be able to provide compatiblity.  If Linux, MacOS, or Windows 10 architecture are with in the abilites of a chipset and the manufacture said chipset makes a driver, then there would be compatiblity.   For the latest drivers for your adapter products go to that product's support page on TP-Link.com.

 

 

Best Regards 

0
0
#5
Options