TP-Link Kasa devices not syncing in Google Home

TP-Link Kasa devices not syncing in Google Home
TP-Link Kasa devices not syncing in Google Home
2020-07-23 02:48:31
Model: HS200
Hardware Version: V2
Firmware Version: 1.5.7

I recently reset my password in my TP-Link Kasa app and everything went haywire. All my devices in my Kasa app work. However, when trying to integrate them to Google Home App again it shows offline.

So here are the steps I have taken.

1. Unlinked my Kasa account in Google Home app. The unusual thing is the devices don't disappear. 

2. I reinked Kasa account to Google Home app. Same issue.

3. Reset back to old password. and redid steps 1 and 2. Issue still persist.

PS I have one Alexa device at my home, and after linking Kasa again, these devices work in Amazon Echo.

 

Any suggestions on what to try??

Thanks Ray

0
0
#1
Options
2 Reply
Re:TP-Link Kasa devices not syncing in Google Home
2020-07-24 17:39:31

@RayI 

 

All the services are showing they are up: https://www.tp-link.com/us/support/cloud-service-status/

 

When I loaded the Google Home app and linked my account I had my plug shown as offline as well. 

 

Kasa worked, and Alexa, so I first tried to re-link the account, but it was still offline. When I relinked the account I added my plug to a room, before it was not associated with a room. Once I did that, I was able to control the plug again and it was no longer offline.

 

So that may be the key, assigning the device to a room.

 

 

0
0
#2
Options
Re:TP-Link Kasa devices not syncing in Google Home
2021-03-14 23:50:46

For me, I successfully installed and used TP-Link Kasa for my dimmer switch.  It worked with Google Home for 2 days.  Then one day it didn't.  Did the whole app reinstall on both Kasa and Google thing, including refreshing ALL devices. . .  It registered but kept saying in Google that the device was OFFLINE.  Worked in Kasa app, but not in Google.  Then I got this brilliant idea.  How about I turn off the dimmer switch and turn it back on at my fuse box.  Did so, then worked fine.  Voila.  

0
0
#3
Options