TP LINK Slim Smart Plug KP 125 “unable to add accessory” fix

TP LINK Slim Smart Plug KP 125 “unable to add accessory” fix

TP LINK Slim Smart Plug KP 125 “unable to add accessory” fix
TP LINK Slim Smart Plug KP 125 “unable to add accessory” fix
2022-08-11 04:31:38 - last edited 2022-08-11 19:10:01
Tags: #User Fix
Model: KP125  
Hardware Version: V1
Firmware Version:

Just want to share my fix for "unable to add accessory" for the KP 125 . Spent like 2 hours troubleshooting this smart plug.

 

Ultimately, I believe the issue is with the firmware not being up to date when it comes out of the box. After using a workaround to update the firmware to 1.0.8, you can factory reset the device and be able to use it as intended (with homekit and with kasa app). 

 

I was unable to add the device under the current Kasa (App Version 2.38.1). Unfortunately, I don't know the firmware version of the smart plugs out of the box. It's quite frustrating that you have to add through the apple homekit app as well, as I am use to using the kasa app for bulbs. 
 

Issue- KP125 does not add no matter how close to the router I am. Scanning the QR code to add the device, entering in the unique ID code, factory resetting, all results in the same error - "unable to add accessory". 
 

My Resolution:
 

1--add KP125 as "Smart Plug Lite/Mini" in the Kasa app instead of "Homekit Smart Plug" (Kp125 is listed as a homekit smart plug, ignore this for now)

 

2--KP125 successfully adds. This circumvents the iphone from forcing to add through homekit as well. The kasa app automatically detects a firmware update for the device. Apply the update.

 

3. after the update you will still be unable to add device to homekit. If you don't want homekit, you can use the smart plug as normal theough the app.

 

4 . if you do want homekit and ultimately , a "clean" install - remove the device from your kasa app. 
 

5. After dissociation, you can now re-add KP 125 by selecting "Homekit Smart Plug" when adding a device in the Kasa App. Homekit recognizes the device and kasa recognizes the device as well. I don't like homekit so I just removed the device from homekit after, it will still remain in the kasa app. 
 

i was able to replicate this issue on and resolve it with this method on seperate KP 125 smart plugs I bought. All had out of date firmware. After updating, I can't replicate the issue. 
 

Note: After  setting up the smart plugs, I have found that my phone doesn't need to be on my 2.4ghz network. I can forget the network on my device and be on my 5ghz network to control the devices. It's been a month since i found this error-resolution and wanted to post it here. This might be just specific to my home network setup - i am just using a single ASUS AC 3100 router. No other wifi network devices on my home except switches. For nerds, I am using dd-wrt firmware for my router. 
 

Ultimately publishing my resolution here in hopes that it help the tp-link team as well as other users. 

 

 

  3      
  3      
#1
Options
1 Reply
Re:TP LINK Slim Smart Plug KP 125 “unable to add accessory” fix
Monday

  @Jacktehdoog this didn't work for me but it got me started.  I used the Kasa app to connect as non-HomeKit, as described (note: it seems to take about 10min for the plug to show up as a regular network; before that it shows as other network and always tries to add as HomeKit).  After adding to the Kasa app, I clicked the picture for the device and then the gears to open settings.  There is an option to add to HomeKit there, I scanned the qr code, and it worked for me.  Whew!  Hint,  plug it into something where you can take a picture of the code while it is plugged in.  You can move it after it is connected.

  0  
  0  
#2
Options