Kasa Smart Switches and plugs dropping off network

Kasa Smart Switches and plugs dropping off network

Kasa Smart Switches and plugs dropping off network
Kasa Smart Switches and plugs dropping off network
2022-08-31 17:49:01 - last edited 2022-09-06 20:43:51

Hiya,

I have an assortment of Kasa smart plugs and switches that have been dropping off my wifi and reconnecting. This will happen repeatedly every 1 or 2 mins. To every and all Kasa devices on the network. Sometimes a few other devices on 2.4Ghz will drop too like the GE washer or dryer. B.ut not always. At least nothing as consistant as the kasa products.  The 5Ghz band seems unaffected. I can watch the client list on the router interface go from 35 to 5 and then back up to 35. Eventually some unknown combination of mashing reset buttons, power cycling router, power cycling modem, Cutting power to all switches, and heavy profanity use corrects the issue for a while untill something makes them mad again. Home assistant running or not doesn't seem to make a difference. All 11 channels on the router have been tested with no noticeable success of one over the other. I tried killing power to half of them to see if maybe I was overloading the router with devices. Firmware and mobile app claim to be up-to-date. I put a few of the switches on static IPs via mac address reservation on router. Wifi signal strength tested and seems fine in all areas of the home. So far nothing has really made a change for better or worse. I can't really nail down anything consistant yet except 2 times that I remembered it has happened right around when a "new" device was added to the network.  Then all the Kasa switches got mad. Then eventually everything started working after jacking around with it.  But before and aftere those events I have had devices jump on and off the network with no issue. So I am running out of ideas. My next idea is to write my SSID on hammer and beat it into the devices.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Kasa Smart Switches and plugs dropping off network-Solution
2022-10-26 01:10:35 - last edited 2022-10-27 16:37:08

  @sirspifalot 

 

All:

 

Just a few things for others that may experience this:

 

1)  Make sure you're not out of or low on DHCP leases.  Inet browsing can really chew these up so don't rule this out quickly.  

 

2)  Many good router/AP's have a "disconnect below signal level ABC".   While I love this (have several routers hardwired to each other), in marginal conditions this can force random drops.  (Well, they aren't random, but it would feel that way to an end-user.)   You may stabilize by using a bigger number, but don't go too big.  Upper 60's is about it, at -70 you really want a better, or multiple, routers.

 

Here is an example under "Profesional Settings"

     Roaming Assistance:   Enable - Disconnect Clients with RSSI lower than:   67db

 

3)  When router shopping, and lets all acknowledge ISP supplied routers are usually low-end, buying the fastest speed isn't the right answer.  You want the most concurrent 2.4 streams.   So you should prefer a 2.4 3x3 vs a 2.4 2x2.   Now is not the time to be cheap.

 

4)  Get your hands on an Android tablet and load a wifi analyzer.   Use it to hard set your center/control channel.   Stick to the approved non-contenting channels of 1, 6, or 11.   Politely educate neighbors using other channels or using poor "automatic" implementations.  (if in doubt on this I suggest you search for "metageek, why channels 1,6, and 11?" and read that.)

 

5)  Use 5ghz for everything you can.

 

6)  If anything in your home is using "B" try to get rid of it.  While you're at it update all code, firmware, and drivers on anything running Wi-fi.

 

7)  Force channel bandwidth to 20 mhz.  Yes, this is a little slower, but in reality you don't see it.  It's also help reduce bandwidth overlap and congestion.

 

8)  Make sure you're AP/Router isn't near a microwave.

 

9)  While not a great answer, try setting "broadcast frames" down a bit.   100 is the industry standard.  Try 75.

 

10) Schedule (assuming you can) a weekly router auto-reboot.

 

 

Luck to you,

 

-d

 

 

 

 

 

Recommended Solution
  1  
  1  
#9
Options
8 Reply
Re:Kasa Smart Switches and plugs dropping off network
2022-08-31 22:48:51

  @sirspifalot 

 

In home assitant, can you see in the device history if it became unavailable during this time. If you are using the local connection through Home Assistant, I think the plugs would still be controllable from HA. I am curious if they are disconnecting from the network or disconnecting from the cloud and receiving new network info. 

 

If the devices are reconnecting, I would think that potentially assigning the StaticIPs may help the issue. If this happens on other devices, I suspect that a router setting is to blame. What router do you have running your network?

 

The most common settings that I have seen cause issues are in regards to either fast roaming or smart connect. 

I have seen many users use their guest network to set up 2.4 GHz smart devices, to much success; as the devices will not try to ever connect to the 5Ghz band

Mobile Wi-Fi Routers Community Survey | What Would You Like to See in a Mobile Wi-Fi Router Release?
  0  
  0  
#2
Options
Re:Kasa Smart Switches and plugs dropping off network
2022-09-01 00:57:00

  @Riley_S 

 

Hiya,

The router is a Askey RAC2V1K. It is the router provided by my ISP Spectrum. It has always performed above what I expected in the past so I decided to hold on to until it became the problem. I won't be surprised or heart broken if it is the problem. I'd like to be sure though instead of just replacing unbroken hardware. I do want to point fingers at it...but I suppose innocent until proven guilty....does that apply to electronics? Any way, I scrolled through a 6 hour or so block of the Home Assistant log. It seems to track... Every few min a crapload of Kasa items become unavailable. In the 6 hour block I found maybe 3 instances where a few additional items became unavailable. I'm pretty sure I power cycled my router twice in this time period so depending on how Home Assistant handles that in the logs, some of those might have explanations. Currently I have a couple of the switches on static IP's that I setup to test, they still drop off with everything else. I suppose it still might be worth it to go ahead and finish the whole set and officially rule it out as a solution or not. I don't think my router supports a guest network. Or they really buried the option for it. Every device that I have that supports the 5Ghz is on that band in attempt to spread the load as much as I can for what its worth...I'll have to do another dig and see if I can find something to do with fast roaming/smart connect or similar settings to play with.

 

Thanks for your input on this.

  0  
  0  
#3
Options
Re:Kasa Smart Switches and plugs dropping off network
2022-09-04 07:13:24 - last edited 2023-01-05 20:01:14

  @sirspifalot 

 

Changing the wireless security setting on your wifi router from WPA/WPA2 Mixed to WPA2 Personal, fixed this issue for me.

 

I dont know why this isnt pinned to the top of the forums, seems so many are effected by this.

 

 

  0  
  0  
#4
Options
Re:Kasa Smart Switches and plugs dropping off network
2022-09-06 20:42:20

  @2DamSmart ,

Thanks for the information, I will create a KB and pin a post for the fix. I found this fix just last week and thought this may be the cause of the disconnects. I am glad that this seems to be a fix that is working for people.

Mobile Wi-Fi Routers Community Survey | What Would You Like to See in a Mobile Wi-Fi Router Release?
  1  
  1  
#5
Options
Re:Kasa Smart Switches and plugs dropping off network
2022-09-06 21:20:24

  @Riley_S 

I had a check of my router security and it was already set to WP2 personal and i still have the issue. Happened again yesterday.  Maybe I am backwards and need to set it to mixed? Hahaha.

  0  
  0  
#6
Options
Re:Kasa Smart Switches and plugs dropping off network
2022-09-06 21:51:37

  @sirspifalot 

 

it could be a "distance" issue, where your switch is getting poor wifi signal. A quick trick.. You can hold your phone near the switch and look at the wifi bars on your phone to see if the signal is low in the area you have the switch installed. Its probably fine, but something to check.

 

One other thing to try is to make sure your wifi router has been rebooted if you changed any wifi security protocals. You should also reboot, or re connect the kasa switch to the router. in other words.. delete the switch in the kasa app, then re-install it in the kasa app. This will re-establish the connectivity of the switch to the wifi router and its new or changed security protocol. 

 

 

  0  
  0  
#7
Options
Re:Kasa Smart Switches and plugs dropping off network
2022-09-06 22:44:38

  @sirspifalot,

So about that pointing fingers, I will continue looking for other possible solutions on our internal docs, but I do think that the issue will lie with a setting on your router. I was looking at my home assistant logs, and the times at which my devices do go unavailable(for like 30 seconds), all happen around the same time on days when they do happen. If you check your logbook and filter by an entity, you can see if there is a trend by looking at the times for your device.

If the router is provided by your ISP, they will usually provide a replacement router in the event of something like this. If the router is getting old, I would highly recommend looking to upgrade as the technology has changed a lot over the previous few years.

 

 

Lastly, out of curiosity are you using homeassistant to directly control things through the HA TP-Link integration or are you accessing these devices through a third party such as the smartthings integration?

 

 

Mobile Wi-Fi Routers Community Survey | What Would You Like to See in a Mobile Wi-Fi Router Release?
  0  
  0  
#8
Options
Re:Kasa Smart Switches and plugs dropping off network-Solution
2022-10-26 01:10:35 - last edited 2022-10-27 16:37:08

  @sirspifalot 

 

All:

 

Just a few things for others that may experience this:

 

1)  Make sure you're not out of or low on DHCP leases.  Inet browsing can really chew these up so don't rule this out quickly.  

 

2)  Many good router/AP's have a "disconnect below signal level ABC".   While I love this (have several routers hardwired to each other), in marginal conditions this can force random drops.  (Well, they aren't random, but it would feel that way to an end-user.)   You may stabilize by using a bigger number, but don't go too big.  Upper 60's is about it, at -70 you really want a better, or multiple, routers.

 

Here is an example under "Profesional Settings"

     Roaming Assistance:   Enable - Disconnect Clients with RSSI lower than:   67db

 

3)  When router shopping, and lets all acknowledge ISP supplied routers are usually low-end, buying the fastest speed isn't the right answer.  You want the most concurrent 2.4 streams.   So you should prefer a 2.4 3x3 vs a 2.4 2x2.   Now is not the time to be cheap.

 

4)  Get your hands on an Android tablet and load a wifi analyzer.   Use it to hard set your center/control channel.   Stick to the approved non-contenting channels of 1, 6, or 11.   Politely educate neighbors using other channels or using poor "automatic" implementations.  (if in doubt on this I suggest you search for "metageek, why channels 1,6, and 11?" and read that.)

 

5)  Use 5ghz for everything you can.

 

6)  If anything in your home is using "B" try to get rid of it.  While you're at it update all code, firmware, and drivers on anything running Wi-fi.

 

7)  Force channel bandwidth to 20 mhz.  Yes, this is a little slower, but in reality you don't see it.  It's also help reduce bandwidth overlap and congestion.

 

8)  Make sure you're AP/Router isn't near a microwave.

 

9)  While not a great answer, try setting "broadcast frames" down a bit.   100 is the industry standard.  Try 75.

 

10) Schedule (assuming you can) a weekly router auto-reboot.

 

 

Luck to you,

 

-d

 

 

 

 

 

Recommended Solution
  1  
  1  
#9
Options