How to resolve common problems when setting up the Kasa smart device (Plug/Bulb)

Released On: 2018-11-05 12:19:52Last update time: 2021-02-16 18:32:20

Our Kasa app is designed to provide an easy step-by-step process to set up your new smart device. However, there may be instances where issues come up during the installation. This guide will try and provide steps to try in order to resolve your issue.


Case 1 

  • Go into the “Settings > Wi-Fi” menu of your smartphone for Android or "Settings > Wi-Fi > Choose a network" for iOS, manually connect to the smart device's network. Open Kasa and select the option that you are manually connected to the smart device located on the bottom of the setup screen
  • Make certain you choose the correct smart device to connect to. The last four characters of the MAC address are also apart of the network name of the smart device.
  • Disable any VPN connection that your phone may be using during the setup.
  • Perform a factory default on the smart device and repeat the process.
  • If your Apple device is running iOS 14, check the app permission to allow local network access


Case 2

  • Make sure the smart device is not connecting back to your home Wi-Fi network. If so, connect back to the TP-Link Wi-Fi network.
  • Reinstall the Kasa app on your smartphone.


Case 3

  • When on the screen where you join the smart device to the network. The wireless network name you see above the wireless password box should be the one you normally connect to in order to receive internet, if not, select the link below to choose a different network name.
  • The wireless signal should be at least two bars, if it is one bar, move the device closer for setup.
  • If the router’s SSID is hidden, please choose “manually setup my Wi-Fi” to input SSID and password.


Case 4

  • Wait 15 seconds then check LED status. If the smart device's LED indicates it is connected to the network or if the bulb blinks several times, do not select the option to start over. Sign out and back into the Kasa app and wait a few minutes to see whether the device is working.
  • Check to see if your phone is now connected back to your home Wi-Fi. If not, connect back, and go back to Kasa.
  • Verify that the wireless password being used is correct. Going into your phone Settings > Wi-Fi menu. Forget the wireless network that you are trying to connect the smart device to, and then reconnect. When the phone asks for the wireless password, use the same password that you tried in Kasa. Delete the password that exists in the box and enter the wireless password for your network again.

I'm trying to set up the device and just doesn't connect to the cellphone. What can I do?


Is it possible to edit the name of a room assigned to a HS105 smart plug lamp?


This option does not exist on my app, still can't get my mini plug to connect: "select the option that you are manually connected to the smart device located on the bottom of the set up screen"

@Jack If you tried the recommended on Case 1, it would probably be worth trying on another smart device.


@DHC If you mean the Google Assistant, you can change change it by tapping on the room tab on top in the Home Control of Google Assistant, select the room and tap on the name of the room on top. A small windows will pop up with a new name that you can give the room.


@sunnshyne The screen that is referenced in Case 1 pops up when the Kasa app tries to look for the smart device. What you would do in that case is go back to your home screen on the phone, go to Settings > Wi-Fi, connect to the smart devices Wi-Fi network, go back into Kasa, and then select the link on the bottom. Make sure your keyboard is not up which can block it.

This is really helpful.  I followed Case 1, above.  On the small instruction card and in the Kasa app, it was not clear to me that I had to go to my iPhone iOS  "Settings > Wi-Fi > Choose a Network" and choose the TP-Link SmartPlug device Network which the iPhone Wi-Fi searcher had found.  Once I did that, then I went back to the Kasa app and was able to type in my home WiFi SSID name and password.  All good.  Thanks again.

@Steverino Thanks for the input. I went ahead and added that to help other iOS users.

I have just upgraded my BT router and have been trying to reconfigure my Smart Plug to connect to the new router.  When I scan the network it does not see my network so have been trying to configure it manually.  However it still won't connect.


just bought HS100 and HS110 smart plugs. They're up and running in no time. Very happy.


Now, here is the issue. I use it on multiple iOS devices. All work fine, except the widget on one device (iPhone particularly). I cannot make it to show the custom name of one particular plug on the widget. It displays "TP-LINK_..." instead of given name. On all the other devices it shows up fine, no problem at all.


Firmware of plugs is updated.


What might be the problem?






Make sure you updated your Kasa app to the newest 2.11.0 version.

Thanks.  I’m connected.