Android no Internet with Powerline WiFi

Android no Internet with Powerline WiFi
Android no Internet with Powerline WiFi
2019-05-22 08:19:35
Hardware Version: V4
Firmware Version: 4.0.2 Build 20180308 Rel.37064

Hello

My Home network consists of:
- LTE Internet Router only wifi access (no RJ-45 port)
- Powerline network built with TP-Link WPA4220KIT + 1 additional  AV600
- The Powerline network is connected to LTE Router through EdiMax EW-7438RPn product (wifi bridge)

See PDF network diagram "Rete Cicognini94" attached.

 


Problem: No Internet Access on WiKo smartphone when connected to wifi of Powerline network. See next Screenshot_20190522-094343

 

 

All other devices I have (PC windows 7, iPAD, Internet Radio, SmartTVs) connected to wifi of powerline have stable Internet access

 

Note: When connecting wiko to SSID of LTE router then the Wiko always has Internet access. See next Screenshot_20190522-094447

 

Note 2: when associating the wiko to SSID of powerline the process takes much more time as compared to associating it to SSID of LTE router. 
In fact Android show message "not connected to Internet. Do you want to stay connected to this network". I say "yes" and then after a while 
(30 seconds or so) the android shows that the selected wifi network is "connected" however with anomaly as described above.

 

Some additional info:

While WiKo connected to wifi of powerline and no Internet Access:
-  IPv4 PING on wiko runs ok. See next Screenshot_20190514-085203

Note "ping www.google.com" also works OK --> no DNS issue

 

 


-  some debug on wiko itself shows issues with HTTP access to internet (Test Client HTTP: Fail). See attached Screenshot_20190517-140733, Screenshot_20190517-140846

 

 

 

 

- While connected to SSID os LTE router it shows up all OK, especially the "Test client HTTP:"  see next  Screenshot_20190517-141058

 

Deactivating Firewall on LTE router does not change anything.

 

Anyone seen similar issue? 
Anyone has a suggestion to further trouble shoot this?
Any who has resolved this and how?

 

Thanks for your help,
Fred

File:
Rete Cicognini94.pdfDownload
0
0
#1
Options
8 Reply
Re:Android no Internet with Powerline WiFi
2019-05-23 08:41:45

Hi,

 

The current TL-WPA4220 work properly with all other devices means that the TL-WPA4220KIT should be working properly; We will do further analysis and try to fix it. 

 

From the network topology attached, the IP address of the cellphone exceeded the DHCP pool of the main LTE router, may I know is there any other DHCP server existed in the current network? 

 

Meanwhile, please login to the web interface of the extender ( EdiMax EW-7438RPn) to confirm that the DHCP server is disabled. 

 

Besides, there are 2 wifi extenders, you can access internet from the AV600( wifi-taverna) but no internet from the wifi-salone? 

 

Did you try to changed their positions and give it a go? 

 

What is more, with the cellphone connected to the 2 extenders' wifi, please check the IP address and default gateway separately and show me a picture. 

Note: Usually, you can press the wifi name you connected and you can see the IP address and default gateway. 

 

Thanks in advance, and have a nice day. 

 

0
0
#2
Options
Re:Re:Android no Internet with Powerline WiFi
2019-05-23 09:09:57

Hello

 

thanks for looking into the issue. Follow my asnwers:

 

1. Yes I would agree the powerline works OK and the issue is most probably caused by the smartphone. After I opened the case I tried a different model: WiKo Jerry and this phone works OK on the powerline wifi SSIDs

 

2. The IP address on the phone is a slip of the pen. I changed the DHCP pool on the Internet router but forgot to update the diagram. I confirm it has an IP addres sinside the DGCP pool. No other DHCP server in my network as far as I know.

 

3. DHCP server on Edimax. Will check this asap (I am out now for work).

 

4. 2 x AV600. The issue is the very same on SSID of both AV600.

 

5. Check Smartphone IPCONFIG when connected to AV600 wifi: will do so upon my return.

 

Please note that in the meantime I also opened a case with WiKo. They have no explanation for the issue and forwarded the infos to their development community. Of course I'll let you know any news from them.

 

Kind regards

Fred

0
0
#3
Options
Re:Android no Internet with Powerline WiFi
2019-05-23 18:07:29

Hello

I did some additional trouble shooting to try to get more info on when and how the Internet connectivity issue is present.

From detailed steps below it seems:

 

- Reboot of Edimax wifi bridge device eliminates the problem. 
        * However the issue comes back when associating the WiKo Harry to the other SSID of the powerline network
- Configuring the same SSID on both AV600 devices of powerline network and flipping WiKo Harry between the AV600 devices 
          using the same SSID name I have not been able to re-create the issue.
- Re-configuring the powerline network to the initial status (different SSID on different AV600) the problem re-presents itself.

 

I hope this info can help you to in the analysis.

 

If there would be anything you want me to try to capture other data let me know.

I am also willing to give you access to my home network (using Teamviewer or similar) if that would be helpful to you).

 

Below are the steps I went through.

Regards
Fred

 

Note I have attached the correct version of network diagram.

 

Note 2: I confirm that the Edimax device in wifi bridge mode has no DHCP server in this config. I have screen shots but I can not attach more than one file here.

 

1. Change the IP address on the Edimax wifi bridge to have it outside the LTE router's DHCP pool.
Change requires to reboot the Edimax
After reboot of Edimax, associate the WiKo Harry to WiFi-salone (AV600-2) of powerline: as before it takes quite long
It results in status = "Connected".
Now the app PingTools indicates "internet connection".
Internet browsing on WiKo Harry works.
On WiKo Harry (dialing *#*#4636#*#*) we now have:  "Test client HTTP: Pass"


2. On WiKo Harry switch off wifi in settings/wifi menu.
Switch wifi ON again.
It reconnects to the powerline AV600-2 with SSID WiFi-salone and within normal time it results in "connected".
Browsing works.

I did this wifi switch OFF/ON various times and, except from the first time, each time I get an internet connection quickly


3. Now without switching OFF the wifi on WiKo Harry, associate WiKo Harry to the other AV600-1 wifi of the powerline (i.e. SSID = WiFi-taverna)
It connects quickly and in the wifi menu it shows "connected" but now again no Internet (i.e. the problem is re-created :  Test client HTTP: Fail: IOException).

Go back to connect to WiFi-salone:
Connects quickly but no Internet and we have "Test client HTTP: Fail: IOException"

4. Reboot the Edimax again (also change it's IP adress otherwise no access to reboot option):

Doing a "refresh stats" on the WiKo Harry wifi debug screen now gives "Test client HTTP: Pass"
Indeed browsing works.

So: after reboot of Edimax WiKo Harry gets Internet access. However then associating it to another SSID (i.e. other AV600 device) of powerline 
system re-creates the problem.

Maybe leaving the SSID name unchanged would improve things?

5.So I assign the same SSID to both AV600 units, that is assign SSID=WiFi-taverna also to AV600-2 (192.168.1.31).
Connect to WiFi-taverna and the AV600-2 associated client list shows the MAC of WiKo Harry.
It gets to status "connected" quickly and we have "Test client HTTP: Pass".
Internet OK.

6. Switch the WiKo Harry to the other AV600 device.
Impossible to switch the WiKo Harry to the WiFi-taverna of AV600-1 (ex "taverna") since only single SSID WiFi-taverna shows up in menu.


So: place Wiko Harry close to AV600-1 and switch off wifi and switch it on again --> it re-associates ==> connects to wifi of AV600-1 and connects quickly.
Association to AV600-1 confirmed by AV600-1 client list with MAC of WiKo Harry. (this MAC indeed not in AV600-2 client list anymore).
Internet OK and we have "Test client HTTP: Pass"

7. Move back to wifi of AV600-2.
MAC of Harry in AV600-2 client list
Internet OK
"Test client HTTP: Pass"

So toggling between AV600 devices with the same SSID name (different channel numbers though) Internet is always OK 
(in the few tests/toggles I have carried out).

8. Move back to initial SSID config (i.e. different SSID on different AV600): reconfig SSID = Wifi-salone on AV600-2
Harry very close to AV600-2 from previous step.
It has associated to SSID WiFi-salone 
Internet OK
"Test client HTTP: Pass"

9. Move Harry to AV600-1 SSID = Wifi-taverna by selecting this SSID in wifi menu (no switch OFF --> ON of wifi on Harry)
Connects again very slowly
And we have again: "Test client HTTP: Fail: IOException"
No Internet

File:
Rete Cicognini94.pdfDownload
0
0
#4
Options
Re:Re:Android no Internet with Powerline WiFi
2019-05-29 05:56:37

Hi,

 

Thanks for your reply and effort to do the troubleshooting; 

 

From your description, I found that when you switched to AV600-2 network from AV600-1, there is no internet access and you need reboot the Edimax to recover the network, and the Wiko Harry works fine when they use the same network name, so I'm afraid that there is some interference on the actual wireless network environment; 

 

As a workaround, you can setup same network name for the 2 extenders; meanwhile we will remind our R&D colleagues; but I have to say, it is hard to give you a specific answer on what is the root cause now;

 

Wish your understanding. Good day. 

 

0
0
#5
Options
Re:Re:Re:Android no Internet with Powerline WiFi
2019-05-29 07:18:37
Hello Kevin I had the same SSID all over for while during troubleshooting and as far as I could notice did not experience issues with the WiKo Harry internet access during that configuration. I am out for work now - let me see if I have time this weekend to reconfigure things with single SSID everywhere and see the effect. Point I have with same-SSID home network is that I can not easily select the best SSID based on where I am. That said in the position where I normally work I have enough wifi signalfrom wifi router to connect smartphone directly to the router so the problem is not coming up until the stays at my desk. That is my workaround for the moment. Yes I fully understand the difficulty in understanding this issue. Regards Fred
0
0
#6
Options
Re:Re:Re:Re:Android no Internet with Powerline WiFi
2019-05-30 03:04:39

Hi Fred, 

 

Thanks for your reply and understanding. 

 

Sure you can take some time to test the connection with all same SSID. 

 

Meanwhile, it is true that it is hard to verify which SSID you have connected with they all use the same SSID, but to solve the current issue, it is worth to give it a go. And you can build a seamless roaming connection. 

 

Good day. 

 

0
0
#7
Options
Re:Re:Re:Re:Re:Android no Internet with Powerline WiFi
2019-06-02 09:50:19
Hi Kevin I configured both AV600s with the same SSID that is active on the LTE wifi router by default, i.e. the one indicated as "Webpocket-3C8D" in the network diagram. (Note: I have not tried to change SSID to the same, never-used string on all three devices). In this way the WiKo Harry works flawlessly. I went around in the house so as to make the phone attach to different WiFi AP (LTE router, AV600-1, AV600-2) and it is working OK everywhere in all the tests I did. I also verified that while moving the PC around the house it is connecting nearly always to the stongest wifi signal. All other devices work fine as well. So I think I'll leave things like they are now. Thanks for your attention to the issue I presented, which unfortunately I think we'll leave "not understood". Kind regards Fred
0
0
#8
Options
Re:Re:Re:Re:Re:Re:Android no Internet with Powerline WiFi
2019-06-05 08:16:23

Hi Fred, glad to hear that it works, congrats.^_^

 

If need any further help, just let us know.

 

Good day

0
0
#9
Options