TP Link M7650 Wifi Issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TP Link M7650 Wifi Issue
TP Link M7650 Wifi Issue
2019-09-08 16:56:41
Model: M7650
Hardware Version: V1
Firmware Version: 1.0.13 Build 180808 Rel.1056n

Hi there, 

 

I have been searching for an answer to this, and having factory reset the router, and updated the firmware, I have not been able to resolve it.

 

For some reason, I am unable to connect to the wifi unless I hold the router right next to my phone / other device. Once done the wifi works as expected, and I can move away from it. Although if I move out of range, I have to move right next to it to connect again. This is quite annoying when I have to keep the router in the window to get a decent 4G signal, and have multiple devices to connect. It seems to be fine if theres already one device connected, but if not, none of my devices can pick up the signal.

 

Is this some sort of power saving feature, or an issue with my router itself?

 

Thanks

0
0
#1
Options
2 Reply
Re:TP Link M7650 Wifi Issue
2019-09-09 07:43:48

@MrLogano 

 

Hello, we need ensure that the devices is under the coverage area of the router first otherwise the connection will be cut.

 

Once your device detected the wifi signal from the M7650 but not very close to it, is there any error message indicates that you cannot connect to the wifi? 

 

Besides, have you ever tried to forget the network and reconnect to it? 

 

Try to change the wireless channel and channel width to give it a shot also.

 

Any updates, please let us know.

 

Good day. 

 

0
0
#2
Options
Re:Re:TP Link M7650 Wifi Issue
2019-09-09 08:01:35

Hey there,

 

I need to be close (less than 1m) to pick it up initially, but other than that it performs as you would expect. 

 

I have tried 2.4Ghz and 5Ghz, with various channels. It all has the same issue. Although I tend to pick it up from further away when switching between 2.4Ghz, and 5Ghz, but loses it after the router completes the action. 

 

In my room, I also struggle to pick up the wifi on my Samsung smart TV, Xbox One, and laptop. Although they seem to connect once I've got my phone connected. So it only seems to be when there are no existing devices connected. 

 

Bit of a head scratcher it seems.

0
0
#3
Options