TL-WA901ND - no internet connection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WA901ND - no internet connection
TL-WA901ND - no internet connection
2019-10-16 13:41:21
Model:Adapter
Hardware Version: V5
Firmware Version: 3.16.9 Build 160929 Rel. 37753n

Hello,

 

yesterday I received the TL-WA901ND. It's connected via LAN cable to a switch, the switch is connected via LAN cable to a Speedport router (router's IP address is 192.168.2.1, DHCP enabled).

Cable connections and TL-WA901ND's WLAN still working, I can connect to the TL-WA901ND WLAN with my Android smartphone and login to the settings menu.

 

The TL-WA901ND should work in access point mode.

 

The issue is there's no internet connection on the TL-WA901ND's WLAN and I hardly guess that's due to my settings.

 

Here are screenshots from the settings:

 

 

 

 

 

 

 

Yesterday the WLAN internet connection seems to work fine with these settings. Today it's gone.

 

When I connect the Android smartphone with the TL-WA901ND WLAN it needed approx. 20 seconds to get the IP on the smartphone, that seems quite long compared to other WLAN networks.

 

Any of you might know what the issue is here, any help is much appreciated.

0
0
#1
Options
6 Reply
Re:TL-WA901ND - no internet connection
2019-10-17 03:07:47

@tufftone 

 

When the connection drops out, please connect your computer or smart phone to the TP-Link wifi and then click here to verify its IP address and gateway. 

 

And try to ping the gateway of the main router which is 192.168.2.1. 

 

Besides, you can change the type of LAN settings of TL-WA901ND to smart DHCP/IP and enable DHCP server under network-DHCP server settings page.

 

After that, please verify whether the access point works well as expected. 

 

Good day. 

 

 

0
0
#2
Options
Re:TL-WA901ND - no internet connection
2019-10-21 14:43:07

@Kevin_Z Thank you.

 

It seems I can't fix this.

 

I had a look at router's protocoll, it stated an issue with IP address allocation (when the devices try to connect I guess).

 

At the moment I can't reach the 901 when the laptop is connected to its WLAN, neither with "http://tplinkap.net/" nor "http://192.168.2.254/" (static address).

0
0
#3
Options
Re:TL-WA901ND - no internet connection
2019-11-01 06:42:01

@tufftone 

 

Once the TL-WA901ND connected to the main router, the IP will change, not 192.168.0.254 anymore, instead, it is assigned by the main router. 

 

You can login to the web UI of the main router to get the current IP address and use it to access the web interface. 

 

May it help. 

0
0
#4
Options
Re:TL-WA901ND - no internet connection
2019-11-01 11:32:39

@Kevin_Z I reseted the 901 once again and tried different connections, with and without a switch in between. To connect the 901 directly to a LAN port of the router did the trick as it seems. Still testing but so far no "no internet connection" on the smartphone.

 

I wanted the 901 two floors above the router, but that's not possible without a switch in between atm, but the 901's WLAN seems strong enough to just put it on the first floor and have the WLAN even on the 2nd floor.

 

Just out of interest, is it a common behavior the 901 doesn't work properly when connected with a switch in between to a router? 

 

Thank you for support and informations.

 

 

0
0
#5
Options
Re:TL-WA901ND - no internet connection
2021-11-05 03:04:35
Can you help me
0
0
#8
Options
Re:TL-WA901ND - no internet connection
2021-11-12 11:19:01

Hey @Zosen 

As this thread is a bit old, please start a new thread from here with the model and the case details, thank you. 

0
0
#9
Options