Port Forwarding on port 80 not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Port Forwarding on port 80 not working
Port Forwarding on port 80 not working
2019-11-18 18:03:23 - last edited 2019-11-19 02:45:07
Hardware Version: V2
Firmware Version:

Hi guys,

As per subject. Port forwarding to other ports works just fine,but for port 80.

I've got an apache2 web server which is perfectly working from within the local network,but it's not reachable from the outside. 

 

Even setting virtual server to redirect traffic coming from port 80 to the static IP address of the webserver on port 80 has no effect at all.

It throws a 403 forbidden error just like if I would try to access to the router itself.

Any clue?

Please help.

Tnx

1
1
#1
Options
4 Reply
Re:Port Forwarding on port 80 not working
2019-11-18 19:26:23 - last edited 2019-11-19 02:45:07

Well...

 

I've got back home and I've found something I don't like AT ALL.

 

I'll put it simple.  Why does the resulting web page of my website page is the router login access page even if I set port forwarding to another machine when a traffic from port 80 is coming and even if I also set port,like, 1234 for management purposes?

 

I've found this when connected to my wifi home network.

 

In simple words, it looks like the port 80 is reserved to the router management routine, regardless of any other rule you set. Even if you set a different port for that. 

 

This means that this router does not allow customers to set up a web server, since port 80 can't be used. This is also conflicting with the nat forwarding menu which by default sets port 80 for http services, but this port forwarding won't be triggered at all.

 

If I am right,  and I hope I'm not,  this is a severe and very disappointing bug.

 

Any thoughts?

 

 

0
0
#2
Options
Re:Port Forwarding on port 80 not working
2019-11-19 02:44:44 - last edited 2019-11-19 02:45:07

@deltav 

 

Hello, per you know, the port 80 is used for the local management page by default, while it can be adjusted. 

 

Please login to the web UI of the Archer vr2800 and then go to advanced-system tools-administration-local management page to change the port number.

 

And then you can enable the virtual server for the web server with port 80 and you can test whether it works this time.

 

May it help. 

 

0
0
#3
Options
Re:Port Forwarding on port 80 not working
2019-11-19 06:12:26

@Kevin_Z hi Kevin,

Thanks for your reply.

 

As I said, I've already changed the port for management into a different number.

And the port 80 is still unavailable for port forwarding.

 

Even if I change the port for local management to another number,the port 80 is still locked and it points to the router access page!

 

May I kindly remind you I paid 140€ for this product which is not working as described in your manual.

 

It's quite clear right now that you do not test your products before launching in the market. 

 

In addition, I've found several other posts with same issue involving other products of yours ,thus demonstrating tp link has no intention, or maybe capabilities, to address this severe issue. But you still sell your routers as capable of doing port forwarding, which is not actually the truth.

 

It would at least be honest from your side to provide a firmware update to address your bugs.

0
0
#4
Options
Re:Port Forwarding on port 80 not working
2019-11-20 07:10:11

@deltav 

 

We are sorry for the inconvenience caused. We will do further analysis to locate this issue and solve it. 

 

In the same network, please test whether you can access it with your server's IP address and port number 80;  meanwhile, you can use the WAN IP plus port number to test.

 

Besides, please use telnet to test:

1. in the same network, please go to run—cmd—telnet lan ip port number 

2. in external network, please run—cmd—telnet wan ip port number

 

Note: Please show us the pictures of the test results.
 

Thanks in advance, and have a nice day. 

0
0
#5
Options