deco m4 : Upgraded to latest firmware and my whole system is unusable

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
deco m4 : Upgraded to latest firmware and my whole system is unusable
deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-03-06 18:03:36
Model:Adapter
Hardware Version: V2
Firmware Version: 1.1.8 Build 20190917 Rel. 76172

Everything was working fine

 

Till i upgraded to latest firmware.

 

ever since then my connection is super unstable. The speeds im getting are 1mbps sometimes in my 100mbps connection.

 

I just to downgrade my firmware to factory default 

 

why on earth does tplink not have that feature built in ? 

 

can someone pls tell me how do it.. i asked support a bunch of times and im not getting any response

1
1
#1
Options
11 Reply
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-03-08 02:33:43

@farhann 

 

can someone pls helpme out here

 

no one knows how to downgrade the firmware ??????????????????

0
0
#2
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-03-08 04:14:04

@farhann 

 

why am i not getting any response to my problem???

 

i am so regretting purchasing tp-link... never ever again

0
0
#3
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-03-08 12:36:31
I have just purchased the Deco M4 and my download speeds over wifi have dropped from 100 - 200mbps to the levels you are experiencing. I am also running with the latest firmware. I hope someone takes notice of this or I will be returning the product as it's not fit for purpose.
1
1
#4
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-03-09 02:23:52

@farhann 

 

Hello, we found that you raised a ticket email in the meantime, cause my colleague has done the basic troubleshooting with you, our engineer will take over your case and try to figure it out. 

 

Please get in touch with our engineer via email. We have reminded him as well. 

 

Thanks a lot. 

0
0
#5
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-03-09 02:25:45

@Steve5000 

 

Hi, please provide the information below so that we can locate this issue and sort it out. 

1. What is the current network diagram?

2. What is the bandwidth you paid for your ISP and what is the actual speed you can get from Deco M4, including wired speed and wireless speed?

3. Try to connect the main Deco to the modem only and test the speed you can get. 

4. In the meantime, what is the speed you can get from the modem directly, bypass the Deco M4? 

 

Thanks a lot. 

 

0
0
#6
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-07-09 13:51:10

@Kevin_Z 

 

I have the same issue too. My wifi devices keep on disconnecting and no internet indicate on my devices. But fine on GE port from the main deco. My subs speed from isp is 300mbps but if i can connect to the deco im getting around below 30mbps. This is my 2nd set of deco m4. Same problem. 

0
0
#7
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-07-10 12:31:19

@CarloDeAndrea 

 

Hello, please provide the information below so that we can locate this issue and sort it out:

1. What is the current network diagram? How the Deco M4s are connected in your network?

2. Are all clients disconnected from the Deco mesh network or only some of them? What are the devices that disconnecting?

3. Is 30Mbps the wired speed or wireless speed you got from Deco M4? Try to connect the main Deco to the modem only and test the speed you can get. 

4. Please also confirm the link speed when your computer is connected to the Deco network:

How to check the associated/link speed on a wireless client

 

Thanks a lot. 

0
0
#8
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-08-04 17:18:35

Same shi  eh... issue! After upgrade to 1.4.0 Build 20200628 Rel. 48846 connection is super unstable, speed can be 170 mbps then 1 mbps and get to 170mbps in couple minutes. Something is clearly broken in this version. Luckly I can still get my Deco back to shop. Tp-Link, is there ANY way to downgrade FW? This build is not working! We don't want to investigate it for you, get you set from factory and play with as much as you want, meanwhile we'll just downgrade and wait for the resolution. Again, how can I downgrade to 1.1.smth?

0
0
#9
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-08-05 11:00:36

@GhostStalker 

 

Hello, sorry for any inconvenience caused by the new firmware update.

 

Do you mean the connection was stable with the old firmware 1.1.8 but now is very unstable? Except for the Deco firmware upgrade, no other changes in your network?

 

Please provide some issue background and we will try to help you out, as it is now allowed to downgrade to the previous version directly. We may need a remote session to help you do the downgrade if you want to do that.

 

Good day.

0
0
#10
Options
Re:deco m4 : Upgraded to latest firmware and my whole system is unusable
2020-08-14 10:54:55

@TP-Link_Deco I purchased my Deco M4 set of 3 on Aug 10th and got it delivered today in morning. 

 

I have a 200mbps plan and i already have a modem & router from isp so connected the main deco via ethernet and did the rest of the setup. I got the speeds of close 100mbs on wifi. Then i did the 2nd deco setup on 1st floor and there i connected my console via ethernet cable and got 75-80mbs speed. Later on did the setup for 3rd deco on 2nd floor.

 

I saw in the app there was an firmware update available and i updated my all 3 deco. Now i am still getting the same wifi speed i.e 100mbs but on my console it dropped to 12mbps!!!!! 

 

Whole point of me buying this was to have good coverage in my room when i am using my console. Why even the firmware is getting rolled out when proper testing is not done? Now what should i do wait for couple more days or return back the product? As i can see firmware downgrade is not an option and support staff has not ye resolved this issue since March 2020.

 

 

I am having a tp link range extender which is giving me 25 30mbps on my ps4 and after the firmware update the deco couldn't even match that speed.!!!! Really not good start for me with this product.

 

 

Please provide an update asap.

0
0
#11
Options