Deco M9 - Windows devices can connect but no internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M9 - Windows devices can connect but no internet
Deco M9 - Windows devices can connect but no internet
2020-03-20 02:53:12 - last edited 2020-10-27 12:08:04
Hardware Version:
Firmware Version:

Is there a bug with Windows devices and Deco? I am able to connect to the WiFi network just perfectly and get internet on all my devices except Windows 10 devices as of today. What's up?

0
0
#1
Options
1 Accepted Solution
Re:Deco M9 - Windows devices can connect but no internet-Solution
2020-03-20 09:49:16 - last edited 2020-10-27 12:08:04

@Kevin_Z 

 

I figured it out. The time setting for North America/Los Angeles is completely incorrect on tplink side, so it was shutting my internet down (which I have a bedtime setup for). I changed to North America/Phoenix since it's currently same time as Los Angeles. I think tplink needs to fix the time server setting. 

 

Never happened before. 

Recommended Solution
1
1
#3
Options
14 Reply
Re:Deco M9 - Windows devices can connect but no internet
2020-03-20 09:43:16

@msaad 

 

Hi, there is no compatibility issue between the Deco and Windows 10 laptop. 

 

With Win10 pc connected to the Deco's wifi, please click here to get the IP address and gateway. Then try to ping the gateway of the Deco, which is 192.168.68.1 by default. 

Note: Please show us the ping results. 

 

Please ensure that Windows 10 obtains valid IP address from the Deco; you can assign it a static IP to give it a shot. 

 

Besides, you can connect the Win10 PC to the main Deco directly with other Decos unplugged. 

 

Good day. 

 

 

0
0
#2
Options
Re:Deco M9 - Windows devices can connect but no internet-Solution
2020-03-20 09:49:16 - last edited 2020-10-27 12:08:04

@Kevin_Z 

 

I figured it out. The time setting for North America/Los Angeles is completely incorrect on tplink side, so it was shutting my internet down (which I have a bedtime setup for). I changed to North America/Phoenix since it's currently same time as Los Angeles. I think tplink needs to fix the time server setting. 

 

Never happened before. 

Recommended Solution
1
1
#3
Options
Re:Deco M9 - Windows devices can connect but no internet
2020-07-23 11:54:36

 

msaad wrote

@Kevin_Z 

 

I figured it out. The time setting for North America/Los Angeles is completely incorrect on tplink side, so it was shutting my internet down (which I have a bedtime setup for). I changed to North America/Phoenix since it's currently same time as Los Angeles. I think tplink needs to fix the time server setting. 

 

Never happened before. 

Hi @msaad 

 

I have the same problem of my windows 10 laptop not being able to connect to Internet, while it connects to the deco m9 plus WiFi network. Can you please tell me what time setting you updated ? The windows date and time region ? (I'm in Eastern standard time zone) or is there some time setting on the deco ?

 

Thanks

0
0
#4
Options
Re:Deco M9 - Windows devices can connect but no internet
2020-08-04 21:25:43

@Sam_J 

 

Same issues here!

 

Windows 10 laptop keeps being connected to WiFi, but internet access kicks out every now and then. Reconnect=solved for a while

Other devices no problems.

0
0
#5
Options
Re:Deco M9 - Windows devices can connect but no internet
2020-08-06 07:30:19

@Julian2 

 

Update: my laptop used 5ghz 

If I switch of 5ghz on deco settings, all is ok

0
0
#6
Options
Re:Deco M9 - Windows devices can connect but no internet
2020-09-13 23:58:30

I am facing the same issue. Wifi gets disconnevcted frequently with my Windows 10 Desktop, not this issue with any other opertaing syetem. Also, it gives a warningevery time of 

"Wi-Fi network not secure in Windows 10"

Please fix this problem , facing huge issues due with My M9 Plus 

0
0
#7
Options
Re:Deco M9 - Windows devices can connect but no internet
2020-10-27 11:56:16

@msaad 

 

i got some same issue. connect wifi perfectly but still no internet. did it have solution for this problem?

 

0
0
#8
Options
Re:Deco M9 - Windows devices can connect but no internet
2020-10-27 12:20:52

@arifmusa    @Nahar    @Julian2    @Sam_J 

 

Hello all, sorry to respond late and didn't pick up this topic timely. It seems that the issue is quite different as per your descriptions, please help verify the below details:

 

1. Ensure the Deco M9 firmware is up-to-date, which is now 1.4.3.

 

2. If there is still an issue with the Windows 10, please check and ensure the Windows 10 wireless adapter version is also the latest and show us the detailed version info, thanks.

 

 

0
0
#9
Options
Re:Deco M9 - Windows devices can connect but no internet
2021-06-20 00:30:00 - last edited 2021-06-20 00:31:15

Im also experiencing the same thing only with Windows. My macbook connects fine, also android, android tablet, tv, ps4 etc. Its the freaking windows and Decos. I tried with a neighbors network and my computer is fine. At my office I connect perfectly. I read somewhere to create the Decos Guest network and it is stable. I have internet but at low speed. How can I fix this with my Decos network? Should I reset my 6 devices? That would be a pain in the ass because I have like 40 smart devices configured but if that fixes it, ill do it . In conclusion my decos main network are in conflict with windows. The guest network works fine.

0
0
#10
Options
Re:Deco M9 - Windows devices can connect but no internet
2021-12-31 14:39:50

I am having same issue here. Deco m9plus is on latest firmware 1.5.1 and was working fine for couple of weeks now and now all of a sudden all windows laptops are not connected to internet although connected to wifi. Able to get internet on other Android and iOS devices without issues. Please help as this is a major issue for me. I

3
3
#11
Options