TD-W9970 modem only, bridge mode, Talktalk

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TD-W9970 modem only, bridge mode, Talktalk
TD-W9970 modem only, bridge mode, Talktalk
2020-05-25 15:09:16
Model: TD-W9970  
Hardware Version: V3
Firmware Version:

Hi all

 

My ISP is Talktalk on a fibre package and my objective is to improve my home network and wifi. With this in mind, I purchased an Archer C7 router with a view to using it with the Talktalk-supplied modem-router in bridge mode (so it would be modem only). To my great frustration, I just could not find a solution to the problem of putting the Talktalk device in modem-only mode. In the end, I bought the inexpensive TD-W9970 modem-router with the sole intent to use it in modem only mode and connect to the Archer C7. Unfortunately, this has not been straight forwards and I'm asking for some help. 

 

I think I may have got the sequencing of the necessary steps confused maybe. So, for initial setup of the TD-W9970, it prompts to select ISP and Talktalk VSDL is an available option. As the TD-W9970 is a router-modem, would I need to run the complete setup first by selecting the Talktalk option to enable the device to 'handshake' with the IPS; and then set try to set the device into bridge mode. Or, would I run setup for the TD-W9970 in bridge mode from the very beginning (but how then does the modem 'talk' to the IPS - excuse the pun).       

 

Despite the above, I somehow connected it all up and am actually typing this over internet provided through the Archer C7 router. On the TD-W9970, the DSL light is on and the internet light is off - implying that I have somehow managed to get it running in bridge mode. But here's the odd thing - despite me using the live connection made through the Archer C7 router to write this, the internet light on the Archer C7 is red which indicates no internet. So, I'm not fully convinced that the problem is so am still posting this asking for help.  

 

I would greatly appreciate some step-by-step guidance on how to set up the TD-W9970 in modem-only mode, to use with an Archer C7 router, over a talktalk fibre IPS.

 

It also doesn’t help that the TD-W9970 is model V3 and there’s only a V2 user guide available on the support page.

 

Paul 

  0      
  0      
#1
Options
3 Reply
Re:TD-W9970 modem only, bridge mode, Talktalk
2020-06-02 13:51:47
Has anyone got any ideas on this at all?
  0  
  0  
#2
Options
Re:TD-W9970 modem only, bridge mode, Talktalk
2020-06-04 16:32:11

@PTK2106 

 

It kinda sounds like you're there, insomuch as it's all working.

 

The only thing you should be mindful of here is double NAT. So long as your Archer Router has a WAN address that is external eg. 79.76.193.126, then you're golden.

If it's WAN address is something like 192.168.1.2 then your TD modem is still in Router Mode.

Which could well be okay if your Archer does not have a WAN address, which would mean it's in Access Point mode.

 

However, if you're unsure about what any of the above means; I would suggest you just leave it alone. If all your devices are working for you and you're getting the functionaility out of your setup that you wanted then I would say your job is done. ;-)

  0  
  0  
#3
Options
Re:TD-W9970 modem only, bridge mode, Talktalk
2020-06-04 21:11:17
Hi - thanks for the response. No, I didn't have double NAT (i checked in the command promt), but I didn't think things were right as my internet was slow (even when using ethernet) and the Archer internet light was red. I thought it strange that I could use the internet at all with this light red. So I would say that functionality is not meeting my expectation. I am also the sort of person who just wants to know for sure if it's working as it should. I would like to point you to my query about the correct sequence of actions. Does the modem-router have to be configured first by selecting Talktalk ISP and running quick setup (i.e. making that handshake to the IPS), then configuring the Archer through the quick setup which did automatically detect 'Dynamic IP' for the IPS (yes, this will be a double NAT situation), and only then putting the modem router into bridge mode (which would in theory remove the double NAT). The whole process does not seem to be very defined actually and very frustrating. There is a Talktalk page which has settings for use with non-Talktalk devices - but elsewhere on the net I have seen others question that this is even correct. Of course, the TP-Link product architecture may be a problem and other brands may well make executing my objectives easier.
  0  
  0  
#4
Options