ARP binding not working -> WOL from internet not working on Archer C6

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

ARP binding not working -> WOL from internet not working on Archer C6

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ARP binding not working -> WOL from internet not working on Archer C6
ARP binding not working -> WOL from internet not working on Archer C6
2020-06-20 09:37:42 - last edited 2020-11-25 22:12:58
Model: Archer C6  
Hardware Version: V2
Firmware Version: 1.3.0 Build 20200402 rel.52000

I'm trying to set up WOL on my PC which is directly connected to Archer C6.

 

Now, quick disclaimer: WOL works "for a while" after shutdown, when the router still remembers the ARP for my PC. Unfortunately after some time or a router restart the ARP table gets cleared and WOL no longer works.

 

AFAIK to make it work I need two things:

- static LAN IP

- ARP binding entry

- DDNS / static WAN IP

 

Alas, it seems there might be a bug in this FW version. After setting up a static LAN IP in the DHCP I cannot add an ARP binding in the security section because I'm getting a "The to-be-added address already exists" error. Strangely enough, I CAN click on the little "link" icon in the ARP device list and this DOES create an ARP entry (the entry also changes to "bound"), but since I cannot wake my PC after a router restart, I don't think this actually works.

 

I've also tried the "other way" - first add an ARP entry, then try and add a DHCP static entry - same "address already exists" error.

 

So, how should I set up the router so that WOL works without issues? The FAQ (https://www.tp-link.com/en/support/faq/923/) suggests that BOTH DHCP and ARP bindings need to be created, but the FW is clearly preventing this...

 

EDIT:

On a side note: I'm using a WOL app on my phone which is configured to send the packet to the WAN IP, and that gets forwarded using a virtual server to the appropriate LAN IP -> MAC. If my phone is disconnected from the LAN WiFi, the the WOL packet will work (assuming the binding on the router is working - again, it'll stop working after a router restart!). However the same packet will not work if the phone is already inside the LAN. Shouldn't the router still forward the packet when it's coming from the LAN (NAT loopback)?

 

EDIT 2:

It seems the ARP bindings don't really work at all. I've disabled DHCP and added an ARP binding and manually set up my PCs IPs. The PC will show up as "bound" in the device list on the ARP page. After a router reboot the list will no longer contain the entry (if my PC is off at the time). When I booted my PC up, it was STILL UNBOUND (despite having an ARP entry in the bottom list)!

  0      
  0      
#1
Options
1 Accepted Solution
Re:ARP binding not working -> WOL from internet not working on Archer C6-Solution
2020-11-25 13:21:14 - last edited 2020-11-25 22:12:58

Great news, everyone!

As you can see from the message above, I was contacted by a very nice and helpful engineer from TP-Link and, after exchanging a few messages and sending them a backup file from my Archer C6v2, they were finally able to pinpoint the problem.

 

There seems to be an issue with the IPv6 protocol and the ARP binding. As soon as I disable IPv6, the ARP binding entries stick and work as they should, even after a router reboot or power down.

 

As I don't need IPv6 now (and probably won't for a while), this completely solves the problem for me, although there's obviously the need for a firmware update addressing this issue, especially for people who need IPv6 and ARP binding.

 

Anyway, I'd like to thank Mr. Hank Zhang from TP-Link support for his attention and effort to solve the problem.

Recommended Solution
  4  
  4  
#25
Options
26 Reply
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-06-22 06:36:36

@Shaamaan 

 

Hello, thanks for your detailed issue description.

 

Can you please update the Archer C6 to the latest version and we will ask out seniors to check further?

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-06-22 07:17:36

@Solla-topee 

Is 1.3.0 Build 20200402 rel.52000 not the latest release?

 

I tried downloading and installing the version available on the TP-link site for the Archer C6, but using the .bin file I get an "invalid file type" error when attempting to upgrade...

  0  
  0  
#3
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-06-22 07:33:57

@Shaamaan 

 

Hi, it seems 1.3.0 Build 20200402 rel.52000 is the latest version now.

 

Can you please tell me the model number of your adapter that you want to use WOL on and what is the WOL client you are using on your phone? We will soon ask our engineer to check it out.

 

Thanks.

 

 

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#4
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-06-22 07:43:25 - last edited 2020-06-23 05:59:01

The adapter is the built-in Ethernet card in my MSI B250M Mortar motherboard, while the WOL app is this one: https://play.google.com/store/apps/details?id=co.uk.mrwebb.wakeonlan

 

I know that both of them work correctly; as stated, WOL does work for a limited time after I shutdown my PC and stops working after a some time passes or a router reboot (i.e. when ARP tables get cleared). Also I bought the Archer C6 as an EXTRA router and I wanted to test its capabilities. My previous router, an Asus RT-AC58U, is capable of WOL from WAN, albeit non-standard modifications had to be performed (since this model does not have static out-of-the-box ARP entries).

 

PS. I've worked around the hairpin loopback issue by adding two WOL entries on my phone - one being a for LAN and one being for WAN and putting them in a single group, then creating a button for that group. Thus two packets are sent - one using my public WAN IP (via DDNS name) and one using the LAN broadcast IP. Thus, assuming the router remembers the ARP entry correctly, WOL will work regardless if I'm connected to my WiFi or not. Of course that still leaves the ARP issue...

 

EDIT: I was sent a beta version of the Archer C6 firmware (200507). Alas, the same ARP issue is present in that version. After the router is restarted it does not bind static ARP entries as it should.

  0  
  0  
#5
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-07-07 07:56:58

@Shaamaan 

 

I have exactly the same problem!

 

After about 15 minutes it stops working.

 

Curiously only when i am not in the LAN. As soon as i am in the LAN and i use the WOL packet which is being sent over ddns to a specific port and then forwarded it works just fine.

Trying to start the pc through WAN within 15 minutes of shutdown works just fine. After that it doesn't work anymore.

  0  
  0  
#6
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-07-07 08:41:03 - last edited 2020-07-07 08:41:26

Curious that hairpin loopback works for you. I was unable to get WOL working when using ONLY the WAN address whilst connected to LAN. Admittedly I am using a secondary DNS service with a CNAME, so perhaps the router's built-in DDNS service could have something to do with it, but that sounds very unlikely. Is it possible the WOL app you are using is automatically sending a packet on the broadcast address over the same network? That would explain why it starts when you're in your LAN.

  0  
  0  
#7
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-07-07 08:53:25
I have a little bit of a mess as a setup. My Speedport from Telekom is connected to the WAN. It is set up with DDNS. On the Speedport i am portforwarding the port which the magic packet arrives at. This port is being forwarded to my TP-Link Archer C6 which then forwards to Port 9 to my PC. My PC is connected to the Archer C6 and the Archer C6 is in router mode and directly connected to the Speedport. I have set a static IP-Address for my pc though. In conclusion: Internet--> Speedport via DDNS -> TP-Link Archer C6 -> My PC
  0  
  0  
#8
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-07-07 09:55:43

@PunchEnergy I had a similar setup before I changed my ISP: internet -> ISP modem (giving 192.168.0.0 address) with DDNS and port forwarding -> old Asus router via WAN.


In that setup I was able to get WOL working both from LAN and WAN, probably because it was ultimately ALWAYS from WAN (no hairpin loopback because the Asus was in router mode), but I've had to add some custom scripting to the router so that it had a static ARP entry.

 

But your case is still very curious. I assume that because the router is not, in fact, an edge device there's no hairpin loopback issue since all the packets are, essentially, always from WAN. But it's odd that this would work only when connected to your LAN (via WiFi to the C6 I assume?). Did you try a quick test after rebooting the router? This operation effectively clears the ARP tables.

  0  
  0  
#9
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-07-07 09:59:05
Yes. Via LAN is over WIFI from the C6 router, But i don't know how to make a static ARP entry for my PC on the C6. I'll try the reboot and test later this day. I am currently working and cannot switch off the internet.
  0  
  0  
#10
Options
Re:ARP binding not working -> WOL from internet not working on Archer C6
2020-07-07 16:53:21
So i've tested it. I completely restarted the router (C6) while my PC was turned off. And it didn't work over WAN. Over LAN it worked just fine (being connected to the C6's WIFI). I guess that's because of the ARP Binding then. Is there a way to fix that?
  0  
  0  
#11
Options

Information

Helpful: 0

Views: 3193

Replies: 26

Related Articles