HS100 Firmware 1.1

HS100 Firmware 1.1
HS100 Firmware 1.1
2020-11-11 08:02:35 - last edited 2020-11-18 01:05:35
Model: HS100
Hardware Version: V4
Firmware Version: 1.1

I have 2 HS100 v4's that have been working solidly for a while on v1.0.3. According to my smart home these went unavailable over night and now no longer work, they are connected to my wifi but neither my smart home nor the ios kasa app will connect to them.

I tried setting them up again but the ios app only connects if I do a full factory reset, this then works only in the app until I turn the plug off or close the app then it won't connect again.

 

Can you confirm a firmware release was done? Where are the release notes for this? How do I downgrade to 1.0.3 and prevent auto updates in the future 

1
1
#1
Options
1 Accepted Solution
Re:HS100 Firmware 1.1-Solution
2020-11-23 02:08:13 - last edited 2021-05-07 09:27:19

@Timbob 

Hi, All, please refer to this link to get more details:

https://community.tp-link.com/en/smart-home/forum/topic/239364?page=1

Recommended Solution
11
11
#56
Options
80 Reply
Re:HS100 Firmware 1.1
2020-11-12 09:33:33

@scrouchman 

I too have a pair of HS100 that have apparently just updated to 1.1 from 1.03. I was using them with HomeAssistant but now although the Kasa app can see them, they do not respond to HomeAssistant trying to connect to them. The app is too simplistic to be able to turn lights on at dusk, and off at dawn.

 

Hopefully TP-Link can fix the communication problem that has been introduced in 1.1.

 

2
2
#2
Options
Re:HS100 Firmware 1.1
2020-11-12 13:17:42 - last edited 2020-11-12 13:18:20

I have a few HS110's that have recently upgraded to Firmware 1.1 and now they are not working on HomeAssistant either.  It's very annoying, I'll be moving away from these sockets and using one that supports open standards so these issues won't occur in the future.

1
1
#3
Options
Re:HS100 Firmware 1.1
2020-11-12 14:32:27
0
0
#4
Options
Re:HS100 Firmware 1.1
2020-11-12 14:53:47

Has affected all my plugs as well :(
As a workaround have another pi telling Alexa to turn the plugs on via Festival Text to Speach. I have a few things setup like to turn the plug off to the telly and things when my work computer is on and turn the light on when it gets dark.

Hopefully they fix it soon.

0
0
#5
Options
Re:HS100 Firmware 1.1
2020-11-12 15:19:24

So it is home assistant I am using however I do want to stress it does not work in the kasa ios app either. All I can assume is the latest firmware has broken the device api (probably discovery) so it doesn't work from home assistant or the kasa app

0
0
#6
Options
Re:HS100 Firmware 1.1
2020-11-12 15:24:59

My iphone app works still, but I allocated the plugs fixed ip addresses when I set them up, which was supposed to stop them getting lost by Homeassistant. It seems TP-Link found a way round that...

0
0
#7
Options
Re:HS100 Firmware 1.1
2020-11-12 15:36:05

@ntsmkfob I have static ips as well.

I've just tested this again and for me once I factory reset the plug and set it up the app works that one time, can turn it on/off view stats etc. But if I force quit the app it then won't work again.

I do have remote control disabled as I don't need it, do you have that enabled? Maybe its working for you because its doing it via the cloud rather than the local network

0
0
#8
Options
Re:HS100 Firmware 1.1
2020-11-12 15:53:31

Am wondering if the firmware is downloaded to the app then to the plugs, if factory resetting the plugs restores the previous working version as long as the app isnt used it might get things working again, but then, will need the app to join the plug to the network and will probably do the update/break it so will waste more time.

Flipping annoying. Having local control was the reason I chose these plugs. :(
 

 

0
0
#9
Options
Re:HS100 Firmware 1.1
2020-11-12 16:27:25

@scrouchman 

I  never used the app after initial setup a few months ago until they failed yesterday. I have always used the HomeAssistant integration. I surmise that TP-Link can access the plugs directly to force the update.

0
0
#10
Options
Re:HS100 Firmware 1.1
2020-11-12 17:55:42

Likewise, my HS100s have lost their HomeAssistant integration. That was the only reason I had them. Without the integration, the plugs are useless to me. 
 

TP-link, please advice how to downgrade back to the previous firmware (and not have it auto-update again), or provide a fix for this issue. HomeAssistant integration is vital for the so-called "world's no.1 provider of WLAN products". 

2
2
#11
Options