Loopback (Hairpinning) on AX20

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Loopback (Hairpinning) on AX20

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Loopback (Hairpinning) on AX20
Loopback (Hairpinning) on AX20
2021-04-17 11:08:28 - last edited 2021-04-20 06:20:31
Model: Archer AX20  
Hardware Version: V1
Firmware Version: 1.2.0 Build 20200929 rel.54838(4555)

Just replaced a TPLink Archer C8 with the AX20. Configured the NAT rules the same as the old router but Loopback or Hairpinning does not appear to work on this router.

 

When trying to access local services using the WAN ips DDNS name it does not work. However from an external source such as 4g on my mobile I can access the services without issue. Performing Telnet from inside fails but a Telnet from external connects.

 

I looked for a newer version of the firmware and noticed the following bug fixes in previous versions of the firmware (I am on the latest):

 

Firmware - Archer AX20(US)_V1_200527

Bug Fixed:
1. Fixed the bug that sometimes the LAN PC will fail to get access to the Web interface by DDNS address

 

Firmware - Archer AX20(US)_V1.0_200929 (The one I am using)

Bug Fixed:
5. Fixed the bug that the LAN side cannot be accessed through the DDNS domain name when DynDNS and RemoteControl are turned on.

 

So despite this fixes already being applied this still does not appear possible?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Loopback (Hairpinning) on AX20-Solution
2021-04-20 06:07:47 - last edited 2021-04-20 06:20:31

@Kevin_Z 

 

Hi Kevin thanks for the response. Yesterday I decided to factory restore the router and with vanilla settings the issue went away.

 

 

I started to configure the router to my preferences and I noticed the issue returned. So I reset the router again and made changes slowly to try to find the setting causing the problem.

 

 

Turns out that the problem manifests when you use the DMZ feature (with any IP). To fix you have to uncheck the DMZ setting and reboot the router.

 

 

Tech support responded with the following:

 

"Dear Customer,

 

Thank you for your valued reply.

 

This issue should be related to the forwarding priority within the LAN.

 

We can also recreate the issue in our lab, I have register this issue to the R&D department, the R&D will analyze the issue, and I will continue to follow up and inform you immediately if there is any progress.

For the time being, we recommend that you do not use DMZ feature, or you can use the device's LAN IP to access them within the LAN.

 

Thank you for your understanding."

 

Guess I'll make do without using DMZ until it's fixed.

 

 

Recommended Solution
  3  
  3  
#4
Options
4 Reply
Re:Loopback (Hairpinning) on AX20
2021-04-17 13:18:14 - last edited 2021-04-17 13:20:10

@JIBEST 

 

BTW, as I'm also planning to replace my C80 with AX20 I made topic with questionsArcher AX20 very bad 2,4GHz performance and problems with Intel network cards  so please tell why (beside of WiFi6 functionality) did You replace C80 with AX20 and except Your current problem, did You notice any performance, speed, range etc problems?

  0  
  0  
#2
Options
Re:Loopback (Hairpinning) on AX20
2021-04-20 01:55:12

@JIBEST 

 

The AX20 should support NAT Loopback (hairpinning) by default.


May I know who is your ISP? Can you describle the network topology in details, is it the same as before when using the C8? 

 

When you tried to access the local server from local devices by the WAN IP address, what is the error message? Please show us the screenshot, thanks.

 

BTW, do you mean you have tested the two versions already, and both have the same issue?

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#3
Options
Re:Loopback (Hairpinning) on AX20-Solution
2021-04-20 06:07:47 - last edited 2021-04-20 06:20:31

@Kevin_Z 

 

Hi Kevin thanks for the response. Yesterday I decided to factory restore the router and with vanilla settings the issue went away.

 

 

I started to configure the router to my preferences and I noticed the issue returned. So I reset the router again and made changes slowly to try to find the setting causing the problem.

 

 

Turns out that the problem manifests when you use the DMZ feature (with any IP). To fix you have to uncheck the DMZ setting and reboot the router.

 

 

Tech support responded with the following:

 

"Dear Customer,

 

Thank you for your valued reply.

 

This issue should be related to the forwarding priority within the LAN.

 

We can also recreate the issue in our lab, I have register this issue to the R&D department, the R&D will analyze the issue, and I will continue to follow up and inform you immediately if there is any progress.

For the time being, we recommend that you do not use DMZ feature, or you can use the device's LAN IP to access them within the LAN.

 

Thank you for your understanding."

 

Guess I'll make do without using DMZ until it's fixed.

 

 

Recommended Solution
  3  
  3  
#4
Options
Re:Loopback (Hairpinning) on AX20
2021-04-20 06:20:26

@JIBEST 

 

Got it. If that is the case, please disable the DMZ on the router, or you can use the LAN IP to access the local server as a current workaround.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#5
Options

Information

Helpful: 0

Views: 1711

Replies: 4

Related Articles