SIM card not detected

SIM card not detected
SIM card not detected
2021-04-30 01:08:36
Hardware Version: V4
Firmware Version: Firmware Version:1.9.0 0.9.1 v0001.0 Build 190307 Rel.54196n

I just got an Archer MR200 last week and I'm finding it very frustrating to work with. Every so often it stops connecting and shows no SIM found.

 

The SIM is not a problem as I've successfully connected to the Internet with both a Three and a Virgin card. The problem is the constant disconnections which it appears is a feature of this model.

 

Is there a firmware upgrade I can apply? It sounds like a known problem.

 

If any logs are required, please let me know where I can get hold of them. 

0
0
#1
Options
2 Replies
Re:SIM card not detected
2021-05-10 06:25:25

@balangaman 

 

Hi, can you please check the troubleshooting suggestions we provided here, then get back with the results? We will suggest further:
https://community.tp-link.com/en/home/forum/topic/261882

0
0
#2
Options
Re:SIM card not detected
2 weeks ago - last edited 2 weeks ago

The 'No SIM Found' is misleading error. when using the unit, I get this msg, then after turning it off and on, sometimes several times, sometimes ejecting and re-inserting the SIM it just starts working. Sometimes the unit works fine for days on end, but sometimes it just won't connect, and I have tried it with three different SIM cards. Sometimes it won't connect with a particular SIM, but then I try the same SIM in a laptop and it's fine. Is there any logfile anywhere which shows the reason for a disconnection or a non-connection. It's infuriating when this happens.

0
0
#3
Options