[Troubleshooting] SIM Card not Found?

[Troubleshooting] SIM Card not Found?
[Troubleshooting] SIM Card not Found?
2021-04-21 06:25:42 - last edited 2021-05-24 06:39:58
Model: TL-MR6400
Hardware Version: V5
Firmware Version:

This Article Applies to:

All 4G LTE Routers

 

Issue Description/Phenomenon:

Customers may find that the SIM Card Status displays a 'NO SIM card detected' error (pictures as below) when they inserted the SIM card into the 4G router, follow these steps:

 

Troubleshooting Suggestions:

  • Make sure the SIM card is firmly inserted. Try to remove it from the SIM card tray then put it back in. If it is a Nano card, please fix it with the attached sticker and cardholder in the package box.
  • Restart the router with the SIM card inserted.
  • Reset the router by pressing and holding the RESET pinhole for 10s until all LED lights flash off then back on.
  • Put the sim card into a smartphone, confirm that it is working well on the phone.
  • Try using another SIM card if that is possible.

 

 

If none of the above helps to make the SIM card detect correctly, contact the TP-Link tech support by submitting a ticket via email with the subject ‘Forum ID 261882- SIM Card not Found, or leave a DM to @Kevin_Z. In either case, be sure to provide the following information:

- Troubleshooting steps you have taken:

- The model number and hardware version of your 3/4G Gateway:  

- The SIM card carrier:

- Would there be any damage to the Micro SIM Card Slot before, such as the SIM card stuck in and not able to be taken out?

- How long have you had the device, and when did this issue start?

- Was there any firmware upgrade before no sim card was detected?

0
0
#1
Options
5 Replies
Re:[Toubleshooting] SIM Card not Found?
2021-05-10 17:21:20

@TP-Link hello my problem is too 

I did all the above steps and the SIM card is safe and this happened after the firmware upgrade and it has been about 1 day this problem

0
0
#4
Options
Re:[Toubleshooting] SIM Card not Found?
2021-05-18 08:02:53

@ranjbar 

 

If you have already tried all the suggestions listed on this thread, but the router still cannot detect the SIM card, you need to contact the local support to be advised on the following procedure:

https://www.tp-link.com/support/contact-technical-support/#Hotline-Support

0
0
#5
Options
Re:[Toubleshooting] SIM Card not Found?
2021-05-18 10:19:33

@TP-Link 

 

This has just started happening to me with the new SIM card I was provided with by my new ISP. I've had my MR6400 for years and used a number of different SIM cards, all with no problem before now. So I suspect the problem is the new SIM card (it is perhaps slimmer/thinner than previous ones). A reboot usually resolves the problem, but not always first time.

 

I did once have this 'no card found' problem when I used the TP-Link provided SIM card adaptor and a nano SIM - it was clear then that the adaptor was thicker than the SIM and so, I guess, prevented it from making a good contact with the modem. Once I put the nano SIM into a different, slimer, adaptor everything was ok.

 

Might I suggest to people having this problem that, if they are using the TP-Link provided adaptor, to try a different one. Your SIM card might be OK, it's just not making a good contact.

0
0
#6
Options
Re:[Toubleshooting] SIM Card not Found?
2021-05-22 14:36:33

@TP-Link its the sim slot problem ( i have face 3 times same problem) they designed so badly, if you insert sim in reverse for one time also, yor slim slot will get damage and will not detect anymore,  you have to send to replacement log a call or  replace if its under 7 days return policy..be carefull while inserting sim...

0
0
#7
Options
Re:[Troubleshooting] SIM Card not Found?
3 weeks ago

@TP-Link I'm wondering why are you still producing this sh-t? Are you about to f-ck up your brand name? Well done!

0
0
#8
Options