Archer C80 - Fatal Bug in AP mode with latest firmware

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C80 - Fatal Bug in AP mode with latest firmware
Archer C80 - Fatal Bug in AP mode with latest firmware
2022-01-19 12:00:34 - last edited 2022-01-19 12:04:33
Model: Archer C80  
Hardware Version: V1
Firmware Version: V1_210716

Hello Community,

 

First post and hope I can get help as I rasied a ticket and no answer after 48h.

 

I have a critical isssue with my C80s routeurs.

 

I setup a new, Cat 6 wired large home and thought buying the Archer C80 as Access points to extend the wifi network was a good idea. 

So my configuration is as follows:

 

- Fiber Modem

- Central Wifi 6 router connected to modem

- 2 x 24 ports Switch (TP-link) for home distribution

- Each remote area has a C80 connected as access points:

  • Ethernet cable in wan (blue port) of C80
  • Fixed IP address 192.168.2.24x
  • Use Main Wifi Router as DHCP, 192.168.2.1

 

I confifgured first 2 C80s and it was working great. They came with firmware version 201022

 

So I decided to buy 3 more, 6 months later. And after 8 hours of configuring, rebooting, resetting, trying and trying I could not amke any of the new C80s work.

 

Concretely I setup my IP as fixed IP but when selecting the operation mode to be in Access Point, the fixed IP would be lost, impsosible to access the web management page and to connect to the router (my computer would show conenction for 0.5 second then would siwtch back to another wifi).

 

Afer hours and hours of invetigation came the idea it may be firmware related. Sure enough, the new routers had a more advanced firmware version (1.5.7 vs 1.5.0).

 

So, I decided to upgrade to the latest for testing one old (that was working well with the old firmware) and one new C80 for testing. And , sure enough, both failed. Same thing, no fixed IP on network, no access to internet or possibility to conenct to router on wifi, or the web control page of the router!

 

So, clearly post version 201022 something was done to the router setup that makes it fail in access point mode. 

 

I notice in the network diagram that the newer versions have a "Mesh Element"  showing next to the Wifi Clients on the network diagram, and a little mroe menu items. Not sure why adding the mesh option for Mesh then destroyed the basic AP functionality, but it did!

 

I also realized with horror that the latest firmware, 210716 is marked as "cannot be downgraded"!!!

 

What can I do? How cna I revert to the 201022 build all my C80, or can TP-link fix their bug and publish a new router. 

 

I have invested now in 5 C80 and only 1 is working :(

 

Thanks for your help!

 

Julien

 

0
0
#1
Options
1 Reply
Re:Archer C80 - Fatal Bug in AP mode with latest firmware
2022-01-19 15:05:35 - last edited 2022-01-19 17:27:38

@juju-fr 

 

Use Chapter 5 from your user guide to configure C80 in AP mode.

If I recall correctly the LAN IP address is set as SmartIP(DHCP) when setting the device in AP mode.

So to be able to find its IP address look at the DHCP clients list table of your main router and find the C80 LAN IP address assigned.

Then login C80 and set a Static IP address within the main router LAN IP address subnet (like you did with your 2 older devices).

C80 DHCP server should be turned off as well. Here's an additional guide for that - use Case 1.

If after all you can't find C80 LAN IP address when switched to AP mode you can use Address Reservations on your main router:

1. Check on the C80 bottom sticker what's the WAN port MAC address.

2. In your main router add this MAC address along with the LAN IP address you wish to bind to this MAC in Address Reservations table.

Thus even C80 is set with SmartIP (DHCP), it will receive the LAN IP address you've configured in your main router's Address Reservations table.

 

OneMesh:

Usually when OneMesh is introduced as a feature you can't revert back to a previuos FW version - this is stated in the FW release notes.

Look for the OneMesh switch button somewhere in the C80 web management interface (look in the OneMesh section or in its Wireless section).

If you're lucky and there is a OneMesh switch, turn it off - this should stop emitting the hidden OneMesh wireless networks.

Remember that you should do this while still in router mode since OneMesh is not supported when the device is in AP mode - OneMesh FAQ - Q8/A8.

For more details on that you can browse this thread and more specifically this post.

If you're with the EU FW version you can try to downgrade to 1.5.5 - here's the FW file.

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
3
3
#2
Options