TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-16 11:46:40

This is what the router displays (Germany here):

 

while this is what the website shows:

 

We have been experiencing issues with NOT BEING ABLE TO CALL OUT since mid-February. Everything else works, including incoming calls.

What's wrong here?

  2      
  2      
#1
Options
12 Reply
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-18 07:15:31 - last edited 2022-03-18 07:17:39

  @_-LC-_ Thank you very much for your feedback.

As for the firmware update, if possible, could you please try to manually update the latest firmware version-Archer VR600v(DE)_V2_220113?

How to update the firmware on AC VDSL/ADSL Modem Router (new logo)?

And for the VOIP issue, may i know who is your VOIP service provider?

Could you please send an email to support.forum@tp-link.com with a copy of the system logs under system tools>system logs?

Thank you again for your support.

Wi-Fi 7 Launch Replay: https://www.tp-link.com/us/wifi7/event | Leave me a message with any Urgent Requests, or Simply Feel Left Out
  0  
  0  
#2
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-20 16:35:21

  @David-TP 

Thank you very much for your reply.

Our provider (phone and Internet) is O2 (Telefonica). We are located in Germany.

 

I just manually updated the router to Archer VR600v(DE)_V2_220113 without any issues. It's strange that the router's function to check for updates kept showing that there was no update (already newest, though years old).

So far, it works without issues. Phoning out works as well, though this is no guarantee. In the past it used to work for some time and it could or could not be fixed by a reboot. Time will tell.

 

Here is a description of the error before (SysLog):

Initially, I found lines with the error code 503 in the log, basically telling me that the service was temporarily unavailable. Then it didn't show errors anymore, though. I even turned on debug and attempted to dial out. It showed me the dialing of the numbers, one by one, and then nothing. The telephone gives the short busy sound (line not connected?).

My question to you: Is that short busy sound coming from the router or is it in fact coming from the O2 server? If the latter is the case, then wouldn't that mean that the router is connected to their server?

The error (not being able to phone anyone, while still receiving calls) came up and went away sporadically. Sometimes rebooting helped. Other times it didn't. Sometimes the error went away by itself without reboot after a few hours. Other times it didn't work for days, despite reboots.

 

Do you still want to send me the email? I can read the log and it didn't show anything useful. Hence, I didn't bother storing it.

I will let you know, if the error comes back despite the new firmware. Thanks again!

 

After manual update:

  2  
  2  
#3
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-21 08:28:55

  @_-LC-_ 

Thank you very much for the update.

I will wait for your update on the new firmware and you could send me the logs when the same issue started on the new firmware.

As for your question here:

My question to you: Is that short busy sound coming from the router or is it in fact coming from the O2 server? If the latter is the case, then wouldn't that mean that the router is connected to their server?

Since you are still able to receive calls, the O2 VOIP service should not be the problem but all the call-out phones failed, the busy sound is more related to the router.

 

At the same time, here is also a beta firmware for VOIP issue on O2 which I have sent to you via private message and you could test this firmware if the same issue started next time.

Thank you again.

Wi-Fi 7 Launch Replay: https://www.tp-link.com/us/wifi7/event | Leave me a message with any Urgent Requests, or Simply Feel Left Out
  0  
  0  
#4
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-27 10:43:16

  @David-TP 

 

Installed version is release: Archer VR600v(DE)_V2_220113


After last Sunday's update to version Archer VR600v(DE)_V2_220113, outgoing calls worked all week long. The router it set to reboot periodically every few nights. There was at least one of those automated reboots during the week.

 

Just today, on Sunday, when I wanted to report the seeming success, it does not work again. Not even after a reboot.
Striking for me: Here the problems seem to start mostly on weekends.

 

I turned on Debug, did a reboot and then attempted to dial out (O2 Hotline). I will send you the log and a recording of the sound (short busy signal, then a beep after 30 seconds).

 

  2  
  2  
#5
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-29 13:16:12

The BETA is up and running. So far without issues. Debug is turned on in SysLog.

I'll let you know, if something happens or when it manages to withstand the weekend this time.

 

  2  
  2  
#6
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-30 05:40:08

  @_-LC-_ Thank you very much.cool

Wi-Fi 7 Launch Replay: https://www.tp-link.com/us/wifi7/event | Leave me a message with any Urgent Requests, or Simply Feel Left Out
  0  
  0  
#7
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-30 10:09:52

  @David-TP 

Just sent you the new log, as it didn't take a day before dialing out stopped working again.

 

  2  
  2  
#8
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-31 01:59:35

  @_-LC-_ In this way, I would like to forward your case to the senior engineers, and please check the email for further assistance.Thank you very much.

 

Wi-Fi 7 Launch Replay: https://www.tp-link.com/us/wifi7/event | Leave me a message with any Urgent Requests, or Simply Feel Left Out
  0  
  0  
#9
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-03-31 14:00:01

  @David-TP 

 

 

I might have found a solution, but I'm not sure. It could be just a glitch.

Under “SIP Proxy” and “Outbound Proxy” I added the SIP address from O2 redundantly. Before, it was left empty (0.0.0.0 or so). Now it works.

There are two possible explanations for this:

1. It fixed the issue (I'm somewhat doubtful about that).

2. By playing around with the SIP registration data I caused a lot of reconnects, until it worked eventually (playing Bingo with the O2 SIP server).

 

The latter would mean that simply retrying the SIP connecting makes it work sooner or later.

 

Unfortunately, the information provided in the SysLog is very scarce. Not even in Debug mode do we get the full picture. In Debug it should give detailed information in plain English, like:

* registering at SIP-server XY, IP address, port - success/failure (reason for failure)

* outgoing call from XY to ZZ

this and that success, then failure: reason for failure

 

 

  2  
  2  
#10
Options
Re:TPlink Archer VR600v V2 shows firmware up-to-date, while newer firmware seems available
2022-04-01 09:39:59

  @David-TP 

 

I'm afraid my attempts to communicate with Abner Zeng, the senior engineer, have failed. Both replying or sending the mail to the TP-link e-mail address that he provided, bounce.

What I received from him was a standardized message that doesn't make much sense in context of this particular problem.

 

So far, calling out still works. I'm still doubtful that this actually fixed the issue, though.

In a forum of the provider (O2 - Telefonica) others reported the same issue, including TP-link customers with different models. One did a factory reset and setup everything from scratch again. It didn't help. Another one reported the same issues on a AVM Fritzbox. I'm not sure if he got it fixed now. Looking into it, however, I got struck by AVM offering A LOT more parameters for tweaking (timings and everything).

 

Here's a new analysis of the problem. The router connects to the O2 SIP server alice (initializes). This is always reported as success. Though sometimes outgoing calls then fail and continue to fail, whereas on other occasions they succeed and continue to succeed. Therefore, this doesn't seem to be an issue of the individual outgoing call, but rather the one connection to the server. Either the server is bogus (could be) and reconnecting eventually picks a different one from the pool or the connection, which is always reported as succeeding, does NOT always succeed.

Does this make sense?

 

  0  
  0  
#11
Options