Paint Your Home in Wi-Fi/ Let's begin on the Deco APP

Paint Your Home in Wi-Fi/ Let's begin on the Deco APP

Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
2022-03-18 10:19:43 - last edited 2022-12-15 10:43:49
Model: Deco  
Hardware Version:
Firmware Version:

This Article replied to:
All Deco models.

 

Recently, we have received some inquiries that the Deco network is green and working fine, but on the Deco APP, it said "Paint Your Home in Wi-Fi and let's begin". It seems the APP does not know the network has been set up already and requires it to be set up again.

It might happen due to the following reasons:

1. You might log into the wrong TP-Link ID.

2. The network was deleted on the Deco APP when Deco was temporarily offline before, such as when Deco APP temporarily said: "We could not find Deco" or Deco was powered off.

3. The password of TP-Link ID has been changed when Deco was temporarily offline.

 

Solution:

Please refer to this link to get more instructions: 

  1. Ensure you have logged in to the Deco app with the original email address that was used to set up Deco (also called owner account).

 

2. Please confirm the smartphone is connected to Deco’s Wi-Fi network. At the same time, disable mobile data and close any VPN application on the phone if you have one.

After that, launch the Deco app and log in again.

 

2.1 If you’re able to log in and see the Deco network

Go to More -> Update Deco. And ensure the Deco system is using the latest firmware. If the “Let’s begin” issue persists with the latest firmware while the phone connects to other networks, please leave me a private message of the MAC address of your main Deco as well as your current TP-Link email ID.

 

2.2 If you’re not able to log in to the Deco app, or Deco APP said" incorrect password".

In this case, you may have lost the original TP-Link account/password used to configure the Deco system. And you need to reset the whole Deco system and set up them again with your current TP-Link account.

 

Related link:

What can I do if the Deco app shows “Let's Begin” while Deco is working well?

How to delete a network on the Deco app?

  1      
  1      
#1
Options
5 Reply
Re:Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
2022-11-14 20:49:15
bapparaj981602@gmail.com
  0  
  0  
#2
Options
Re:Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
2022-11-15 01:43:29

  @bapparaj981602 

Hi, do you have a similar issue mentioned in the post?

Have you tried the suggestions here?

PS: It is suggested to cover your email address for privacy protection.

Thank you very much.

Best regards.

 

  0  
  0  
#3
Options
Re:Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
2023-04-20 09:46:51

  @David-TP 

 

Hi I am having this issue with my Deco x50. I have reset the Main Deco and logged in and out of network. But my Tether App says No Devices Found.

  0  
  0  
#4
Options
Re:Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
2023-04-21 07:40:26

  @Abrar44444 

Hi, I noticed you mentioned Tether, but Deco X50 is supposed to use Deco APP.

Did you install the wrong APP, or it is a typo?

Best regards.

  0  
  0  
#5
Options
Re:Paint Your Home in Wi-Fi/ Let's begin on the Deco APP
2023-09-22 16:07:58

  @bapparaj981602 

Hi All. I had this ame problem of the app not recognizing my already set up network. Doubly annoying as I have a remote network also on the app.

Anyway, I discovered that I was logging in with @googlemail rather than @gmail. 

MAKE SURE YOU USE THE EMAIL YOU ORIGINALY USED TO SET UP ACCOUNT!

 

Russ

 

  0  
  0  
#6
Options

Information

Helpful: 1

Views: 4019

Replies: 5

Related Articles